Microsoft System Center Operations Manager 2007용 Microsoft System Center Configuration Manager 2007 Management Pack 사용자 가이드
참고 항목
System Center Configuration Manager 2007 로고

System Center Operations Manager 2007용 Microsoft System Center Configuration Manager 2007(ConfigMgr) Management Pack은 관리자가 Configuration Manager 2007 서버를 관리하는 데 유용합니다.

최신 관리 팩 및 관리 팩 설명서 가져오기

Configuration Manager 2007 Management Pack은 http://go.microsoft.com/fwlink/?LinkId=103233에서 다운로드할 수 있습니다.

새로운 기능

관리 팩의 변경 내용 목록은 Configuration Manager 2007 Management Pack의 새로운 기능을 참조하십시오.

참고 항목

개념

Configuration Manager 2007용 Management Pack 모니터링 시나리오

기타 리소스

Configuration Manager 2007 Management Pack 개요
Configuration Manager 2007 Management Pack 배포
Configuration Manager 2007 Management Pack의 운영 작업 수행
Configuration Manager 2007 Management Pack 문제 해결
Configuration Manager 2007 Management Pack용 참조


Configuration Manager 2007 Management Pack 개요

이 가이드에서는 Configuration Manager 2007 Management Pack에 대한 배포 및 기술 정보를 제공합니다. 이 정보를 통해 관리 팩의 배포 계획을 세우고, 관리 팩에서 제공하는 기능을 이해하고, 이러한 기능을 IT 조직에 유용하게 활용하는 방법을 이해할 수 있습니다.

System Center Configuration Manager 2007 Management Pack for Operations Manager 2007에서는 다음을 포함하여 Configuration Manager 2007 모니터링을 위한 향상된 기능을 제공합니다.

  • WMI(Windows Management Instrumentation), IIS Admin Service, World Wide Web Publishing 서비스, Windows 배포 서비스 서버, Trivial FTP Daemon, BITS(Background Intelligent Transfer Service), Microsoft SQL Server™ 등의 주요 종속 서비스를 비롯한 모든 Configuration Manager 2007 서비스의 시작 및 중지 모니터링
  • Configuration Manager 2007 관리자에게 중요한 Configuration Manager 2007 상태 메시지 알림
  • 주 사이트 서버와 관리 지점 모두에서 DDR(검색 데이터 기록), 소프트웨어 인벤토리, 하드웨어 인벤토리, 상태 메시지, 상황 메시지 및 소프트웨어 미터링의 백로그 모니터링
  • 사이트 시스템의 발신함 백로그 모니터링
  • 구성 요소 및 사이트 시스템 역할 상태 모니터링
  • 컬렉션 평가, 상황 메시지 요약 및 사이트 유지 관리 작업(사이트 백업 등) 모니터링
  • SMS Executive 크래시 덤프 모니터링
  • 일반 CPU, 메모리 및 디스크 시스템 리소스 사용량 모니터링
  • 처리 속도 모니터링
  • 뷰 및 보고서를 사용하여 여러 Configuration Manager 성능 카운터의 성능 추세 모니터링
  • 모든 경고 및 처리 규칙에 대한 제품 정보 내용
  • 모든 Configuration Manager 2007 컴퓨터, 클래스 및 컴퓨터 그룹 검색
  • Configuration Manager 2007 뷰
  • Configuration Manager 2007 서버 그룹의 성능, 가용성 및 구성을 표시하는 보고서. 이러한 연결된 보고서에는 성능, 구성 및 가용성 추세에 대한 Systems Center Operations Manager 2007의 향상된 보고 기능이 사용됩니다.
  • Configuration Manager 2007 관리자 콘솔 응용 프로그램을 실행하기 위한 작업
  • 모든 Configuration Manager 2007 서버 역할 및 Configuration Manager 2007 클라이언트의 상태가 들어 있는 컴퓨터 상태 뷰
  • 계층 구조의 사이트와 계층 구조 자체의 상태를 표시하기 위한 사이트 계층 구조 및 사이트 상태 뷰
  • 중요한 Configuration Manager 2007 서버 및 Configuration Manager 2007 클라이언트 정보에 대한 서비스 검색
  • Configuration Manager 2007 사이트 계층 구조의 토폴로지 다이어그램
  • Configuration Manager 2007 프로그램 속성을 통해 구성할 수 있는 배포된 프로그램의 오류에 대한 Configuration Manager 2007 알림 기능

모니터링 시나리오 및 기능에 대한 자세한 내용은 Configuration Manager 2007용 Management Pack 모니터링 시나리오를 참조하십시오.

Configuration Manager 2007 Management Pack에서는 다음 작업은 수행할 수 없습니다.

  • System Management Server(SMS) 1.2, SMS 2.0, SMS 2003, 또는 그 이상의 모든 R2 또는 서비스 팩 릴리스에 대한 모니터링
  • SMS와 Configuration Manager의 혼합 환경 모니터링. 혼합 환경은 SMS 1.2, SMS 2.0, SMS 2003 및 Configuration Manager가 함께 설치되어 실행되는 환경입니다. SMS 2003 자식 사이트에서 Configuration Manager 2007 부모 사이트에 보고할 수 있습니다.
  • Configuration Manager 2007 클라이언트를 실행하는 Configuration Manager 2007 클라이언트 전용 컴퓨터에 대한 포괄적인 모니터링
  • 설치된 Configuration Manager 2007을 수정하지 않고 관리하는 기본 모니터링 솔루션 제공. 규칙 임계값은 설치된 Configuration Manager 2007에 따라 다르므로 고객이 규칙을 직접 사용자 지정해야 합니다.

이 섹션에서

Configuration Manager 2007 Management Pack의 새로운 기능

Configuration Manager 2007 Management Pack에 대한 권장 지식

Configuration Manager 2007 Management Pack의 지원되는 구성

참고 항목

개념

Configuration Manager 2007 Management Pack 시작하기
Configuration Manager 2007용 Management Pack 모니터링 시나리오

기타 리소스

Configuration Manager 2007 Management Pack 배포
Configuration Manager 2007 Management Pack의 운영 작업 수행
Configuration Manager 2007 Management Pack용 참조
Configuration Manager 2007 Management Pack 문제 해결


Configuration Manager 2007 Management Pack의 새로운 기능

System Center Configuration Manager 2007 Management Pack for Operations Manager 2007에는 새로운 기능 모니터링뿐만 아니라 새로운 모니터링 메커니즘도 포함되어 있습니다. 사용하지 않는 역할 및 데이터 원본에 대한 모니터링 기능은 제거되었습니다.

Configuration Manager 2007 기능에 대한 추가 지원

Configuration Management 2007 Management Pack에는 다음과 같은 Configuration Manager 2007 기능에 대한 모니터링 기능이 추가되었습니다.

  • 원하는 구성 관리
  • 운영 체제 배포
  • NAP(네트워크 액세스 보호). NAP 모니터링은 Configuration Management 2007 서비스 팩 1 이전 버전에서는 지원되지 않습니다.
  • 장치 관리
  • Wake On LAN
  • VSS 기반 백업
  • 모바일 클라이언트, 분기 및 인터넷 연결 인프라

추가된 SQL Server 가용성 모니터링

이제 Configuration Manager 데이터베이스는 SQL 서버에서 로컬로 모니터링하는 대신 사이트 서버에서 모니터링합니다. 이 모니터링은 SMS Executive 서비스의 스레드인 SMS_DATABASE_NOTIFICATION_MONITOR에서 수행됩니다. SQL 서버 가용성은 가용성 보고서를 사용하여 모니터링할 수 있습니다.

추가된 장치 관리 지점 가용성 모니터링

장치 관리 지점 모니터링은 MP Control Manager가 장치 관리 지점에서 자체 테스트를 수행하도록 지시하는 가상 트랜잭션을 실행함으로써 수행됩니다. 테스트 결과는 역할의 가용성으로 반영되며 경고 및 보고서를 통해 이를 모니터링할 수 있습니다.

추가된 배포 지점 가용성 모니터링

배포 지점 가용성 모니터링은 현재는 분기 배포 지점에 대해서만 사용할 수 있습니다. 역할의 가용성은 Configuration Manager 클라이언트에서 실행되는 BDP 에이전트가 보고합니다.

추가된 소프트웨어 업데이트 지점 가용성 모니터링

소프트웨어 업데이트 지점 가용성은 역할의 상태와 WSUS 서버의 업데이트에 대한 동기화 가능 여부를 반영합니다.

추가된 상태 마이그레이션 지점 가용성 모니터링

상태 마이그레이션 지점 모니터링은 SMP Control Manager가 상태 마이그레이션 지점에서 자체 테스트를 수행하도록 지시하는 가상 트랜잭션을 실행함으로써 수행됩니다. 테스트 결과는 역할의 가용성으로 반영되며 경고 및 보고서를 통해 이를 모니터링할 수 있습니다.

추가된 PXE 서비스 지점 가용성 모니터링

PXE 서비스 지점 모니터링은 PSP Control Manager가 PXE 서비스 지점에서 사이트 데이터베이스에 액세스하도록 지시하는 가상 트랜잭션을 실행함으로써 수행됩니다. 테스트 결과는 역할의 가용성으로 반영되며 경고 및 보고서를 통해 이를 모니터링할 수 있습니다.

추가된 시스템 상태 검사기 가용성 모니터링

시스템 상태 검사기 가용성 및 상태는 시스템 상태 검사기 자체에서 동적으로 보고되며, 경고 및 보고서를 통해 모니터링할 수 있는 현재의 내부 운영 상태를 반영합니다.

추가된 네트워크 부하 분산 관리 지점 가용성 모니터링

NLB(네트워크 부하 분산) 관리 지점에 대한 실제 관리 지점 및 가상 관리 지점 모니터링을 모두 제공하기 위해 관리 지점 Control Manager가 업데이트되었습니다. NLB 가용성 모니터링은 Configuration Manager 2007에서 실제 관리 지점에 대한 모니터링이 수행되는 것과 동일한 방식으로 수행되며, NLB 내의 각 노드 상태도 모니터링됩니다.

추가된 구성 요소 가용성 모니터링

많은 구성 요소가 구성 요소 가용성 상태가 들어 있는 하트비트를 생성하도록 계측되었습니다. 구성 요소 가용성 문제는 경고를 통해 보고됩니다.

추가된 Configuration Manager 작업 모니터링

컬렉션 평가, 상황 메시지 요약 및 백업을 포함한 사이트 유지 관리에 대한 작업은 정기적으로 수행됩니다. 사이트 데이터베이스의 테이블은 확장되었으며 작업 기간 및 상태를 보고하도록 구성 요소가 업데이트되었습니다. 이제 예상보다 오래 실행되거나 실패하는 작업도 보고됩니다.

업데이트된 수신함 파일 수 임계값 규칙

이제 수신함은 관리 팩 성능 카운터를 통해 모니터링됩니다. 이전에는 스크립트에서 이러한 카운터를 모니터링했습니다.

추가된 발신함 모니터링

발신함 모니터는 발신함에 있는 파일 수를 세며 성능 카운터에 의해 보고됩니다.

Operations Manager 콘솔에서 실행되는 업데이트된 Configuration Manager 2007 작업

SMS 2003에서는 SMS 관리자 콘솔을 설치할 때 만들어진 SMS_ADMIN_UI_PATH 환경 변수가 사용자 환경 변수이므로 콘솔을 설치한 사람만이 운영 콘솔에서 SMS 작업을 실행할 수 있었습니다. Configuration Manager 2007에서는 이제 이 환경 변수가 시스템 환경 변수이므로 이러한 제한이 더 이상 적용되지 않습니다. 영향을 받는 작업은 다음과 같습니다.

  • 리소스 탐색기
  • Configuration Manager 콘솔
  • 서비스 관리자
  • 상태 메시지
  • 이제 이러한 작업은 ConfigMgr 서버 클래스 인스턴스의 존재 여부에 관계없이 작업창에서 사용할 수 있습니다.

Configuration Manager 2007의 업데이트된 유지 관리 모드

Operations Manager 유지 관리 모드는 다음과 같은 Configuration Manager 2007 기능에서 활용됩니다.

  • 백업 및 복구
  • 소프트웨어 업데이트 관리
  • 소프트웨어 배포

백업 및 복구 시 여전히 서비스 종료가 수행되지만 서비스가 종료되기 전에 Operations Manager 에이전트가 유지 관리 모드로 전환되므로 관리 팩에서 서비스 모니터링에 대한 사용자 지정 구현이 더 이상 필요하지 않습니다.

업데이트된 Configuration Manager 사이트 계층 구조 다이어그램

Operations Manager(MOM) 2007에서는 SMS 2003의 사이트 계층 구조 다이어그램이 상태를 롤업하도록 업데이트되었습니다. 자세한 내용은 Configuration Manager 2007 Management Pack의 다이어그램을 참조하십시오.

업데이트된 Configuration Manager 보고서

Configuration Manager에는 사이트 시스템 역할을 기준으로 한 성능 카운터와 개체 처리 카운터를 기준으로 한 성능 카운터(예: DDR 관련 카운터)에 중점을 둔 새로운 보고서가 포함되어 있습니다. 새 보고서에 대한 자세한 내용은 Configuration Manager 2007 Management Pack의 보고서를 참조하십시오.

제거된 Configuration Manager 발신자 역할

Configuration Manager 2007에서는 원격 발신자가 더 이상 지원되지 않습니다. 발신자 역할에 대한 관리 팩 지원 기능은 관리 팩에서 제거되었습니다.

제거된 클라이언트 액세스 지점 역할

이 역할은 Configuration Manager 2007에서 제거되었습니다. 이 역할에 대한 모니터링 기능도 상태 탐색기에서 제거되었습니다.

제거된 클라이언트 구성 요청 발신함 모니터링

Configuration Manager 2007 클라이언트 구성 요청 발신함(ccr.box 발신함)의 모니터링은 관리 팩에서 더 이상 지원되지 않으므로 CCR이 더 이상 이 발신함을 통해 전달되지 않습니다.


Configuration Manager 2007 Management Pack에 대한 권장 지식

Configuration Manager 2007 Management Pack을 배포 및 사용하려면 다음 지식과 기술을 갖추고 있는 것이 좋습니다.

  • Operations Manager 2007 모니터링 기능에 대해 알고 있어야 합니다. Operations Manager 2007에 대한 자세한 내용은 Operations Manager 2007 웹 페이지(http://go.microsoft.com/fwlink/?LinkID=83259)를 참조하십시오.
  • Operations Manager 2007 디자인 아키텍처와 조직에 배포된 디자인 아키텍처를 이해해야 합니다.
  • System Center Operations Manager 2007 Deployment Guide에 설명된 대로 관리 팩을 배포하기 위한 권장 절차에 익숙해야 합니다.
  • Configuration Manager 개념 및 용어를 알고 있어야 합니다. Operations Manager 2007에 대한 자세한 내용은 Configuration Manager Documentation Library 웹 페이지(http://go.microsoft.com/fwlink/?LinkId=98803)를 참조하십시오.
  • Configuration Manager 2007의 관리 효율성 및 계측을 이해해야 합니다. Configuration Manager 2007 유지 관리에 대한 자세한 내용은 Maintaining Configuration Manager 2007(http://go.microsoft.com/fwlink/?LinkId=102324) 및 Manageability TechCenter(http://go.microsoft.com/fwlink/?LinkId=102326)를 참조하십시오.

참고 항목

개념

Configuration Manager 2007용 Management Pack 모니터링 시나리오

기타 리소스

Configuration Manager 2007 Management Pack 배포
Configuration Manager 2007 Management Pack의 운영 작업 수행


Configuration Manager 2007 Management Pack의 지원되는 구성

System Center Configuration Manager 2007 및 Systems Center Operations Manager 2007의 요구 사항은 해당 제품의 배포 가이드에 설명되어 있습니다. Configuration Manager 2007 Management Pack에서는 Configuration Manager 2007만 모니터링합니다.

  • Configuration Manager 2007 Management Pack을 설치하기 전에 Operations Manager 2007 MOM 2005 Backward Compatibility MP Update를 설치해야 합니다. OpsMgr 2007 MOM 2005 Backward Compatibility MP Update에 대한 자세한 내용은 다운로드 웹 페이지(http://go.microsoft.com/fwlink/?LinkId=101878)를 참조하십시오.
  • 이 Configuration Manager 2007 Management Pack에서는 System Management Server(SMS) 1.2, SMS 2.0 또는 SMS 2003을 모니터링하지 않습니다.
  • SMS 2003을 모니터링하려면 "Microsoft SMS 2003 Management Pack for Microsoft System Center Operations Manager 2007"(http://go.microsoft.com/fwlink/?LinkId=102297) 또는 "Systems Management Server(SMS) 2003 Management Pack for MOM 2005"(http://go.microsoft.com/fwlink/?LinkId=102297)를 사용하십시오.

참고 항목

기타 리소스

Configuration Manager 2007 Management Pack 개요
Configuration Manager 2007 Management Pack용 참조
Configuration Manager 2007 Management Pack 문제 해결


Configuration Manager 2007 Management Pack 배포

이 단원에서는 Configuration Manager 2007 Management Pack을 배포, 테스트 및 사용자 지정하기 위한 단계를 설명합니다.

이 섹션에서

Configuration Manager 2007 Management Pack 시작하기

Operations Manager 2007 에이전트 배포

Configuration Manager 2007 Management Pack 테스트 및 파일럿 테스트

Configuration Manager 2007 Management Pack 사용자 지정

참고 항목

개념

Configuration Manager 2007 Management Pack의 알려진 문제
Configuration Manager 2007용 Management Pack 모니터링 시나리오

기타 리소스

Configuration Manager 2007 Management Pack 개요


Configuration Manager 2007 Management Pack 시작하기

관리 팩을 가져오기 전에

Microsoft® Configuration Manager 2007 Management Pack을 배포하기 전에 Operations Manager 2007 웹 페이지(http://go.microsoft.com/fwlink/?LinkID=83259)에 있는 Microsoft Operations Manager 2007 Deployment Guide를 검토하십시오. 이 단원에서는 Operations Manager Management Pack을 배포하기 위한 추가 지침을 제공합니다.

Configuration Manager 2007 Management Pack을 배포하려면 다음 절차를 따라야 합니다.

  • 운영 및 조직의 필요에 따라 모니터링 환경을 디자인합니다. 성능 및 척도 요소를 고려합니다. 모든 주 사이트 서버 및 기본 관리 지점을 모니터링하는 것이 좋습니다.
  • 모니터링할 모든 Configuration Manager 2007 서버 구성 요소 컴퓨터에 Operations Manager 2007 에이전트를 배포합니다. 증분 방식이 가장 적절합니다.
  • 모든 에이전트가 정상적인지 확인합니다.
  • 다른 컴퓨터에 프록시를 통해 연결할 수 있도록 Configuration Manager 2007 공급자 및 Configuration Manager 2007 주 사이트 서버에 Configure Operations Manager 2007 에이전트를 구성합니다.
  • Operations Manager 2007 구성 그룹으로 Configuration Manager 2007 Management Pack을 가져옵니다.
  • 권장 테스트 및 파일럿 테스트 작업을 완료합니다.
  • 권장 조정 작업을 완료합니다.

Configuration Manager 2007 Management Pack을 가져오는 방법

관리 팩을 사용하여 Configuration Manager 2007 설치를 모니터링하려면 먼저 관리 팩을 Operations Manager 2007로 가져와야 합니다. 이를 수행하는 방법에 대한 자세한 내용은 Operations Manager 웹 페이지(http://go.microsoft.com/fwlink/?LinkID=98348)의 "How to Import a Management Pack in Operations Manager 2007"을 참조하십시오.

사용자 지정을 위한 새 관리 팩 만들기

대부분의 관리 팩은 관리 팩 파일의 원래 설정을 변경할 수 없도록 봉인되어 있습니다. 그러나 재정의 또는 새 모니터링 개체와 같은 사용자 지정 항목을 만든 다음 이를 다른 관리 팩에 저장할 수는 있습니다. 기본적으로 Operations Manager에서는 모든 사용자 지정 항목을 기본 관리 팩에 저장합니다. 최상의 방법은 사용자 지정할 봉인된 각 관리 팩에 대해 별도의 관리 팩을 만드는 것입니다.

재정의를 저장하기 위한 새 관리 팩을 만들면 다음과 같은 이점이 있습니다.

  • 테스트 및 사전 프로덕션 환경에서 만든 사용자 지정 항목을 프로덕션 환경으로 간단하게 내보낼 수 있습니다. 예를 들어 여러 관리 팩의 사용자 지정 항목이 포함된 기본 관리 팩을 내보내는 대신 단일 관리 팩의 사용자 지정 항목이 포함된 관리 팩을 내보내면 됩니다.
  • 기본 관리 팩을 먼저 삭제하지 않고도 원래 관리 팩을 삭제할 수 있습니다. 사용자 지정 항목이 포함된 관리 팩은 원래 관리 팩에 종속되어 있습니다. 이 종속성으로 인해 사용자 지정 항목이 포함된 관리 팩을 삭제해야 원래 관리 팩을 삭제할 수 있습니다. 모든 사용자 지정 항목이 기본 관리 팩에 저장되어 있는 경우에는 기본 관리 팩을 삭제해야 원래 관리 팩을 삭제할 수 있습니다.
  • 개별 관리 팩의 사용자 지정 항목을 손쉽게 추적하고 업데이트할 수 있습니다.

봉인된 관리 팩과 봉인되지 않은 관리 팩에 대한 자세한 내용은 Management Pack Formats를 참조하십시오. 관리 팩 사용자 지정과 기본 관리 팩에 대한 자세한 내용은 About Management Packs를 참조하십시오.

사용자 지정을 위한 새 관리 팩을 만들려면

  1. 운영 콘솔을 열고 관리 단추를 클릭합니다.

  2. 관리 팩을 마우스 오른쪽 단추로 클릭하고 새 관리 팩 만들기를 클릭합니다.

  3. ConfigMgr 2007 MP 사용자 지정과 같은 이름을 입력하고 다음을 클릭합니다.

  4. 만들기를 클릭합니다.

참고 항목

개념

Operations Manager 2007 에이전트 배포
Configuration Manager 2007 Management Pack 테스트 및 파일럿 테스트
Configuration Manager 2007 Management Pack 사용자 지정


Operations Manager 2007 에이전트 배포

Operations Manager 에이전트는 Operations Manager가 모니터링하는 각 컴퓨터에서 실행됩니다. Configuration Manager 2007 Management Pack에서 모니터링하는 컴퓨터 그룹을 보려면 이 가이드의 Configuration Manager 2007 Management Pack의 컴퓨터 그룹 단원을 참조하십시오. Operations Manager 2007 에이전트는 관리되는 컴퓨터에 대한 모니터링 데이터를 수집하고 수집한 데이터에 규칙을 적용한 다음 결과 데이터를 DCAM(Data Consolidator Agent Manager)에 보냅니다. 에이전트 컴퓨터에 대한 모니터링 기능은 Operations Manager 2007 서비스(HealthService.exe), Operations Manager 2007 호스트(MonitoringHost.exe) 및 에이전트 작업 계정에서 제공합니다.

Operations Manager 2007 에이전트를 배포하려면 Operations Manager 2007 설치 마법사나 Configuration Manager 소프트웨어 배포를 사용합니다. Operations Manager 2007 에이전트 배포 및 Operations Manager 2007 설치 마법사 사용에 대한 자세한 내용은 Microsoft Operations Manager 2007 Deployment Guide의 "Discovering Computers and Deploying Operations Manager Agents"를 참조하십시오. 자세한 내용은 Operations Manager 2007 웹 페이지(http://go.microsoft.com/fwlink/?LinkID=83259)를 참조하십시오.

참고
Operations Manager 2007 에이전트는 Configuration Manager 공급자 컴퓨터에서 LocalSystem 계정이나 Configuration Manager WMI 네임스페이스 루트, root\cimv2, root\sms 및 SMS 레지스트리 키와 하위 키에 액세스하는 데 충분한 권한이 있는 계정을 사용하여 실행하는 것이 좋습니다.

사용자 환경에서 에이전트 없는 모니터링을 사용할 수 있는지 확인하려면 Configuration Manager 2007용 Management Pack 모니터링 시나리오의 "에이전트 없는 모니터링 지원"을 참조하십시오.

로그 기반 규칙을 지원하도록 SMS 환경 변수 정의

Configuration Manager Management Pack의 여러 규칙은 Configuration Manager 기반 로그 파일을 읽고 오류를 검사합니다.

'ConfigMgr 사이트 서버 - 일반' 규칙 그룹의 다음 규칙은 각각 sender.log, distmgr.log 및 policypv.log 파일을 기반으로 합니다.

  • ConfigMgr 2007 구성 요소: 발신자가 LAN(표준 보안)을 통해 원격 사이트에 연결할 수 없음
  • ConfigMgr 2007 구성 요소: 발신자가 RAS 연결을 통해 원격 사이트에 연결할 수 없음
  • ConfigMgr 2007 구성 요소: 발신자가 LAN(고급 보안)을 통해 원격 사이트에 연결할 수 없음
  • ConfigMgr 2007 구성 요소: Distribution Manager가 패키지를 처리하지 못함
  • ConfigMgr 2007 구성 요소: CI_Contents 테이블에 SDM 유형의 콘텐츠가 없어서 Distribution Manager가 SMS 패키지를 삽입하지 못함
  • ConfigMgr 2007 구성 요소: Policy Provider가 SMS 사이트 데이터베이스에서 새 소프트웨어 업데이트 정책을 가져오지 못함
  • ConfigMgr 2007 구성 요소: Policy Provider가 새 소프트웨어 업데이트 정책을 만들지 못함
  • ConfigMgr 2007 구성 요소: Policy Provider가 SMS 사이트 데이터베이스에서 새 호환성 정책을 가져오지 못함
  • ConfigMgr 2007 구성 요소: Policy Provider가 새 호환성 정책을 만들지 못함
  • ConfigMgr 2007 구성 요소: Policy Provider가 Hierarchy Manager에 정책 변경 내용을 알리지 못함

이러한 로그를 모니터링하려면 Configuration Manager 설치 폴더의 위치를 지정해야 합니다. 이를 위해서는 사이트 서버에 %SMS_INSTALL_DIR_PATH% 시스템 환경 변수를 만들어 로컬 시스템 또는 로컬 관리자 사용자 컨텍스트에서 실행되는 MOM 에이전트가 %SMS_INSTALL_DIR_PATH%\Logs 디렉터리의 로그 파일에 액세스할 수 있도록 합니다. 시스템 환경 변수 설정에 대한 자세한 내용은 시스템 환경 변수 웹 페이지(http://go.microsoft.com/fwlink/?LinkId=92316)를 참조하십시오.

Operations Manager 상태 에이전트에서 이 시스템 환경 변수를 사용할 수 있도록 하려면 Configuration Manager 사이트 서버를 다시 시작해야 합니다.

권한이 낮은 시나리오에서 실행할 수 있도록 에이전트 컴퓨터 구성

에이전트 컴퓨터에 대한 모니터링 기능은 Operations Manager 2007 서비스(HealthService.exe), Operations Manager 2007 호스트(MonitoringHost.exe) 및 에이전트 작업 계정에서 제공합니다. Microsoft Windows® 2000에서 에이전트 계정은 로컬 관리자 그룹의 구성원이어야 합니다. Microsoft Windows™ 2003에서는 일부 경우 에이전트의 에이전트 작업 계정에 낮은 권한의 계정을 사용할 수 있습니다. 그러나 Operations Manager 2007 서비스와 Operations Manager 2007 호스트 프로세스가 실행되는 작업 계정 및 사용자 컨텍스트를 Configuration Manager 2007 Management Pack 기능을 실행하는 데 필요한 권한 및 사용 권한으로 구성하려면 에이전트 컴퓨터에서 많은 사항을 수동으로 구성해야 합니다. Microsoft Windows Server™ 2003에서 에이전트 작업 계정에는 최소한 다음과 같은 사용자 권한과 사용 권한이 있어야 합니다.

  • 로컬 사용자 그룹의 구성원
  • Windows 이벤트 로그에 대한 액세스 권한
  • 감사 및 보안 로그 관리 권한(SeSecurityPrivilege)
  • 보안 감사 생성 권한(SeAuditPrivilege)
  • 로컬 로그온 허용 권한(SeInteractiveLogonRight)

권한이 낮은 시나리오에서 Configuration Manager 2007 Management Pack을 실행하려면 에이전트 작업 계정에 사용되는 계정에 추가 권한 및 사용 권한이 있어야 합니다. 다음 표에서는 수동으로 구성해야 하는 액세스 권한에 대해 자세히 설명합니다.

Configuration Manager 2007 Management Pack에 필요한 액세스 유형

리소스 | 액세스 유형 | 지침
Windows 이벤트 로그 | 읽기 | 로컬 또는 글로벌 정책을 사용하여 작업 계정에 감사 및 보안 로그 관리 권한을 부여해야 합니다.
SMS 레지스트리 키 | 읽기 | HKLM\Software\Microsoft\SMS 레지스트리 속성에 작업 계정을 추가하고 모든 하위 키에 상속되는 읽기 권한을 부여합니다.
Win32 서비스 레지스트리 키 | 읽기 | HKLM\System\CurrentControlSet\Services 로컬 사용자 그룹에 작업 계정을 추가합니다.
스크립트 생성 임시 파일 | 읽기 및 쓰기 | 경로는 작업 에이전트에 대한 TMP 변수로 지정됩니다. 로컬 시스템의 경우 %Windir%\Temp입니다. 로컬 사용자 그룹에 작업 계정을 추가합니다.
SMS 로그 파일 | 읽기 | <ConfigMgr 설치 폴더>\Logs 폴더 속성에 작업 계정을 추가합니다.
WMI 네임스페이스 | 읽기 | root 및 root\cimv2 필요한 작업이 없습니다.
SMS WMI 네임스페이스 | 읽기 | 필요한 작업이 없습니다.
SMS WMI 클래스 | 읽기 | SMS_Site SMS_R_System SMS_SiteControlFile SMS_ProviderLocation SMS_SCI_SiteDefinition SMS_SystemResourceList SMS_SystemResourceList SMS_SiteSystemSummarizer 모든 인스턴스의 클래스에 작업 계정을 추가합니다.
기본 인스턴스에 대한 보안 로그인 권한 | 액세스 허가 | 관리되는 SQL Server 컴퓨터의 기본 인스턴스인 경우 작업 계정에 보안 로그인에 대한 액세스 허가 권한을 부여해야 합니다. SQL Server 엔터프라이즈 관리자에서는 instancename\Security\Logins 노드에 작업 계정을 추가합니다.
기본 인스턴스의 마스터 데이터베이스에 대한 액세스 권한(SMS 사이트 데이터베이스를 확인하는 데 필요) | 허용 | 관리되는 SQL Server 컴퓨터의 기본 인스턴스인 경우 작업 계정에 마스터 데이터베이스에 대한 허용 권한을 부여해야 합니다. SQL Server 엔터프라이즈 관리자에서는 instancename\Databases\Master\Users 노드에 작업 계정을 추가합니다. 이 새 사용자와 관련된 모든 기본 권한을 유지합니다.
기본 인스턴스의 SMS 사이트 데이터베이스에 대한 액세스 권한 | 허용 | 관리되는 SQL Server 컴퓨터의 기본 인스턴스인 경우 작업 계정에 SMS 사이트 데이터베이스에 대한 허용 권한을 부여해야 합니다. SQL Server 엔터프라이즈 관리자에서는 instancename\Databases\<SMS site>\Users 노드에 작업 계정을 추가합니다. 이 새 사용자와 관련된 모든 기본 권한을 유지합니다.

참고 항목

개념

Configuration Manager 2007 Management Pack 사용자 지정
Configuration Manager 2007 Management Pack 시작하기
Configuration Manager 2007 Management Pack의 알려진 문제
Configuration Manager 2007 Management Pack 테스트 및 파일럿 테스트

기타 리소스

Configuration Manager 2007 Management Pack 문제 해결


Configuration Manager 2007 Management Pack 테스트 및 파일럿 테스트

Microsoft Operations Manager 2007 Deployment Guide에 설명된 관리 팩을 테스트하기 위한 일반적인 권장 사항 외에도 이 단원에서는 Configuration Manager 2007 Management Pack에 적절한 테스트 작업을 설명합니다. 관리 팩 테스트에 대한 자세한 내용은 Operations Manager 2007 웹 페이지(http://go.microsoft.com/fwlink/?LinkID=83259)를 참조하십시오.

테스트 작업

  • Configuration Manager 2007 컴퓨터 그룹이 Configuration Manager 2007을 실행하는 컴퓨터로 채워져 있는지 확인합니다.
  • 관련 규칙을 사용하도록 설정한 후 Operations Manager 2007의 뷰 및 보고서가 올바르게 작동하는지 확인합니다. 여기에는 Configuration Manager 2007 처리 속도 및 Configuration Manager 2007 백로그와 관련된 뷰가 포함됩니다.
  • 기본적으로 IIS 및 SQL Server Management Pack 등의 다른 관리 팩과 관련된 일부 규칙은 Configuration Manager 2007 Management Pack에서는 사용하지 않도록 설정됩니다. 배포한 추가 관리 팩에 따라 이러한 사용되지 않는 규칙을 검토하여 사용자 환경에서 사용할 규칙을 식별해야 합니다.
  • 기본적으로 에이전트의 CPU, 메모리 및 네트워크 리소스에 주는 영향을 최소화하기 위해 모든 성능 측정 규칙은 사용하지 않도록 설정됩니다. 보다 세부적으로 모니터링하려는 경우 이러한 규칙을 사용하도록 설정할 수 있습니다.
  • Configuration Manager 2007 공급자 컴퓨터 및 Configuration Manager 2007 사이트 서버에서 실행되거나 Configuration Manager 2007 사이트 데이터베이스에 액세스하는 일부 Configuration Manager 2007 스크립트는 에이전트 없는 모드에서는 실행되지 않습니다. Configuration Manager 2007 공급자 및 Configuration Manager 2007 사이트 데이터베이스 서버 컴퓨터 그룹의 모든 컴퓨터가 에이전트에서 관리되는 컴퓨터로 구성되었는지 확인합니다. 또한 이러한 스크립트 중 일부는 프록시 이벤트일 수 있으므로 이러한 에이전트가 프록시를 통해 연결할 수 있도록 구성되었는지 확인합니다.
  • SQL 클러스터를 지원하기 위해 ConfigMgr 사이트 데이터베이스에 대해 실행되는 모든 스크립트는 사이트 서버에서 실행됩니다. 스크립트에서 오류 이벤트 및 경고가 발생하지 않는지 확인합니다.

참고 항목

개념

Configuration Manager 2007 Management Pack 사용자 지정
Operations Manager 2007 에이전트 배포
Configuration Manager 2007 Management Pack의 알려진 문제

기타 리소스

Configuration Manager 2007 Management Pack 문제 해결


Configuration Manager 2007 Management Pack 파일럿 테스트

Microsoft Operations Manager 2007 Deployment Guide에 설명된 관리 팩을 테스트하기 위한 일반적인 권장 사항 외에도 이 단원에서는 Configuration Manager 2007 Management Pack에 적절한 파일럿 테스트 작업을 설명합니다. 관리 팩 테스트에 대한 자세한 내용은 Operations Manager 2007 웹 페이지(http://go.microsoft.com/fwlink/?LinkID=83259)를 참조하십시오.

파일럿 테스트 작업

  • 이전 버전에서 Configuration Manager 2007 Management Pack의 배포 또는 업그레이드 과정이 성공적으로 완료되었는지 확인합니다.
  • 콘솔의 제작 모드를 사용하여 사용자 지정 성능 임계값을 확인하고 사용자 환경에 맞게 편집합니다. 범위를 선택하거나 적절한 규칙을 검색합니다.
  • 성능 규칙이 Operations Manager 2007 성능에 주는 영향을 평가하기 위해 각 단계에서 성능 규칙을 사용하도록 설정합니다.
  • Configuration Manager 2007 컴퓨터 그룹이 Configuration Manager 2007을 실행하는 컴퓨터로 채워져 있는지 확인합니다.
  • 관련 규칙을 사용하도록 설정한 후 Operations Manager 2007의 뷰 및 보고서가 올바르게 작동하는지 확인합니다. 여기에는 Configuration Manager 2007 처리 속도, 처리 합계 및 Configuration Manager 2007 백로그와 관련된 뷰가 포함됩니다.
  • 기본적으로 다른 관리 팩과 관련된 일부 규칙은 사용하지 않도록 설정됩니다. 배포한 추가 관리 팩에 따라 사용되지 않는 규칙을 검토하여 사용자 환경에서 사용할 규칙을 식별해야 합니다.
  • 기본적으로 에이전트의 CPU, 메모리 및 네트워크 리소스에 주는 영향을 최소화하기 위해 일부 성능 규칙은 사용하지 않도록 설정됩니다. 에이전트를 보다 세부적으로 모니터링하려는 경우 이러한 규칙을 사용하도록 설정할 수 있습니다.
  • Configuration Manager 2007 스크립트 오류 이벤트 및 경고가 생성되지 않는지 확인합니다. 이 이벤트는 일반적으로 스크립트의 액세스 권한에 문제가 있음을 나타냅니다.
  • Operations Manager 및 SQL Servers의 크기가 프로덕션 부하에 적절한지 확인합니다.
  • 운영 프로세스 및 직원 요구 사항을 확인합니다.
  • 알림이 제대로 작동하는지 확인합니다.
  • Operations Manager 2007에서 사용하고 있는 권한이 올바르게 실행하는 데 적절하고 과도하지 않은지 확인합니다.
  • 작업 계정 에이전트는 LocalSystem 계정에서만 실행할 수 있습니다. 작업 계정 에이전트가 LocalSystem 권한으로 실행되지 않는 경우 최소 보안 권한을 충족하는지 확인합니다. 자세한 내용은 이 가이드의 Operations Manager 2007 에이전트 배포 단원에 있는 "권한이 낮은 시나리오에서 실행할 수 있도록 에이전트 컴퓨터 구성" 단원을 참조하십시오.
  • Configuration Manager 2007 서버 및 Configuration Manager 2007 클라이언트 역할이 컴퓨터 상태 뷰에 나타나는지 확인합니다. 이러한 각 역할을 호스팅하는 컴퓨터를 클릭하고 해당 속성이 세부 정보 창에 표시되는지 확인합니다.
  • 컴퓨터 상태 뷰에서 ConfigMgr 서버 및 ConfigMgr 클라이언트 인스턴스를 클릭하고 해당 역할이 세부 정보 창에 표시되는지 확인합니다.
  • 컴퓨터 상태 뷰에서 ConfigMgr 서버 및 ConfigMgr 클라이언트 인스턴스를 두 번 클릭하고 해당 속성이 상태 뷰의 세부 정보 창에 표시되는지 확인합니다.
  • 사이트 및 사이트 계층 구조 상태 뷰가 동작하고 있는지 확인합니다.
  • 작업을 클릭하여 Configuration Manager 2007 관리자 콘솔 작업이 작동하는지 확인합니다. 작업이 실행되지 않는 경우 Configuration Manager 2007 관리자 콘솔이 설치되어 있고 로그온한 사용자에게 콘솔 작업을 실행하는 데 충분한 권한이 있는지 확인합니다.
  • 사이트 계층 구조 다이어그램을 확인합니다. Operations Manager 2007 에이전트가 해당 Configuration Manager 2007 공급자에 로컬로 설치된 사이트에 대해 모든 사이트 시스템이 표시되는지 확인합니다. 사이트 시스템이 나타나지 않으면 Configuration Manager 2007 관리자 콘솔에서 사이트 시스템이 사이트별로 검색되고 All Systems 컬렉션에 나타나는지 확인합니다. 또한 각 서버에 대한 FQDN이 입력되었는지 확인합니다.

파일럿 테스트 및 조정 작업을 완료한 후 기본 관리 팩이나 변경 내용을 백업하기 위해 만든 사용자 지정 Configuration Manager 2007 Management Pack을 내보냅니다.

참고 항목

개념

Configuration Manager 2007 Management Pack 사용자 지정
Operations Manager 2007 에이전트 배포
Configuration Manager 2007 Management Pack의 알려진 문제

기타 리소스

Configuration Manager 2007 Management Pack 문제 해결


Configuration Manager 2007 Management Pack 사용자 지정

최적의 모니터링을 위해 조직의 비즈니스 필요에 따라 Configuration Manager 2007 Management Pack을 사용자 지정할 수 있습니다. 기존 규칙이 조직의 필요에 맞지 않는 경우 기존 규칙을 수정하거나 새 규칙을 만듭니다.

참고 Configuration Manager 2007 Management Pack을 변경하기 전에 항상 백업하십시오. Operations Manager 2007의 관리 팩 내보내기 마법사를 사용하면 기본 관리 팩 또는 봉인되지 않은 사용자 지정 관리 팩을 백업할 수 있습니다.

사용자 지정할 수 있는 사항에는 다음이 포함됩니다.

  • 재정의를 사용하여 규칙을 사용 또는 사용하지 않도록 설정
  • 새 규칙 및 모니터 만들기
  • 경고 조건, 경고 심각도 및 경고 제거 수정
  • 모니터의 사용자 지정 임계값 설정. 모든 성능 임계값 모니터를 구성할 수 있습니다. 기본 임계값이 최적이 아닌 경우 불필요한 경고를 받거나, 임계값이 사용자 환경에 비해 너무 높게 설정되어 경고가 생성되지 않을 수 있습니다.
  • 규칙 및 모니터에 대한 재정의를 사용하여 수신함 모니터링 임계값 및 폴링 간격 구성
  • 수신함에 대한 스크립트 기반의 새 사용자 지정 모니터링 이벤트 규칙 추가. 새 수신함 모니터링 규칙을 추가하려면 기본 관리 팩 또는 사용자 지정 관리 팩에서 새 규칙을 만든 다음 스크립트 입력 매개 변수(FileCountThreshold 및 InboxDirectoryName)와 일정에 대한 재정의를 만듭니다.
  • 재정의를 사용하여 성능 측정을 위한 폴링 간격 설정
  • 회사 기술 자료에 내용 추가
  • 규칙 또는 모니터를 변경하거나 규칙 또는 모니터에 새 응답을 추가하여 경고에 대한 응답 사용자 지정
  • 많은 양의 데이터를 생성하며 성능 문제를 초래할 수 있는 에이전트에 대해 성능 측정 규칙을 사용하도록 설정. 잠재적인 성능 영향을 허용할지 여부를 사용자가 결정할 수 있도록 성능 측정 규칙은 기본적으로 사용하지 않도록 설정되어 있습니다. 성능 규칙을 검토하고 소규모 배치에서 이러한 규칙을 사용하도록 설정하면 데이터베이스의 크기를 포함하여 이러한 규칙이 Operations Manager 2007 성능에 주는 영향을 평가할 수 있습니다.
  • 사용자 환경에 적용할 수 있는 규칙 검토. 기본적으로 다른 관리 팩과 관련된 일부 규칙은 사용하지 않도록 설정됩니다. 배포한 추가 관리 팩에 따라 사용되지 않는 규칙을 검토하여 사용자 환경에서 사용할 규칙을 식별해야 합니다.

관리 팩 사용자 지정과 관리 팩 사용자 지정 내용을 내보내는 방법에 대한 자세한 내용은 Operations Manager 2007 웹 페이지(http://go.microsoft.com/fwlink/?LinkId=100980)의 "About Management Packs in Operations Manager 2007" 및 "How to Export Management Pack Customizations" 항목을 참조하십시오.

수신함 모니터링

Operations Manager 2007의 내보내기 마법사를 사용하면 기본 관리 팩 또는 사용자 지정 관리 팩을 추가로 변경하기 전에 변경 내용을 저장할 수 있습니다.

수신함 모니터링 규칙 구성

중앙 사이트, 주 사이트 및 보조 사이트 서버에 이러한 규칙을 배포하려면 관리 팩에서 Microsoft ConfigMgr 2007 사이트 서버 - 일반의 규칙을 기초로 새 규칙을 만들어야 합니다. 그런 다음 이러한 규칙의 대상을 적절한 사이트 서버 클래스로 지정하고 임계값을 수정한 다음 규칙을 사용하도록 설정할 수 있습니다.

  • ConfigMgr 수신함: 수신함 모니터링
  • ConfigMgr 수신함: 수신함 모니터링 스크립트 오류
  • ConfigMgr 수신함: 임계값이 초과됨

ConfigMgr 수신함: 임계값이 초과됨 이벤트 처리 규칙은 ConfigMgr: Monitor Inbox script error 스크립트에서 발생하는 이벤트를 모니터링합니다. 지정된 임계값 개수를 초과하는 각 수신함에 대해 고유한 경고가 생성됩니다.

이 스크립트의 기본 임계값 설정은 한 수신함에 10,000개의 파일입니다. 기본 또는 사용자 지정 관리 팩에서 이 스크립트나 임의의 스크립트 매개 변수에 대해 이 값의 재정의를 만들 수 있습니다. 지정된 값을 초과하면 "임계값이 초과됨" 이벤트가 발생합니다. 올바르게 작동하는 각 프로세스에 대해 서버의 일별 예상 부하를 계산한 다음 허용할 수 있는 버퍼 백분율을 추가하여 임계값 설정을 수정할 수 있습니다. 수신함 모니터링 규칙은 기본적으로 하루에 한 번씩 실행되며 01:00부터 시작하여 매일 15분씩 늦게 실행됩니다. 성능 영향을 최소화하려면 이 간격을 유지하거나 수신함 모니터링 규칙 간에 스크립트가 겹쳐 실행되는 것을 최소화할 수 있도록 조정하는 것이 좋습니다.

다음 표에서는 수신함 모니터링 규칙, 기본 임계값 및 SMS Executive 공급자에서 모니터링되는 수신함의 목록을 보여 줍니다.

SMS Executive 수신함 모니터링

수신함 모니터링 규칙 이름 | 기본 임계값 | 수신함 이름
ConfigMgr 수신함: 수신함 모니터링 스크립트 오류 | 해당 없음 | 해당 없음
ConfigMgr 수신함: 임계값이 초과됨 | 해당 없음 | 해당 없음
ConfigMgr 수신함: <수신함 디렉터리 이름> 모니터링 | 10000 | Inboxes\auth\dataldr.box

수신함 모니터링 이벤트 규칙 재정의 절차

수신함 모니터링 이벤트 규칙을 재정의하려면 먼저 Operations Manager 2007 사이트 서버에서 Microsoft Configuration Manager 2007 Site Servers 유형의 Configuration Manager 2007 사이트 서버 개체를 검색해야 합니다.

수신함 모니터링 이벤트 규칙을 재정의하려면

  1. System Center Operations Manager 2007 콘솔에서 제작을 클릭합니다.

  2. 제작 > 관리 팩 개체 > 규칙으로 이동합니다.

  3. 찾을 대상 텍스트 상자를 사용할 수 없는 경우 보기로 이동한 다음 찾기를 클릭합니다.

  4. 범위 변경을 클릭하고 Microsoft ConfigMgr 2007 사이트 서버의 범위를 클릭합니다.

  5. 수정할 ConfigMgr 수신함 모니터링 이벤트 규칙을 마우스 오른쪽 단추로 클릭하고 규칙 재정의를 선택한 후 다음 유형의 모든 개체: Microsoft ConfigMgr 2007 사이트 서버를 클릭합니다.

  6. 재정의 속성에서 재정의 사용 확인란을 선택하고, 재정의 설정을 True로 설정하여 해당 규칙을 사용하도록 설정하거나 False로 설정하여 해당 규칙을 사용하지 않도록 설정합니다.

  7. 재정의 속성에서 재정의 확인란을 선택하고 재정의 설정을 원하는 값으로 설정합니다. 확인을 클릭합니다. 수정된 임계값이 서버에 배포됩니다.

콘솔 작업을 지원하도록 SMS 관리 UI 변수 정의

Configuration Manager 2007 사이트 서버 또는 관리 UI가 Configuration Manager 2007 관리 작업을 가져온 Operations Manager 2007과 함께 설치되어 있는 경우에는 Operations Manager 콘솔의 작업창에서 다음 Configuration Manager 2007 UI 구성 요소를 실행할 수 있습니다.

  • 리소스 탐색기
  • Configuration Manager 콘솔
  • 서비스 관리자
  • 상태(status) 메시지

이러한 응용 프로그램을 실행하기 위해 SMS_ADMIN_UI_PATH 시스템 환경 변수가 만들어집니다. 이 환경 변수는 기본적으로 Configuration Manager 콘솔이 들어 있는 디렉터리인 [ConfigMgr 설치 경로]\AdminUI\bin\i386을 나타냅니다.

Configuration Manager 2007 규칙 사용

Wake On LAN 기능을 모니터링하는 규칙 및 성능 측정 카운터를 비롯하여 일부 관리 팩 규칙은 기본적으로 사용하지 않도록 설정되어 있습니다. 이러한 규칙을 사용하려면 규칙을 활성화해야 합니다.

  • Configuration Manager 2007 Management Pack에서 기본적으로 사용하지 않도록 설정되어 있는 Wake On LAN 규칙은 다음과 같습니다.
  • ConfigMgr 2007 성능 임계값: 사이트 서버 수신함 WOLCMGR.box의 백로그 > 20(1시간)
  • ConfigMgr 2007 성능 임계값: 사이트 서버 수신함 WOLCMGR.box\data의 백로그 > 100(1시간)
  • ConfigMgr 2007 성능 임계값: SMS Wake On LAN Communication Manager의 실패한 총 패킷 수 > 100(15분)
  • ConfigMgr 2007 성능 임계값: SMS Wake On LAN Communication Manager의 보류 중인 총 요청 수 > 10,000(3시간)
  • ConfigMgr 2007 누락 상태: 패치 관리 동기화 구성 요소가 성공적으로 카탈로그를 다운로드하고 배포 지점을 새 카탈로그 버전으로 업데이트함
참고
"ConfigMgr 2007 누락 상태: 패치 관리 동기화 구성 요소가 성공적으로 카탈로그를 다운로드하고 배포 지점을 새 카탈로그 버전으로 업데이트함" 규칙은 Operations Manager 2007 SP1 이상에서만 지원됩니다.

사용하지 않도록 설정된 관리 팩 규칙을 사용하도록 설정하려면 다음 절차를 따르십시오.

절차

사용하지 않도록 설정된 관리 팩 규칙을 사용하도록 설정하려면

  1. 운영 콘솔에서 제작을 클릭합니다.

  2. 탐색 창에서 제작 > 관리 팩 개체로 이동한 다음 규칙을 클릭합니다.

  3. 규칙 창에서 사용하도록 설정할 규칙을 검색합니다. 찾을 대상 표시줄이 규칙 목록 위에 표시되지 않는 경우 보기로 이동하고 찾기를 클릭합니다.

  4. 사용하도록 설정할 규칙의 규칙 이름을 마우스 오른쪽 단추로 클릭하고 재정의 > 규칙 재정의로 이동한 다음 해당 규칙으로 모니터링할 개체 집합을 클릭합니다.

  5. 사용 속성을 True로 설정하고 사용자 환경에 맞게 임계값을 수정합니다. 확인을 클릭합니다.

참고 항목

개념

Configuration Manager 2007 Management Pack 시작하기
Configuration Manager 2007용 Management Pack 모니터링 시나리오
Configuration Manager 2007 Management Pack의 지원되는 구성
Configuration Manager 2007 Management Pack 테스트 및 파일럿 테스트

기타 리소스

Configuration Manager 2007 Management Pack용 참조
Configuration Manager 2007 Management Pack 문제 해결


Operations Manager 2007과 Configuration Manager 2007 통합

Configuration Manager 2007은 Configuration Manager 관리자 콘솔 구성 요소를 실행하는 Operations Manager 콘솔 작업을 통해 Operations Manager 콘솔과 통합됩니다.

또한 소프트웨어가 배포되고 소프트웨어 업데이트 프로그램이 실행되는 동안 Operations Manager 2007 에이전트를 실행하는 Configuration Manager 클라이언트에서 유지 관리 모드를 설정할 수 있습니다. 사이트 백업 중에도 유지 관리 모드를 설정할 수 있지만 이를 구성할 수는 없습니다.

Operations Manager 2007 콘솔 작업

Configuration Manager 2007 관리자 콘솔 작업을 수행하려면 Operations Manager 2007 운영 콘솔과 동일한 컴퓨터에 Configuration Manager 2007 관리자 콘솔을 설치해야 합니다. 시스템 환경 변수 SMS_ADMIN_UI_PATH는 Configuration Manager 2007 콘솔 프로그램이 들어 있는 폴더의 경로로 정의해야 합니다. 시스템 환경 변수 설정에 대한 자세한 내용은 시스템 환경 변수 웹 페이지(http://go.microsoft.com/fwlink/?LinkId=92316)를 참조하십시오.

Operations Manager 콘솔에서는 다음과 같은 Configuration Manager 2007 작업을 실행할 수 있습니다.

작업 | 설명
ConfigMgr 2007 관리 콘솔 | 현재 선택된 컴퓨터에 대한 Configuration Manager 2007 관리자 콘솔을 엽니다. 이 작업은 Configuration Manager 2007 사이트 서버 역할을 호스팅하는 컴퓨터에 적용됩니다.
모든 ConfigMgr 2007 상태(status) 메시지 | 컴퓨터의 사이트 서버를 확인하고 MMC 창을 연 다음 상태(status) 메시지 쿼리를 실행하여 현재 선택된 컴퓨터와 연관된 모든 상태(status) 메시지를 반환합니다. 이 작업은 모든 시스템에 적용됩니다.
ConfigMgr 2007 서비스 관리자 | 현재 선택된 컴퓨터에 대한 Configuration Manager 2007 서비스 관리자를 엽니다. 이 작업은 Configuration Manager 2007 사이트 서버 역할을 호스팅하는 컴퓨터에 적용됩니다.
ConfigMgr 2007 리소스 탐색기 | 컴퓨터의 사이트 서버를 확인하고 MMC 창을 연 다음 현재 선택된 컴퓨터의 데이터를 이 창의 Configuration Manager 2007 리소스 탐색기에 표시합니다. 이 작업은 모든 시스템에 적용됩니다.

Configuration Manager 2007의 유지 관리 모드

System Center Configuration Manager 2007에서는 소프트웨어 배포 및 소프트웨어 업데이트 기능이 있는 Operations Manager 2007의 유지 관리 모드를 지원합니다. MOM 에이전트를 유지 관리 모드로 전환하면 Configuration Manager 클라이언트를 실행하는 컴퓨터에서 경고가 발생하지 않도록 할 수 있습니다.

Configuration Manager 2007에서 컴퓨터에 소프트웨어를 배포할 때 대상 컴퓨터에서 생성되는 Operations Manager 규칙 기반 경고를 임시로 비활성화해야 할 수 있습니다. 예를 들어 서버에 핫픽스 및 보안 패치를 배포하려면 스레드와 서비스를 종료해야 할 수 있습니다. 관리 팩에서 이러한 서버의 스레드나 서비스를 모니터링할 경우 수많은 Operations Manager 경고가 생성되어 Operations Manager 서버에 걸리는 부하가 커질 수도 있기 때문입니다.

Disable MOM alerts while this program runs 확인란을 선택하면 배포된 소프트웨어가 종료될 때까지 Operations Manager 경고가 생성되지 않습니다. Configuration Manager 2007 관리자는 Configuration Manager 패키지 프로그램 속성에서 이 확인란을 설정할 수 있습니다. 이 옵션을 설정하면 클라이언트 컴퓨터에서 해당 프로그램을 실행하는 동안 클라이언트 컴퓨터를 대상으로 하는 모든 관리 팩에 대해 Operations Manager 경고가 제거됩니다. 허용되는 최대 실행 시간은 유지 관리 모드 기간의 제한 시간으로 사용됩니다.

Configuration Manager 소프트웨어 업데이트에 대한 유지 관리 모드 설정

Configuration Manager 2007에서 배포된 소프트웨어 업데이트는 소프트웨어 업데이트가 클라이언트 컴퓨터에서 실행될 때 경고를 생성할 수 있습니다. 이 계획된 유지 관리에 대한 경고가 발생하지 않도록 하려면 소프트웨어 업데이트 기간 동안 경고를 사용하지 않도록 설정합니다.

소프트웨어 업데이트가 실행되는 동안 Operations Manager 경고를 사용하지 않도록 설정하려면 다음 절차를 수행하십시오.

절차

소프트웨어 업데이트가 실행되는 동안 Operations Manager 경고를 사용하지 않도록 설정하려면

  1. Configuration Manager 2007 콘솔에서 System Center Configuration Manager / Site Database - <사이트 서버 이름> / Computer Management / Software Updates / Deployment Management로 이동합니다.

  2. 업데이트 이름을 마우스 오른쪽 단추로 클릭하고 Properties를 클릭합니다.

  3. Program Properties 대화 상자에서 Event Generation 탭을 클릭합니다.

  4. Disable Operations Manager alerts while software updates run을 선택하고 OK를 클릭합니다.

Configuration Manager 소프트웨어 업데이트에 대해 유지 관리 모드를 설정하면 Configuration Manager 업데이트가 배포 및 실행될 때 클라이언트 컴퓨터가 유지 관리 모드로 설정됩니다.

Configuration Manager 소프트웨어 배포에 대한 유지 관리 모드 설정

Configuration Manager 2007에서 배포된 소프트웨어는 소프트웨어 배포용 소프트웨어 배포 프로그램이 클라이언트 컴퓨터에서 실행될 때 경고를 생성할 수 있습니다. 이 계획된 유지 관리에 대한 경고가 발생하지 않도록 하려면 소프트웨어 배포 프로그램 기간 동안 경고를 사용하지 않도록 설정합니다.

소프트웨어 배포 프로그램이 실행되는 동안 Operations Manager 경고를 사용하지 않도록 설정하려면 다음 절차를 수행하십시오.

절차

소프트웨어 배포 프로그램이 실행되는 동안 Operations Manager 경고를 사용하지 않도록 설정하려면

  1. Configuration Manager 2007 콘솔에서 System Center Configuration Manager / Site Database - <사이트 서버 이름> / Computer Management / Software Distribution / Packages / <패키지 이름> / Program으로 이동합니다.

  2. 세부 정보 창에서 프로그램 이름을 마우스 오른쪽 단추로 클릭하고 Properties를 클릭합니다.

  3. Program Properties 대화 상자에서 MOM Maintenance Mode 탭을 클릭합니다.

  4. Disable Operations Manager alerts while this program runs를 선택하고 OK를 클릭합니다.

Configuration Manager 프로그램에 대해 유지 관리 모드를 사용하도록 설정하면 Configuration Manager 패키지가 배포 및 실행될 때 클라이언트 컴퓨터가 유지 관리 모드로 전환됩니다.

참고
유지 관리 모드의 제한 시간은 Program Properties 대화 상자의 Requirements 탭에서 Maximum allowed runtime 속성을 선택하여 설정합니다.

Configuration Manager 2007 프로그램 오류에 대한 경고 생성

관리자는 Configuration Manager 2007에서 배포된 소프트웨어를 클라이언트 컴퓨터에 설치하지 못한 경우 경고를 표시해야 할 수 있습니다.

소프트웨어 배포 프로그램에 오류가 있는 경우 Operations Manager 경고를 생성하려면 다음 절차를 수행하십시오.

절차

소프트웨어 배포 프로그램에 오류가 있는 경우 Operations Manager 경고를 생성하려면

  1. Configuration Manager 2007 콘솔에서 System Center Configuration Manager / Site Database - <사이트 서버 이름> / Computer Management / Software Distribution / Packages / <패키지 이름> / Program으로 이동합니다.

  2. 세부 정보 창에서 프로그램 이름을 마우스 오른쪽 단추로 클릭하고 Properties를 클릭합니다.

  3. Program Properties 대화 상자에서 MOM Maintenance Mode 탭을 클릭합니다.

  4. Generate Operations Manager alert if this program fails를 선택하고 OK를 클릭합니다.

이 속성을 설정하면 소프트웨어 프로그램을 실행하지 못한 경우 Operations Manager 경고가 발생합니다.

Configuration Manager 2007 프로그램 오류에 대한 경고 생성

관리자는 Configuration Manager 2007에서 배포된 소프트웨어를 클라이언트 컴퓨터에 설치하지 못한 경우 경고를 표시해야 할 수 있습니다.

소프트웨어 배포 프로그램에 오류가 있는 경우 Operations Manager 경고를 생성하려면 다음 절차를 수행하십시오.

절차

소프트웨어 업데이트 설치에 오류가 있는 경우 Operations Manager 경고를 생성하려면

  1. Configuration Manager 2007 콘솔에서 System Center Configuration Manager / Site Database - <사이트 서버 이름> / Computer Management / Software Updates / Deployment로 이동합니다.

  2. 세부 정보 창에서 업데이트 이름을 마우스 오른쪽 단추로 클릭하고 Properties를 클릭합니다.

  3. Program Properties 대화 상자에서 MOM Maintenance Mode 탭을 클릭합니다.

  4. Generate Operations Manager alert when a software update installation fails를 선택하고 OK를 클릭합니다.

이 속성을 설정하면 소프트웨어 업데이트를 설치하지 못한 경우 Operations Manager 경고가 발생합니다.

참고 항목

개념

Configuration Manager 2007 Management Pack의 일별 작업
Configuration Manager 2007 Management Pack의 주별 작업
Configuration Manager 2007 Management Pack의 월별 작업

기타 리소스

Configuration Manager 2007 Management Pack의 운영 작업 수행
Configuration Manager 2007 Management Pack용 참조
Configuration Manager 2007 Management Pack 문제 해결


Configuration Manager 2007용 Management Pack 모니터링 시나리오

Microsoft® System Center Configuration Manager 2007 Management Pack에서는 Configuration Manager 2007 모니터링을 위한 새로운 기능과 향상된 기능을 제공합니다. 다음 단원에서는 Configuration Manager 2007 Management Pack에서 지원하는 주 시나리오와 해당 기능에 대해 설명합니다.

서비스 가용성

서비스 검색

가용성 모니터링

컴퓨터 상태 모니터링

사이트 계층 구조 상태 모니터링

사이트 상태 모니터링

에이전트 없는 모니터링 지원

성능 임계값 모니터링

성능 모니터링

중요한 Configuration Manager 상태 메시지 모니터링

사이트 시스템 상태 모니터링

Executive 크래시 덤프 모니터링

백로그 모니터링

일반 상태 모니터링

Configuration Manager 소프트웨어 업데이트 관리 모니터링

Configuration Manager Site Backup 모니터링

모든 경고에 대한 제품 정보 내용

모든 Configuration Manager 서버 및 클라이언트 역할의 컴퓨터 그룹

확장된 모니터링

소프트웨어 배포 프로그램 실행 상태

Configuration Manager 작업 모니터링

구성 요소 로그 파일 모니터링

Configuration Manager 2007 수신함 모니터링

서비스 가용성

서비스 가용성 시나리오에서는 System Center Operations Manager 2007의 서비스 가용성 기능과 NT 이벤트 시스템 로그의 서비스 제어 관리자 이벤트를 모두 사용하여 Configuration Manager 서비스의 가용성을 모니터링합니다. 서비스 가용성을 모니터링할 경우 생성되는 경고는 다음과 같습니다.

  • Configuration Manager 사이트 시스템에서 Configuration Manager 기반 서비스가 중지될 때의 경고
  • Configuration Manager 사이트 시스템에서 WMI(Windows Management Instrumentation)와 같이 중요한 Configuration Manager 종속 서비스가 중지되거나 시작되지 않을 때의 경고
  • Configuration Manager 사이트 시스템에서 Microsoft SQL Server™, IIS(인터넷 정보 서비스) 및 BITS(Background Intelligent Transfer Service) 등의 다른 Configuration Manager 종속 서비스가 중지되거나 시작되지 않을 때의 경고
  • Configuration Manager Site Backup 서비스가 시작 및 중지될 때의 경고. 이를 통해 백업이 진행되는 기간 동안 모니터링하고 다른 Configuration Manager 서비스의 중지 이벤트를 Configuration Manager Site Backup 서비스에 연결할 수 있습니다.

서비스 검색

서비스 검색은 관리되는 컴퓨터의 데이터, 서버 역할 및 구성 요소를 검색하는 프로세스입니다. 서비스 검색 프로세스에서는 Configuration Manager 서버 및 Configuration Manager 클라이언트에 대한 정보를 반환하며 이 프로세스를 통해 상태 모니터링 뷰에 Configuration Manager 서버 및 Configuration Manager 클라이언트 역할을 표시할 수도 있습니다.

서버 관련 서비스 검색 데이터는 관리 팩이 에이전트에 배포된 후부터 수집되어 System Center Operations 콘솔에 표시되기 시작합니다. 따라서 서비스 검색 데이터가 처음으로 수집되기 전까지는 특정 작업의 역할, 컴퓨터 그룹 및 대상 컴퓨터를 식별해야 하는 기능은 사용할 수 없습니다.

Configuration Manager Management Pack에서는 다음 이벤트 처리 규칙을 사용합니다.

  • ConfigMgr 2007 서비스 검색

이 이벤트 처리 규칙을 사용하여 다음과 같은 적절한 서비스 검색 스크립트를 실행합니다.

  • ConfigMgr 2007 서비스 검색 - 서버
  • ConfigMgr 2007 서비스 검색 - 클라이언트
  • 기본적으로 스크립트는 비동기 시간 제한 공급자를 사용하여 서비스 검색 데이터를 24시간마다 한 번씩 수집합니다.

가용성 모니터링 보고서

Configuration Manager 2007 Management Pack에는 서버 역할의 하트비트를 모니터링하는 다음과 같은 가용성 보고서가 포함되어 있습니다.

  • 서버 가용성
  • 배포 지점 가용성
  • 관리 지점 가용성
  • PXE 서비스 지점 가용성
  • 사이트 서버 가용성
  • 소프트웨어 업데이트 지점 가용성
  • 시스템 상태 검사기 가용성
  • 상태 마이그레이션 지점 가용성
  • 사이트 데이터베이스 서버 가용성

모든 보고서는 OperationsManager 데이터베이스에 대해 실행되며 사용자가 보고 기간을 지정할 수 있습니다.

서버 가용성 보고서에 대한 자세한 내용은 Configuration Manager 2007 Management Pack의 보고서를 참조하십시오.

서버 역할 가용성 모니터링

다음 역할의 가용성이 모니터링됩니다.

  • 관리 지점
  • NLB 관리 지점
  • 장치 관리 지점
  • 시스템 상태 검사기
  • 상태 마이그레이션 지점
  • PXE 서비스 지점
  • 소프트웨어 업데이트 지점
  • 배포 지점
  • 사이트 데이터베이스 서버

구성 요소 가용성 모니터링

다음과 같은 구성 요소의 가용성이 모니터링되며 해당 가용성 상태를 보고하는 정기적인 하트비트가 생성됩니다.

  • Inbox Manager
  • Inbox Monitor
  • Site Component Manager
  • MP Control Manager
  • MP File Dispatch Manager
  • 발신함 모니터
  • WakeOnLan Communication Manager
  • WakeOnLan Manager
  • WSUS Configuration Manager
  • WSUS Sync Manager
  • WSUS Control Manager
  • 데이터베이스 알림 모니터
  • Offer Status Summarizer
  • Component Status Summarizer
  • Site System Status Summarizer
  • Component Monitor
  • 상태 마이그레이션 지점
  • PXE 서비스 지점

컴퓨터 상태 모니터링

컴퓨터 상태 모니터링 프로세스에서는 모든 Configuration Manager 서버 및 클라이언트의 상태를 표 형식으로 보여 줍니다. 서버 역할 및 구성 요소는 서비스 검색을 통해 관리되고 구성 요소 상태는 일련의 규칙 및 모니터를 통해 관리됩니다.

아래 표를 참고하면 Configuration Manager 구성 요소를 모니터링할 때 해당 구성 요소의 상태를 색별로 구분할 수 있습니다.

Configuration Manager 서버 상태 모니터링

ConfigMgr 서버 구성 요소 | 녹색 (성공) | 노랑 (경고) | 빨강 (중요)
SS(사이트 서버) | 예 | 예 | 예
MP(관리 지점) | 예 | 예 | 예
DB(사이트 데이터베이스) | 예 | 예 | 예
DP(배포 지점) | 예 |  | 예
SLP(서버 검색 지점) | 예 |  | 예
RP(보고 지점) | 예 |  | 예
SMP(상태 마이그레이션 지점) | 예 | 예 | 예
PSP(PXE 서비스 지점) | 예 | 예 | 예
FSP(대체 상태 지점) | 예 | 예 | 예
SHV(시스템 상태 검사기) | 예 | 예 | 예
SUP(소프트웨어 업데이트 지점) | 예 | 예 | 예
공급자 |  |  |
성능 | 예 | 예 | 예

Configuration Manager 클라이언트 상태 모니터링

ConfigMgr 클라이언트 구성 요소 | 녹색 (성공) | 노랑 (경고) | 빨강 (중요)
클라이언트 서비스 | 예 |  | 예

사이트 계층 구조 상태 모니터링

사이트 계층 구조 상태 모니터링 프로세스에서는 사이트 계층 구조의 모든 Configuration Manager 2007 관리 시스템 상태를 표 형식으로 보여 줍니다. 시스템 상태는 일련의 규칙 및 모니터를 통해 관리됩니다.

아래 표를 참고하면 Configuration Manager 시스템을 모니터링할 때 해당 시스템의 상태를 색별로 구분할 수 있습니다.

Configuration Manager 사이트 계층 구조 상태 모니터링

ConfigMgr 서버 구성 요소 | 녹색 (성공) | 노랑 (경고) | 빨강 (중요)
가용성 | 예 | 예 | 예
성능 | 예 | 예 | 예

사이트 상태 모니터링

사이트 상태 모니터링 프로세스에서는 Configuration Manager에서 관리하는 모든 서버의 상태를 표 형식으로 보여 줍니다. 사이트 상태는 일련의 규칙 및 모니터를 통해 관리됩니다.

아래 표를 참고하면 Configuration Manager 사이트 상태를 모니터링할 때 해당 사이트의 상태를 색별로 구분할 수 있습니다.

Configuration Manager 사이트 상태 모니터링

ConfigMgr 서버 구성 요소 | 녹색 (성공) | 노랑 (경고) | 빨강 (중요)
가용성 | 예 | 예 | 예
성능 | 예 | 예 | 예

에이전트 없는 모니터링 지원

Configuration Manager Management Pack에서는 에이전트 없는 관리되는 컴퓨터에 대해 아래에 나열된 기능을 제외한 모니터링 기능을 지원합니다.

  • 중요한 Configuration Manager 상태 메시지 모니터링
  • 사이트 시스템 상태 모니터링

위의 기능을 지원하는 스크립트는 다음과 같습니다.

  • ConfigMgr 2007 컬렉션 평가 작업 모니터
  • ConfigMgr 2007 사이트 유지 관리 작업 모니터
  • ConfigMgr 2007 사이트 시스템 요약 작성기 모니터
  • ConfigMgr 2007 SMS Executive 크래시 덤프 모니터
  • ConfigMgr 2007 SMS 상태 메시지 모니터
  • ConfigMgr 2007 상황 메시지 요약 작업 모니터

이러한 스크립트는 로컬로 실행되어야 Configuration Manager 리소스에 액세스할 수 있습니다. 스크립트에서 리소스에 액세스할 수 없으면 스크립트 오류 이벤트 및 경고가 발생합니다.

성능 임계값 모니터링

성능이 저하되면 지연이 발생하고 시간, 성능 및 데이터 정확도 측면에서 고객 SLA(서비스 수준 계약)에 영향을 줄 수 있습니다. 따라서 Configuration Manager 인프라의 중요한 성능 문제를 찾아 해결하는 것이 중요합니다. 성능 임계값 모니터링 프로세스에서는 모니터링되는 조건이 다음과 같은 특정 수준을 초과할 경우 경고를 생성합니다.

  • Configuration Manager 사이트 시스템의 CPU, 페이징 파일 및 메모리와 관련된 컴퓨터 수준의 일반적 상태 메트릭
  • Configuration Manager 사이트 서버 수신함에 있는 Scheduler 작업, 보내기 요청, 소프트웨어 미터링 레코드, DDR(검색 데이터 기록), 소프트웨어 인벤토리 및 하드웨어 인벤토리 레코드와 같은 Configuration Manager 파일의 총 수
  • Configuration Manager 관리 지점 메시지 대기열에 있는 상태 메시지, DDR, 소프트웨어 인벤토리 및 하드웨어 인벤토리와 관련된 Configuration Manager 메시지의 총 수
  • SHV 응답 및 조건
  • SMS 발신함의 파일
  • PSP 요청
  • SMP 총 클라이언트 수 및 디스크 공간
  • WOL 패킷

성능 모니터링

성능 모니터링을 통해 백로그, 처리 속도 및 주요 Configuration Manager 개체의 총 수에 대한 추세를 조사함으로써 손쉽게 문제를 파악하고 미리 해결할 수 있습니다. 성능 추세 분석 프로세스에서는 Operations Manager 2007 뷰 및 보고서를 사용하여 다음과 같은 추세를 시각적으로 모니터링합니다.

  • Configuration Manager 사이트 서버의 Scheduler 작업, 보내기 요청, 소프트웨어 미터링 레코드, DDR, 하드웨어 인벤토리, 소프트웨어 인벤토리, WOL 패킷, 상황 및 상태 메시지와 관련된 수신함의 백로그 파일
  • Configuration Manager 사이트 서버의 Scheduler 작업, 보내기 요청, 소프트웨어 미터링 레코드, DDR, 하드웨어 인벤토리, 소프트웨어 인벤토리, WOL 패킷, SUP 업데이트, 상황 및 상태 메시지 처리 속도
  • Configuration Manager 사이트 서버의 Scheduler 작업, 보내기 요청, 소프트웨어 미터링 레코드, DDR, 하드웨어 인벤토리, 소프트웨어 인벤토리, WOL 패킷, SUP 업데이트, 상황 및 상태 메시지 총 수
  • Configuration Manager 관리 지점 서버 메시지 대기열에 있는 DDR, 하드웨어 인벤토리, 소프트웨어 인벤토리, 소프트웨어 미터링, 상황 및 상태 메시지, 기타 Configuration Manager 개체와 관련된 메시지의 백로그
  • Configuration Manager 관리 지점 서버 메시지 대기열에 있는 DDR, 하드웨어 인벤토리, 소프트웨어 인벤토리, 소프트웨어 미터링, 상황 및 상태 메시지, SDM 패키지 요청, 기타 Configuration Manager 개체의 처리 속도
  • Configuration Manager 관리 지점 서버 메시기 대기열에 있는 DDR, 하드웨어 인벤토리, 소프트웨어 인벤토리, 릴레이, SDM 패키지 요청 및 상태 메시지의 총 수
  • Configuration Manager 사이트 시스템의 CPU, 페이징 파일 및 메모리와 관련된 컴퓨터 수준의 상태 메트릭
  • 실행 중인 Configuration Manager Executive 스레드의 총 수
  • IIS로 보내는 ISAPI 확장 요청의 처리 속도
  • 사이트 시스템의 발신함에 있는 백로그
  • SMS 서버 가용성 요청
  • SHV 조건 및 SoH 요청
  • PSP 요청 처리
  • SMP 클라이언트 상태 처리 및 사용 가능한 디스크 공간
  • Configuration Manager 장치 관리 지점 서버 메시지 대기열에 있는 DDR, 하드웨어 인벤토리, 소프트웨어 인벤토리, 소프트웨어 미터링, 상태 메시지 및 기타 Configuration Manager 개체의 처리 속도

중요한 Configuration Manager 상태 메시지 모니터링

Configuration Manager 인프라에서는 Configuration Manager 상태 메시지를 생성합니다. 중요한 서버 관련 Configuration Manager 상태 메시지를 확인하여 제때에 문제를 해결하는 것은 중요합니다. 이러한 상태 메시지는 일반적으로 Configuration Manager 인프라의 가용성, 성능, 보안, 구성 및 전반적인 상태에 대한 문제를 나타냅니다.

중요한 Configuration Manager 상태 메시지 모니터링 프로세스에서는 Configuration Manager에 영향을 주는 구성 요소 설치, 데이터베이스 연결 및 사이트 연결 등의 중요한 상태 메시지가 검색될 때 경고를 생성합니다. Configuration Manager 사이트 데이터베이스를 30분마다 한 번씩 검사하여 시간 단위로 동기화함으로써 중요한 Configuration Manager 상태 메시지가 있는지 확인합니다.

사이트 시스템 상태 모니터링

Configuration Manager는 한 시간에 한 번씩 Configuration Manager 사이트 시스템을 폴링하는 Site System Status Summarizer를 통해 정기적으로 사이트 시스템의 기본 상태를 모니터링합니다. 이 기능을 제대로 활용하려면 이 상태에 신속하게 대응하여 Configuration Manager 기능이 저하되지 않도록 해야 합니다. 사이트 시스템 상태 모니터링을 통해 Configuration Manager 사이트 시스템의 상태에 영향을 주는 중요한 Configuration Manager 사이트 시스템 요약 작성기 상태가 감지될 때 이를 모니터링하고 경고를 생성할 수 있습니다. 모니터링되는 상태로는 중단된 Configuration Manager 사이트 시스템, 데이터베이스 공간이나 로그 공간이 부족한 SQL Server 및 NTFS 드라이브의 실제 디스크 공간이 부족한 Configuration Manager 사이트 시스템 등의 내용이 포함됩니다.

Executive 크래시 덤프 모니터링

Configuration Manager Executive 서비스 오류는 Configuration Manager 가용성에 영향을 주므로 크래시 덤프가 언제 발생하는지를 알고 근본적인 원인을 조사하는 것이 좋습니다. SMS Executive 서비스에 오류가 있으면 <ConfigMgr 설치 경로>\Logs\CrashDumps 디렉터리에 크래시 덤프 로그 하위 디렉터리가 만들어집니다. 이 하위 디렉터리 생성 작업은 모니터링되며 SMS Executive 서비스에 종속되어 있는 모든 Configuration Manager 서버 역할에 대해 경고가 생성됩니다.

Configuration Manager 2007 SMS Executive 크래시 덤프 모니터 스크립트는 가장 최근의 크래시 덤프만 보고합니다. 이는 마지막 크래시 덤프가 발생한 후 얼마나 오랜 시간이 경과되었는지에 관계없이 스크립트가 처음으로 실행된 때부터 SMS Executive가 제거되었다가 나중에 다시 설치될 때까지 적용됩니다.

관련 규칙은 SMS Executive 기반 Microsoft Configuration Manager 2007 구성 요소 서버 클래스를 대상으로 합니다.

  • ConfigMgr 2007 크래시 덤프: SMS Executive 모니터링

ConfigMgr 2007 크래시 덤프: SMS Executive 모니터링은 60분마다 스크립트를 실행하여 00:10에 동기화합니다. 요약 정보는 이 규칙의 Knowledge 속성 페이지에서 제공됩니다.

  • ConfigMgr 2007 크래시 덤프: SMS Executive 모니터링 스크립트 오류

ConfigMgr 2007 크래시 덤프: SMS Executive 모니터링 스크립트 오류는 발생할 수 있는 스크립트 오류 이벤트를 모니터링하고 이를 알립니다. 여기에는 모든 스크립트 오류를 보고하는 스크립트 오류 이벤트(번호 1102) 하나만 있습니다. 이 경고를 해결할 수 있는 방법에 대한 정보는 이 규칙의 Knowledge 속성 페이지에서 제공됩니다.

  • ConfigMgr 2007 크래시 덤프: SMS Executive 크래시

ConfigMgr 2007 크래시 덤프: SMS Executive 크래시는 크래시 덤프 이벤트를 모니터링하고 이를 알립니다. 이 경고를 해결할 수 있는 방법에 대한 정보는 이 규칙의 Knowledge 속성 페이지에서 제공됩니다.

백로그 모니터링

백로그가 많으면 지연이 발생하여 시간, 성능 및 데이터 정확도 측면에서 고객 SLA에 영향을 줄 수 있습니다. 따라서 Configuration Manager 인프라의 중요한 성능 문제를 신속하게 찾아 해결하는 것이 중요합니다. 백로그가 지정된 기간 동안 다음 항목에 대한 임계값을 초과하면 경고가 생성됩니다.

  • Configuration Manager 사이트 서버 수신함에 있는 Scheduler 작업, 보내기 요청, 소프트웨어 미터링 레코드, DDR, 소프트웨어 인벤토리 및 하드웨어 인벤토리 레코드, WOL 요청, 상황 및 상태 메시지와 같은 Configuration Manager 파일의 총 수
  • Configuration Manager 사이트 서버 대기열에 있는 Scheduler 작업, 보내기 요청, 소프트웨어 미터링 레코드, DDR, 소프트웨어 인벤토리 및 하드웨어 인벤토리 레코드, WOL 요청 및 상태 메시지와 같은 Configuration Manager 개체의 총 수
  • Configuration Manager 관리 지점 메시지 대기열에 있는 상태 메시지, DDR, 소프트웨어 인벤토리 및 하드웨어 인벤토리와 관련된 Configuration Manager 메시지의 총 수
  • 사이트 시스템 발신함에 있는 소프트웨어 미터링 레코드, DDR, 소프트웨어 인벤토리 및 하드웨어 인벤토리 레코드, 상황 및 상태 메시지와 같은 파일의 총 수

일반 상태 모니터링

일반 상태 모니터링 프로세스에서는 일정 기간 동안 Configuration Manager 서버의 상태 메트릭이 특정 임계값을 초과할 경우 경고를 생성합니다. 일반 상태 모니터링 프로세스는 다음 메트릭을 검사합니다.

  • 3시간 동안의 프로세서 시간 95%
    • Smsexec
    • Ccmexec
    • Total
  • 3시간 동안의 페이징 파일 사용률 98%

Configuration Manager 소프트웨어 업데이트 관리 모니터링

Configuration Manager 관리자는 Configuration Manager 소프트웨어 업데이트 관리 기능을 사용하여 기업의 클라이언트 및 서버 컴퓨터를 최신 보안 업데이트와 동기화합니다. 패치 관리 모니터링 프로세스에서는 Configuration Manager 소프트웨어 업데이트 관리 처리 및 구성의 오류를 감지하며 Configuration Manager 소프트웨어 업데이트 관리 모니터링 프로세스에서는 다음과 같은 경우에 경고를 생성합니다.

  • WSUS 서버를 구성할 수 없는 경우
  • Configuration Manager가 WSUS 서버에서 업데이트를 구독할 수 없는 경우
  • Configuration Manager 소프트웨어 업데이트 관리 동기화 프로세스가 실패할 경우
  • Configuration Manager 소프트웨어 업데이트 관리 프로세스에서 Configuration Manager 배포 지점을 업데이트하는 데 실패할 경우

Configuration Manager Site Backup 모니터링

Configuration Manager Backup 시작, 완료 또는 오류 시기를 알고 있으면 Configuration Manager 관리자가 백업 작업을 감사하는 데 유용합니다. Configuration Manager의 데이터, 정책 및 구성 백업을 정기적으로 실행하도록 Configuration Manager Backup 일정을 지정할 수 있습니다.

이 백업 프로세스의 오류를 모니터링하고 수정 작업을 수행하는 것이 좋습니다. Configuration Manager Backup 프로세스는 SMS Site Component Manager와 SMS Executive를 중지 및 시작하므로 이 프로세스가 성공할 경우에도 서비스 가용성에 영향을 줍니다. Configuration Manager Backup을 모니터링하면 백업 중에는 이러한 서비스 중지에 대한 경고가 제거되므로 해당 서비스에서 알려진 중단 시간을 추적할 수 있습니다. Configuration Manager Site Backup 서비스의 모니터링을 지원하는 규칙은 다음과 같습니다.

  • ConfigMgr 2007 상태: 사이트 백업이 성공적으로 완료됨
  • ConfigMgr 2007 상태: 사이트 백업에 실패함
  • ConfigMgr 2007 상태: 현재 백업 작업이 완료되기 전에는 Site Backup 서비스가 백업 프로세스를 시작할 수 없음
  • ConfigMgr 2007 상태: Site Backup 서비스에서 SQL 백업 경로가 비어 있거나 올바르지 않음을 발견함
  • ConfigMgr 2007 서비스 실행 중지: SMS_SITE_BACKUP
  • ConfigMgr 2007 서비스 실행 시작: SMS_SITE_BACKUP
  • ConfigMgr 2007 서비스 오류: SMS_SITE_BACKUP이 예기치 않게 종료됨
  • ConfigMgr 2007 서비스 오류: SMS_SITE_BACKUP이 시작 시 멈춤
  • ConfigMgr 2007 서비스 오류: SMS_SITE_BACKUP을 시작하지 못함
  • ConfigMgr 2007 서비스 오류: SMS_SITE_BACKUP이 로그온할 수 없음
  • ConfigMgr 2007 서비스 오류: SMS_SITE_BACKUP을 실행하는 데 필요한 다른 서비스가 시작되지 않았거나 존재하지 않음

  • ConfigMgr 2007 서비스 실행 중: SMS_SITE_VSS_WRITER
  • ConfigMgr 2007 서비스 오류: SMS_SITE_VSS_WRITER가 예기치 않게 종료됨
  • ConfigMgr 2007 서비스 오류: SMS_SITE_VSS_WRITER가 시작 시 멈춤
  • ConfigMgr 2007 서비스 오류: SMS_SITE_VSS_WRITER를 시작하지 못함
  • ConfigMgr 2007 서비스 오류: SMS_SITE_VSS_WRITER가 로그온할 수 없음
  • ConfigMgr 2007 서비스 오류: SMS_SITE_VSS_WRITER를 실행하는 데 필요한 다른 서비스가 시작되지 않았거나 존재하지 않음

모든 경고에 대한 제품 정보 내용

관리자는 모든 경고에 대한 제품 정보 내용을 참조하여 문제를 명확하게 파악하고 해결할 수 있습니다. 제품 정보 내용에 액세스하려면 규칙 이름을 마우스 오른쪽 단추로 클릭하고 속성을 클릭한 다음 제품 정보 탭을 클릭합니다.

모든 Configuration Manager 서버 및 클라이언트 역할의 컴퓨터 그룹

컴퓨터 그룹은 특정 Configuration Manager 서버 및 클라이언트 역할에 매핑됩니다. 규칙 및 모니터 대상은 마찬가지로 Configuration Manager 서버 및 클라이언트 역할에 매핑되는 클래스를 기반으로 지정됩니다. 이를 통해 관리자는 적절한 수준의 제어 권한으로 관리 팩 규칙의 대상을 지정할 수 있습니다.

확장된 모니터링

Configuration Manager Management Pack에 제공된 규칙은 SQL Server, IIS, BITS, Windows 운영 체제, WMI, WSUS, Windows 배포 서비스 및 Trivial FTP 등의 종속 기술에 대한 기본 서비스, 성능 측정 및 성능 임계값 모니터링을 다룹니다. 이러한 지원 기능 중 일부는 기본적으로 사용할 수 없도록 설정되어 있습니다. Configuration Manager Management Pack의 제한된 이 지원 기능을 활성화하여 사용할 수는 있지만 이러한 특정 제품을 위한 관리 팩을 가져와서 사용하는 것도 좋습니다.

  • Configuration Manager 사이트 데이터베이스 서버, 복제된 사이트 데이터베이스가 있는 관리 지점 및 SQL Server 종속성이 있는 소프트웨어 업데이트 지점의 모니터링을 확장하려면 SQL Server Management Pack을 사용합니다.
  • 보고 지점, 관리 지점, 서버 검색 지점, 상태 마이그레이션 지점 및 대체 상태 지점에서 IIS를 모니터링하려면 IIS Management Pack을 사용합니다. IIS Management Pack을 사용하면 BITS를 사용하는 배포 지점을 모니터링할 수도 있습니다.
  • CPU, 디스크 및 메모리 통계와 같은 기본 Windows 구성 요소를 모니터링하려면 Microsoft Windows Operating System Management Pack을 사용합니다.

Configuration Manager 2007 Management Pack에서 관련 규칙을 제공하지 않고 Configuration Manager 인프라의 모니터링을 향상시키는 다른 관리 팩도 있습니다.

  • 확장성을 이유로 네트워크 부하 분산을 사용하여 Configuration Manager 계층 구조의 여러 관리 지점을 지원하는 경우 Windows Network Load Balancing Management Pack을 사용합니다.
  • Active Directory 인프라의 상태를 모니터링하려면 Windows Active Directory® Management Pack을 사용합니다.

사용자 환경에 관리 팩을 여러 개 배포할 경우 각 관리 팩의 규칙에 따라 같은 경고를 중복하여 받을 수 있습니다. 중복 모니터링 규칙을 사용하지 않도록 설정하면 배포된 관리 팩의 상태 뷰 정확도에 영향을 줄 수 있습니다. 따라서 중복 경고를 받을 것인지 배포한 각 관리 팩에 대해 상태 모니터링 작업을 수행할 것인지 신중하게 고려해야 합니다. 배포한 추가 관리 팩에 따라 이러한 중복 규칙을 검토하여 사용자 환경에서 사용할 규칙을 식별해야 합니다. 이러한 관리 팩을 설치한 후에는 관리 팩이 필요에 맞게 사용자 지정되고, 올바르게 구성되고, 적절한 규칙이 설정되었는지 확인합니다.

소프트웨어 배포 프로그램 실행 상태

Configuration Manager 클라이언트에서는 관리 팩을 통해 프로그램 오류를 보고할 수 있습니다.

관리자는 Program Properties 대화 상자의 MOM Maintenance Mode 탭에 있는 Generate Operations Manager alert if this program fails 확인란을 선택할 수 있습니다.

절차

Configuration Manager 2007 프로그램이 실행되지 않을 경우 Operations Manager 2007 경고를 사용하도록 설정하려면 다음 단계를 수행해야 합니다.

Configuration Manager 프로그램에 대한 Operations Manager 2007 경고를 사용하도록 설정하려면

  1. Configuration Manager 콘솔에서 Systems Center Configuration Manager / Site Database - <사이트 서버 이름> / Computer Management / Software Distribution / Packages / <패키지 이름> / Programs로 이동합니다.

  2. 세부 정보 창에서 프로그램을 마우스 오른쪽 단추로 클릭하고 Properties를 선택합니다.

  3. MOM Maintenance Mode 탭을 클릭합니다.

  4. Generate Operations Manager alert if this program fails to run 확인란을 선택합니다. OK를 클릭합니다.

ConfigMgr 작업 모니터링

컬렉션 평가, 상황 메시지 요약 및 사이트 유지 관리와 같이 ConfigMgr 사이트 데이터베이스에 대해 실행되는 작업은 모두 완료 상태 및 기간이 모니터링됩니다. 작업에 실패하거나 실행 시간이 예상 최대 기간을 초과할 경우 경고가 발생합니다.

구성 요소 로그 파일 모니터링

다음 규칙은 sender.log, distmgr.log 및 policypv.log 파일의 모니터링을 기반으로 합니다.

  • SMSv4 구성 요소: 발신자가 LAN(표준 보안)을 통해 원격 사이트에 연결할 수 없음
  • SMSv4 구성 요소: 발신자가 RAS 연결을 통해 원격 사이트에 연결할 수 없음
  • ConfigMgr 2007 구성 요소: 발신자가 LAN(고급 보안)을 통해 원격 사이트에 연결할 수 없음
  • ConfigMgr 2007 구성 요소: Distribution Manager가 패키지를 처리하지 못함
  • ConfigMgr 2007 구성 요소: CI_Contents 테이블에 SDM 유형의 콘텐츠가 없어서 Distribution Manager가 SMS 패키지를 삽입하지 못함
  • ConfigMgr 2007 구성 요소: Policy Provider가 SMS 사이트 데이터베이스에서 새 소프트웨어 업데이트 정책을 가져오지 못함
  • ConfigMgr 2007 구성 요소: Policy Provider가 새 소프트웨어 업데이트 정책을 만들지 못함
  • ConfigMgr 2007 구성 요소: Policy Provider가 SMS 사이트 데이터베이스에서 새 호환성 정책을 가져오지 못함
  • ConfigMgr 2007 구성 요소: Policy Provider가 새 호환성 정책을 만들지 못함
  • ConfigMgr 2007 구성 요소: Policy Provider가 Hierarchy Manager에 정책 변경 내용을 알리지 못함

Configuration Manager 2007 수신함 모니터링

Configuration Manager 2007은 수신함의 파일을 읽고 수신함의 파일에 쓰는 방법으로 대부분의 서버 쪽 주요 작업을 수행합니다. Configuration Manager 2007 수신함이 비정상적으로 가득 차면 이는 Configuration Manager 2007의 처리 속도가 저하되었음을 나타냅니다. 여기에는 잘못된 파일, 중지된 프로세스, 디스크 공간 부족, 비정상적인 소프트웨어 배포 작업 등의 다양한 원인이 있을 수 있습니다. 이러한 문제는 드물지만 사이트 수가 상당히 많은 고객에게는 심각한 문제입니다.

SMS Executive 서비스의 스레드로 실행되는 수신함 모니터는 디스크에서 처리되기를 대기하고 있는 실제 항목 수가 아니라 서비스 구성 요소에서 대기열에 넣은 항목 수를 모니터링합니다.

모든 규칙은 이러한 규칙의 대상을 중앙 사이트, 주 사이트 및 보조 사이트로 지정하는 ConfigMgr 2007 사이트 서버 – 일반 처리 설치 클래스에 있습니다.

일정 및 선택적 구성

수신함 모니터링의 성능 영향을 최소화하기 위해 관련 규칙이 하루에 한 번씩 실행하도록 동기화됩니다. 규칙은 오전 1시부터 시작하여 15분 간격으로 실행되므로 한 번에 하나의 규칙만 실행됩니다. 예를 들어 첫 번째 규칙은 오전 1시에 첫 번째 수신함에 있는 파일 수를 계산하고 두 번째 규칙은 오전 1시 15분에 두 번째 수신함에 있는 파일 수를 계산합니다. 이런 식으로 모든 수신함의 파일 수가 계산됩니다.

Operations Manager 2007에서 실행할 규칙 스크립트의 일정을 지정할 때 수행하는 일반적인 단계에 따라 이 일정을 수정할 수 있습니다. 이 기능을 활성화하는 데 필요한 초기 구성은 없습니다. 다음은 수행 가능한 선택적 구성 변경 작업입니다.

  • 각 수신함의 기본 임계값을 변경합니다.
  • 개별 수신함 규칙의 일정을 변경합니다.

이러한 선택적 구성 변경은 관리 팩에서 임계값 이벤트 규칙을 구성하는 일반적인 단계에 따라 수행할 수 있습니다.

임계값 경고 및 값

모니터링 규칙이 처리될 때마다 특정 수신함 규칙에 대해 구성된 임계값에 도달하면 하나의 경고가 생성됩니다.

성능 임계값을 편집하려면

  1. Operations Manager 2007 관리자 콘솔에서 제작을 클릭합니다.

  2. 제작 창에서 제작 > 관리 팩 개체 > 모니터로 이동합니다.

  3. 모니터 창에서 ConfigMgr server를 찾습니다.

  4. ConfigMgr Server > Entity Health > Availability로 이동하고 다음 서버 역할 중 편집할 서버 역할 하나를 확장합니다.

    • DB - 데이터베이스 서버
    • DP - 배포 지점
    • FSP - 대체 상태 지점
    • MP - 관리 지점 서버
    • PSP - PXE 서비스 지점
    • SS - 사이트 서버
    • 공급자 - 공급자
    • RP - 보고 지점
    • SHV - 시스템 상태 검사기
    • SLP - 서버 검색 지점
    • SMP - 상태 마이그레이션 지점
    • SUP - 소프트웨어 업데이트 지점

  5. 성능을 편집하려는 모니터를 마우스 오른쪽 단추로 클릭하고 재정의 > 모니터 재정의로 이동한 다음 재정의의 영향을 받는 개체 범주를 클릭합니다.

  6. 확인란을 선택하여 사용자 환경에 맞게 모니터의 재정의 속성을 구성합니다. 확인을 클릭합니다.

수신함 폴더와 Configuration Manager에서 이러한 폴더를 사용하는 방법에 대한 자세한 내용은 "Inbox Folders in Configuration Manager 2007" 웹 페이지(http://go.microsoft.com/fwlink/?LinkId=99539)를 참조하십시오.

참고 항목

기타 리소스

Configuration Manager 2007 Management Pack 배포
Configuration Manager 2007 Management Pack용 참조


Configuration Manager 2007 Management Pack의 운영 작업 수행

모든 경고를 신속하게 검토하고 해결하여 중요하거나 중요할 수 있는 특성을 식별하는 것이 좋습니다. 그 밖에도 다른 작업을 사용자 환경에 따라 정기적으로 수행해야 합니다. 중요한 많은 문제는 경고를 발생시키지 않지만 이 경우에도 정기적으로 확인해야 합니다. System Center Configuration Manager 2007 Management Pack에는 시간 경과에 따라 데이터를 표시하고 문제를 나타내는 패턴을 보여 주는 뷰와 보고서가 포함되어 있습니다. 문제로 인해 경고가 생성되기 전에 뷰와 보고서를 검토하여 문제를 해결해야 합니다.

이 단원에 지정된 대로 일별, 주별 및 월별 작업을 수행하되 이러한 작업을 수행하는 빈도는 특정 사용자 환경에 맞게 조정해야 합니다.

Configuration Manager 2007 유지 관리에 대한 자세한 내용은 "Maintaining Configuration Manager 2007(http://go.microsoft.com/fwlink/?LinkId=102324)을 참조하십시오. 사이트 유지 관리에 대한 자세한 내용은 "Overview of Site Maintenance"(http://go.microsoft.com/fwlink/?LinkId=102325)를 참조하십시오.

이 섹션에서

Configuration Manager 2007 Management Pack의 일별 작업

Configuration Manager 2007 Management Pack의 주별 작업

Configuration Manager 2007 Management Pack의 월별 작업

참고 항목

개념

Configuration Manager 2007용 Management Pack 모니터링 시나리오
Operations Manager 2007과 Configuration Manager 2007 통합

기타 리소스

Configuration Manager 2007 Management Pack 개요
Configuration Manager 2007 Management Pack 배포
Configuration Manager 2007 Management Pack의 운영 작업 수행
Configuration Manager 2007 Management Pack용 참조
Configuration Manager 2007 Management Pack 문제 해결


Configuration Manager 2007 Management Pack의 일별 작업

다음 작업은 매일 수행하는 것이 좋습니다.

  • 컴퓨터 그룹 구성원 자격 검토
  • 모든 Operations Manager 2007 에이전트가 Operations Manager 2007 서버와 통신하고 있는지 확인
  • 사이트 계층 구조 상태 뷰 검토
  • 사이트 상태 뷰 검토
  • 사이트 계층 구조 다이어그램 검토
  • 열린 모든 경고 검토. 뷰 또는 다이어그램에서 상태 탐색기를 사용하여 드릴다운합니다.
  • 성능 백로그 검토
  • 성능 처리 속도 검토
  • Operations Manager 2007 에이전트 및 서버 성능 검토
  • ConfigMgr 사이트 백업이 매일 수행되는 경우 백업 상태 및 백업 파일 검토
  • 이벤트 검토(선택적)

열린 모든 경고 검토

Configuration Manager 2007 Management Pack의 많은 경고는 다음과 같은 경고 설명 형식으로 표시됩니다.

$Computer$ <Rule Name>

$Description$

Event details

Operations Manager 2007의 모든 경고를 검토하여 경고가 제때에 처리되도록 해야 합니다. 다음 중 원하는 방법을 사용하여 열린 경고를 검토할 수 있습니다.

  • 운영 콘솔에서 모니터링 단추를 클릭하고 Microsoft System Center Configuration Manager 2007을 확장한 다음 경고를 클릭합니다.
  • 운영 콘솔에서 모니터링 단추를 클릭하고 Microsoft System Center Configuration Manager 2007을 확장한 다음 일반을 클릭합니다. 최근 72시간 동안 새로 발생한 경고를 선택합니다.
  • 제작 모드를 클릭하고 그룹을 선택하면 컴퓨터 또는 컴퓨터 그룹별로 경고를 볼 수 있습니다. 검사할 Configuration Manager 2007 컴퓨터 그룹을 마우스 오른쪽 단추로 클릭하고 상태 뷰를 선택한 다음 열린 경고를 선택합니다.
  • 컴퓨터 상태 뷰를 통해 경고를 볼 수 있습니다. 이 뷰에는 컴퓨터 및 해당 컴퓨터의 검색된 클래스 목록이 표시됩니다. 컴퓨터를 마우스 오른쪽 단추로 클릭하고 Open Alerts View를 선택하여 심각도별로 우선 순위가 지정된 현재 경고 목록을 가져옵니다.
  • 사이트 상태 뷰를 통해 경고를 볼 수 있습니다. 사이트 상태 뷰에는 사이트 및 해당 사이트의 검색된 클래스 목록이 표시됩니다. 사이트를 마우스 오른쪽 단추로 클릭하고 Open Alerts View를 선택하여 심각도별로 우선 순위가 지정된 현재 경고 목록을 가져옵니다.
  • 사이트 계층 구조 상태 뷰를 통해 경고를 볼 수 있습니다. 사이트 계층 구조 상태 뷰에는 사이트 계층 구조 및 해당 계층 구조에서 검색된 클래스가 표시됩니다. 계층 구조 인스턴스를 마우스 오른쪽 단추로 클릭하고 Open Alerts View를 선택하여 심각도별로 우선 순위가 지정된 현재 경고 목록을 가져옵니다.
  • 사이트 계층 구조 다이어그램 뷰를 통해 경고를 볼 수 있습니다. 사이트 계층 구조 다이어그램 뷰에는 Configuration Manager 2007 사이트 계층 구조가 시각적으로 표시됩니다. 다이어그램에 표시된 개체를 마우스 오른쪽 단추로 클릭하고 Open Alerts View를 선택하여 심각도별로 우선 순위가 지정된 현재 경고 목록을 가져옵니다.

다음 순서로 모든 새 경고를 검토하는 것이 좋습니다.

  1. Configuration Manager 2007 설치 실패 경고
  2. Configuration Manager 2007 핵심 서비스 경고
  3. Configuration Manager 2007 종속 서비스 경고
  4. Configuration Manager 2007 스크립트 오류 경고
  5. Configuration Manager 2007 서버 역할 경고
  6. Configuration Manager 2007 구성 요소 경고
  7. Configuration Manager 2007 Site System Status Summarizer 기반 경고
  8. Configuration Manager 2007 상태(status) 메시지 기반 경고
  9. Configuration Manager 2007 성능 임계값 경고
  10. Configuration Manager 2007 수신함 모니터링 경고
  11. Configuration Manager 2007 발신함 모니터링 경고
  12. Configuration Manager 2007 작업 모니터링 경고
  13. Configuration Manager 2007 Site Backup 서비스 실패 경고
  14. Configuration Manager 2007 프로그램 실패 경고

컴퓨터 그룹 구성원 자격 검토

Operations Manager 2007을 사용하여 컴퓨터 그룹 구성원 자격을 확인할 수 있습니다.

운영 콘솔에서 제작 단추를 클릭하고 그룹을 클릭한 다음 적절한 Microsoft Configuration Manager 2007 컴퓨터 그룹을 마우스 오른쪽 단추로 클릭합니다. 표시된 각 컴퓨터 그룹에 올바른 컴퓨터가 포함되어 있는지 확인합니다.

에이전트가 Operations Manager 2007 서버와 통신하는지 확인

에이전트와 모니터링 인프라 간의 통신에 실패할 경우 사용자에게 경고가 표시되지 않습니다. 에이전트와 Operations Manager 2007을 실행하는 서버가 통신하고 있는지 확인하려면 컴퓨터 상태 뷰에서 Configuration Manager 서버 상태가 회색으로 표시되지 않는지 확인합니다.

성능 백로그 및 성능 처리 속도 검토

성능 백로그와 성능 처리 속도는 일별 추세를 파악하고 Configuration Manager 계층 구조에서 발생하는 사항을 이해하는 데 매우 유용합니다. 성능 백로그와 성능 처리 속도는 Operations Manager 2007에서 볼 수 있습니다.

성능 백로그를 검토하려면

성능 백로그를 검토하려면 다음 단계를 수행하십시오.

성능 백로그를 검토하려면

  1. 운영 콘솔에서 모니터링 단추를 클릭하고 Microsoft System Center Configuration Manager 2007을 확장합니다.

성능을 확장하고 백로그를 확장합니다. 그런 다음 적절한 서버 역할 하위 폴더 및 뷰를 클릭합니다. 표시 단추를 클릭하여 카운터 그래프에 표시할 컴퓨터를 지정합니다.

성능 처리 속도를 검토하려면

성능 처리 속도를 검토하려면 다음 단계를 수행하십시오.

성능 처리 속도를 검토하려면

  1. 운영 콘솔에서 모니터링 단추를 클릭하고 Microsoft System Center Configuration Manager 2007을 확장합니다.

  2. 성능을 확장하고 처리 속도를 확장합니다. 그런 다음 적절한 서버 역할 하위 폴더 및 뷰를 클릭합니다. 표시 확인란을 클릭하여 카운터 그래프에 표시할 컴퓨터를 지정합니다.

성능 조건을 검토하려면

성능 조건을 검토하려면 다음 단계를 수행하십시오.

성능 조건을 검토하려면

  1. 운영 콘솔에서 모니터링 단추를 클릭하고 Microsoft System Center Configuration Manager 2007을 확장합니다.

  2. 성능을 확장하고 조건을 확장합니다. 그런 다음 적절한 서버 역할 하위 폴더 및 뷰를 클릭합니다. 표시 확인란을 선택하여 카운터 그래프에 표시할 컴퓨터를 지정합니다.

Configuration Manager 2007 백업 모니터링

Configuration Manager 2007 Site Backup 서비스 유지 관리 작업을 사용할 수 있도록 설정하고 엔터프라이즈 환경에서 필요한 대로 백업 일정을 세워야 합니다. Configuration Manager Site Backup 프로세스에서는 VSS를 지원하지만 다음 프로세스 중에는 런타임 백업을 지원하지 않습니다.

  • Configuration Manager 설치 폴더의 일부를 백업 내보내기 경로에 복사하고 있는 경우
  • 다양한 Configuration Manager 레지스트리 값을 백업하고 있는 경우
  • Microsoft SQL Server™를 실행하는 서버에서 Configuration Manager 사이트 데이터베이스를 백업하고 있는 경우

백업이 완료되면 Configuration Manager Site Backup 서비스에서 SMS 서비스를 다시 시작합니다. 이러한 서비스 중지 및 시작은 백업 프로세스에서 정상적인 과정이며 중요한 오류를 나타내는 것이 아닙니다. 백업 과정에서는 MOM 에이전트가 중지되어 에이전트 유지 관리 모드에 놓이게 되므로 중지된 서비스에서 정상적으로 발생하는 경고가 Configuration Manager Site Backup 중에는 발생하지 않습니다. 사이트의 시작 및 완료를 연결하려면 다음 규칙을 사용하도록 설정해야 합니다. 이렇게 하면 SMS Site Backup 서비스가 시작되거나 중지될 때 다음과 같은 정보 알림이 발생합니다.

  • ConfigMgr 2007 서비스 실행 중지: SMS_SITE_BACKUP
  • ConfigMgr 2007 서비스 실행 시작: SMS_SITE_BACKUP

Configuration Manager Site Backup 서비스가 시작되지 않거나 예기치 않게 중지되면 다음 경고가 발생합니다.

  • ConfigMgr 2007 서비스 오류: SMS_SITE_BACKUP이 예기치 않게 종료됨
  • ConfigMgr 2007 서비스 오류: SMS_SITE_BACKUP이 시작 시 멈춤
  • ConfigMgr 2007 서비스 오류: SMS_SITE_BACKUP을 시작하지 못함
  • ConfigMgr 2007 서비스 오류: SMS_SITE_BACKUP이 로그온할 수 없음
  • ConfigMgr 2007 서비스 오류: SMS_SITE_BACKUP을 실행하는 데 필요한 다른 서비스가 시작되지 않았거나 존재하지 않음

서비스가 예기치 않게 종료되었음을 나타내는 경고가 표시되면 중지된 서비스가 모두 다시 시작되었는지 확인하십시오. 이러한 서비스가 다시 시작되기 전에 Configuration Manager Site Backup 서비스가 종료되었을 수 있습니다.

백업 프로세스의 성공/실패 여부를 표시하기 위해 다음 상태(status) 메시지 경고가 생성됩니다.

  • ConfigMgr 2007 상태: 사이트 백업이 성공적으로 완료됨
  • ConfigMgr 2007 상태: 사이트 백업에 실패함
  • ConfigMgr 2007 상태: 현재 백업 작업이 완료되기 전에는 Site Backup 서비스가 백업 프로세스를 시작할 수 없음
  • ConfigMgr 2007 상태: Site Backup 서비스에서 SQL 백업 경로가 비어 있거나 올바르지 않음을 발견함

액세스 문제, 디스크 공간 부족, 특정 서비스 시작 또는 중지 오류, SQL Server 작업의 오류가 있으면 오류 경고가 발생할 수 있습니다.

이벤트 검토

이벤트는 중요하지 않은 오류를 나타내며 이를 통해 Operations Manager 2007 에이전트의 작동 방식을 살펴볼 수 있으므로 정기적으로 이벤트를 검토하는 것이 좋습니다.

이벤트를 검토하려면

이벤트를 검토하려면 다음 단계를 수행하십시오.

이벤트를 검토하려면

  1. 운영 콘솔에서 모니터링 단추를 클릭합니다.

  2. Microsoft System Center Configuration Manager 2007을 확장하고 이벤트를 클릭합니다.

참고 항목

개념

Operations Manager 2007과 Configuration Manager 2007 통합
Configuration Manager 2007용 Management Pack 모니터링 시나리오

기타 리소스

Configuration Manager 2007 Management Pack용 참조
Configuration Manager 2007 Management Pack 문제 해결


Configuration Manager 2007 Management Pack의 주별 작업

매일 수행하는 작업 외에도 매주 다음 작업을 수행해야 합니다.

  • 보고서 검토. Configuration Manager 2007 Management Pack에 포함된 보고서 목록은 이 가이드에 있는 Configuration Manager 2007 Management Pack의 보고서 단원을 참조하십시오.
  • 지난 주의 잠재적 문제 및 추세에 대한 경고, 이벤트, 서버 가용성, 구성 변경 및 성능 검토
  • 필요한 경우 Operations Manager 2007 에이전트 하트비트 간격, 경고 설정 및 데이터베이스 그루밍 매개 변수와 같은 Operations Manager 2007 구성 설정 조정
  • Configuration Manager 2007 사이트의 백업 기록 검토
  • Configuration Manager 2007용 Operations Manager 2007 구성 그룹의 백업 기록 검토
  • SQL Server 데이터베이스 및 로그 검토
  • Configuration Manager 2007 가용성 보고서를 실행하여 Configuration Manager 2007 서버 및 해당 역할의 가용성 확인
  • Configuration Manager 2007 사이트 계층 구조 다이어그램을 사용하여 Configuration Manager 2007 계층 구조 확인

참고 항목

개념

Configuration Manager 2007 Management Pack의 일별 작업
Configuration Manager 2007 Management Pack의 월별 작업

기타 리소스

Configuration Manager 2007 Management Pack 문제 해결
Configuration Manager 2007 Management Pack용 참조


Configuration Manager 2007 Management Pack의 월별 작업

매일 및 매주 수행하는 작업 외에도 매월 다음 범주의 데이터를 검토해야 합니다.

  • 알림 구독 및 수신자를 검토합니다. 각 구독에 대해 적절한 그룹 및 클래스가 선택되어 있는지 확인합니다.

가장 일반적인 경고 및 이벤트

  • 가장 일반적인 경고
  • 가장 일반적인 이벤트
  • 컴퓨터 및 클래스별로 가장 일반적인 경고 및 이벤트
  • Configuration Manager 2007 구성 요소별로 가장 일반적인 경고 및 이벤트
  • Configuration Manager 2007 서버 역할별로 가장 일반적인 경고 및 이벤트

이러한 경고 및 이벤트 수를 줄이기 위한 작업 계획을 세워야 합니다.

Configuration Manager 2007 백로그 모니터링

다양한 사이트 시스템의 백로그 추세와 관련된 성능 원시 보고서를 살펴봅니다.

Configuration Manager 2007 백로그 추세

성능 원시 보고서 및 속도 관련 보고서를 검토하여 백로그 수가 오랫동안 증가하는 추세에 있거나 Configuration Manager 2007 사이트 시스템의 SLA(서비스 수준 계약)에 영향을 주는 허용되지 않는 수준의 백로그가 있지 않은지 확인합니다. 검토할 사항은 다음과 같습니다.

  • 검색 데이터 기록
  • 하드웨어 인벤토리
  • 소프트웨어 인벤토리
  • 소프트웨어 미터링
  • 상태 메시지
  • 상황 메시지

일반적인 시스템 성능

서버 시스템 리소스 성능 보고서를 검토하여 다음의 시스템 성능을 검사합니다.

  • 디스크 사용량
  • 메모리 사용량
  • 프로세서 사용량

서버 역할 성능

다음과 같은 각 역할에 대한 원시 및 속도 성능 보고서를 검토합니다.

  • 장치 관리 지점
  • 관리 지점
  • 사이트 서버

Configuration Manager 2007 가용성

Configuration Manager 2007 ‏가용성 보고서를 실행하여 Configuration Manager 2007 서버 및 Configuration Manager 2007 서버 역할의 가용성을 검토합니다.

Configuration Manager 2007 사이트 계층 구조 모니터링

Configuration Manager 사이트 계층 구조에서 에이전트 설치를 검토하고 배포된 서버의 모니터링 적용 범위가 충분한지 확인합니다. 새 Configuration Manager 서버는 아직 MOM 에이전트가 설치되어 있지 않은 상태로 배포되었을 수 있습니다.

참고 항목

개념

Configuration Manager 2007 Management Pack의 일별 작업
Configuration Manager 2007 Management Pack의 주별 작업
Operations Manager 2007과 Configuration Manager 2007 통합

기타 리소스

Configuration Manager 2007 Management Pack의 운영 작업 수행
Configuration Manager 2007 Management Pack용 참조
Configuration Manager 2007 Management Pack 문제 해결


Configuration Manager 2007 Management Pack 문제 해결

다음과 같은 여러 가지 방법으로 제품 문제를 해결할 수 있습니다.

  • Operations Manager 2007이 올바르게 설치되었는지 확인합니다.
  • Operations Manager 2007 구성 설정이 올바른지 확인합니다.
  • 모든 System Center Configuration Manager 2007 시스템이 Operations Management 레지스트리 키로 올바르게 구성되어 있는지 확인합니다.
  • 관리되는 모든 Configuration Manager 2007 공급자 및 Configuration Manager 2007 사이트 서버 컴퓨터에 Operations Manager 2007 에이전트가 설치되어 있으며 해당 컴퓨터가 다른 컴퓨터에 프록시를 통해 연결할 수 있도록 설정되어 있는지 확인합니다.
  • 관리 팩 가져오기가 완료되고 성공되었는지 확인합니다.
  • 규칙 및 모니터와 같은 관련된 모든 항목이 사용하도록 설정되어 있는지 확인합니다.
  • 컴퓨터 그룹이 올바른 컴퓨터로 채워졌는지 확인합니다. 이 검사는 콘솔에서 제작 모드의 그룹 노드를 사용하여 수행할 수 있습니다.
  • 모든 에이전트가 정상적인지 확인합니다.
  • 하트비트 간격이 올바르게 설정되고 Operations Manager 2007 에이전트 컴퓨터에 규칙이 전파되었는지 확인합니다.
  • WMI(Windows Management Instrumentation), World Wide Web Publishing 서비스, IIS(인터넷 정보 서비스) Admin Service, BITS(Background Intelligent Transfer Service), WSUS(Windows Server Update Services), WDS(Windows 배포 서비스 서버), TFTPD(Trivial FTP Daemon) 및 MSSQLServer를 비롯한 종속 서비스가 Configuration Manager 2007 사이트 시스템에 올바르게 설치되어 실행 중인지 확인합니다.
  • 모든 성능 카운터가 올바르게 설치되었는지 확인합니다.
  • 작업 계정이 로컬 시스템이 아닌 다른 항목일 경우 필요한 리소스에 액세스할 수 있는 충분한 권한이 스크립트에 있는지 확인합니다.

이 섹션에서

Configuration Manager 2007 Management Pack의 알려진 문제

참고 항목

개념

Configuration Manager 2007용 Management Pack 모니터링 시나리오

기타 리소스

Configuration Manager 2007 Management Pack 개요
Configuration Manager 2007 Management Pack 배포
Configuration Manager 2007 Management Pack의 운영 작업 수행
Configuration Manager 2007 Management Pack용 참조


Configuration Manager 2007 Management Pack의 알려진 문제

Configuration Manager 2007 Management Pack for Operations Manager 2007에는 다음과 같은 알려진 문제가 있습니다.

WMI 서비스를 중지하는 타사 소프트웨어를 설치할 때 Configuration Manager와 충돌할 수 있다

WMI 모니터링

ConfigMgr 2007 관리자 콘솔이 보조 사이트와 같은 컴퓨터에 설치된 경우 Configuration Manager 2007 Management Pack에서 보조 사이트를 감지할 수 없다

시스템을 다시 시작하면 제한된 경고가 나타난다

Configuration Manager 2007의 Monitor SMS Status Messages 스크립트

Configuration Manager 2007의 Monitor Site Summarizer 스크립트의 실행 간격이 기본 Site System Status Summarizer 간격과 차이가 난다

BITS 모니터링이 기본적으로 사용되지 않는다

응용 프로그램 공급자 경로가 기본적으로 일부 SMS 사이트 서버에서는 유효하지 않을 수 있는 SMS_INSTALL_DIR_PATH%\Logs로 설정된다

발신자 연결을 모니터링하는 상태 메시지 규칙이 발신자 작동에 의존한다

사이트 계층 구조 검색 뷰의 스크립트 오류에서 컴퓨터 이름 대신 설치 경로가 표시된다

사이트 계층 구조 다이어그램을 지원하려면 모든 Configuration Manager 서버에 에이전트가 필요하다

Configuration Manager 2007 상태 뷰에 SMS 2003 작업이 나타난다

WMI 서비스를 중지하는 타사 소프트웨어를 설치할 때 Configuration Manager와 충돌할 수 있다

WMI(Windows Management Instrumentation) 서비스에 액세스하는 타사 소프트웨어를 설치할 때 Configuration Manager 2007 Management Pack과 충돌할 수 있습니다. 대부분의 관리 팩 스크립트는 WMI를 사용하여 레지스트리에 액세스하며 WMI 서비스를 다시 시작할 수 있습니다. WMI 서비스가 사용하도록 설정되어 있고 이를 시작할 수 있으면 COM(구성 요소 개체 모델)에서 아무 문제 없이 WMI를 다시 시작할 수 있습니다.

타사 소프트웨어가 WMI를 중지하지만 설치 또는 업그레이드 중에 WMI를 사용할 수 없게 설정하지는 않을 경우 WMI 스크립트의 자동 재시작 기능은 타사 소프트웨어 설치의 성공 여부에 영향을 줄 수 있습니다. 이로 인해 설치 프로그램에서 먼저 WMI 서비스를 사용할 수 없게 설정하지 않을 경우 WMI 또는 WMI 공급자의 업그레이드에 문제가 발생할 수 있습니다. 이 문제는 WMI의 모든 클라이언트에 해당됩니다.

WMI 모니터링

  • 다음 규칙은 예기치 않은 서비스 오류에 대해 서비스 제어 관리자의 Windows NT® 시스템 이벤트 로그 이벤트를 기반으로 합니다. 이러한 규칙에 대한 알려진 운영 체제 제한은 없습니다.
  • Configuration Manager 2007 종속 서비스 오류: Windows Management Instrumentation이 예기치 않게 종료됨
  • Configuration Manager 2007 종속 서비스 오류: Windows Management Instrumentation이 시작 시 멈춤
  • Configuration Manager 2007 종속 서비스 오류: Windows Management Instrumentation이 시작되지 않음
  • Configuration Manager 2007 종속 서비스 오류: Windows Management Instrumentation이 로그온할 수 없음
  • Configuration Manager 2007 종속 서비스 오류: Windows Management Instrumentation을 실행하는 데 필요한 다른 서비스가 시작되지 않았거나 존재하지 않음

ConfigMgr 2007 관리자 콘솔이 보조 사이트와 같은 컴퓨터에 설치된 경우 Configuration Manager 2007 Management Pack에서 보조 사이트를 감지할 수 없다

Configuration Manager 2007 보조 사이트 서버로도 사용되는 컴퓨터에 Configuration Manager 2007 관리자 콘솔을 설치하면 Configuration Manager 2007 Management Pack에서 해당 서버를 Configuration Manager 2007 보조 사이트 서버로 식별하지 못합니다.

이 문제를 해결하려면 Configuration Manager 2007 보조 사이트 서버에 Configuration Manager 2007 관리자 콘솔을 설치할 때 레지스트리 값 HKLM\SOFTWARE\Microsoft\SMS\Setup\Type을 4에서 2로 변경해야 합니다.

시스템을 다시 시작하면 제한된 경고가 나타난다

시스템이 다시 시작될 경우 단 몇 개의 서비스 중지 경고만 나타날 수 있습니다. 시스템이 다시 시작되었음을 나타내는 이벤트나 경고는 없습니다. 예상한 시스템 종료나 예상치 않은 시스템 종료를 감지하기 위한 최상의 방법은 시스템 재시작 시 경고를 생성하는 규칙이 포함된 Microsoft Windows Server Base Operating System Management Pack을 설치하는 것입니다. 시스템 재시작이 발생했는지 여부를 확인하기 위한 다른 방법은 Configuration Manager 2007 로그, Operations Manager 2007 NT 이벤트 로그, Windows NT 이벤트 로그 및 Operations Manager 2007 이벤트에서 에이전트 통신을 검사하는 것입니다.

Configuration Manager 2007의 Monitor SMS Status Messages 스크립트

Configuration Manager 2007 상태 메시지 표의 메시지 수가 4,294,967,296개를 초과하면 레코드 ID는 0부터 다시 시작됩니다. Configuration Manager 2007의 Monitor SMS Status Messages 스크립트에는 레코드 ID가 0부터 다시 시작될 경우 이를 감지하는 메커니즘이 없습니다. 현재 이 스크립트는 마지막으로 처리한 상태 메시지의 레코드 ID에서 정방향으로만 검색합니다. 따라서 레코드 ID가 다시 시작되면 관리 팩에서 새 상태 메시지를 검색할 수 없습니다.

사이트 서버에서 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER 레지스트리 키의 Next Status Message Record ID 레지스트리 값에 주의하십시오. 이 값은 SQL StatusMessages 테이블에 삽입되는 다음 레코드 ID입니다. 이 값이 LastRecordID 값보다 작으면 StatusMessages 테이블은 다시 순환하고 다시 시작됩니다. 스크립트는 Next Status Message Record ID 레지스트리 값이 VarSet 파일의 LastRecordID 값보다 커질 때까지 메시지를 다시 처리하지 않습니다.

사이트 서버에서 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER 레지스트리 키를 정기적으로 모니터링하여 다음 상태 메시지의 레코드 ID를 확인해야 합니다. 소규모 조직이나 SMS 계층 구조에서 하위에 있는 소규모 사이트에서는 이 레지스트리 키를 두세 달마다 확인해야 합니다. 대규모 조직이나 여러 개의 자식 사이트가 있는 사이트에서는 이 레지스트리 키를 매달 확인해야 합니다. 값이 4,294,967,296에 가까울수록 이 레지스트리 키를 보다 자주 모니터링합니다. 레코드 ID가 0으로 다시 설정된 후에는 사이트 서버를 실행하는 컴퓨터에서 상태 메시지 모니터링을 차단 해제해야 합니다.

레지스트리 키 모니터링을 자동화하는 한 가지 방법은 이 임계값에 근접하는 컴퓨터에 대한 스크립트 또는 검색 규칙을 만드는 것입니다.

구성 그룹의 모든 Configuration Manager 2007 사이트 데이터베이스를 찾으려면 다음 절차를 수행하십시오. 클러스터된 SQL Server를 지원하기 위해 사이트 데이터베이스 서버 역할은 이제 실제로는 사이트 서버의 ConfigMgr에서 검색됩니다.

절차

구성 그룹의 모든 Configuration Manager 2007 사이트 데이터베이스를 찾고 상태 메시지 모니터링 기능을 차단 해제하려면

  1. 운영 콘솔에서 제작 단추를 클릭하고 그룹을 선택합니다.

  2. 결과 창에서 Microsoft ConfigMgr 2007 사이트 데이터베이스 서버 컴퓨터 그룹이 들어 있는 그룹 이름을 검색합니다.

  3. 구성원을 찾을 그룹 이름을 마우스 오른쪽 단추로 클릭하고 그룹 구성원 보기를 선택합니다.

  4. Configuration Manager 2007 사이트 데이터베이스 역할을 호스팅하는 컴퓨터에서 스크립트가 실행되는 사용자 컨텍스트의 TMP 환경 변수로 지정된 경로(로컬 시스템의 경우 Windows Temp 폴더)로 이동하여 ConfigMgr 2007 Monitor SMS Status Messages.SCOM2007.VarSet 텍스트 파일을 엽니다. LastRecordID_[SMSDatabaseName] 항목은 스크립트에서 처리한 SQL StatusMessages 테이블의 마지막 상태 메시지를 나타내는 레코드 ID입니다.

  5. LastRecordID_[SMSDatabaseName] 값을 Next Status Message Record ID 레지스트리 값에서 1을 뺀 값으로 변경합니다. 결과 값이 4,294,967,296이면 해당 값을 0으로 설정하고 파일을 저장합니다.

Configuration Manager 2007의 Monitor Site Summarizer 스크립트의 실행 간격이 기본 Site System Status Summarizer 간격과 차이가 난다

Configuration Manager 2007의 사이트 시스템 요약 작성기 모니터 스크립트가 실행되는 간격은 Site System Status Summarizer 폴링 간격과 매시간 10분씩 차이가 납니다. Configuration Manager 관리자 콘솔을 통해 Site System Status Summarizer 일정을 구성할 수 있지만 이 폴링 간격은 변경할 수 없고 다른 유지 관리 작업의 간격만 변경할 수 있습니다. Configuration Manager의 사이트 시스템 요약 작성기 모니터 스크립트는 60분마다 실행되어 00:10에 동기화됩니다. 10분의 시간차가 있으므로 Site System Status Summarizer가 주기를 완료할 수 있는 시간이 충분합니다. 이 시간이 충분하지 않으면 시간을 늘려야 합니다. 그렇지 않으면 사이트 시스템 요약 작성기가 주기를 완료하기 전에 스크립트가 종료됩니다. 이 경우 이전 사이트 시스템 상태가 보고될 수 있습니다.

BITS 모니터링이 기본적으로 사용되지 않는다

BITS(Background Intelligent Transfer Service) 서비스는 필요할 때 Configuration Manager 2007 클라이언트에서 시작되므로 Configuration Manager Management Pack에서 다음 규칙은 기본적으로 사용하지 않도록 설정되어 있습니다.

  • ConfigMgr 2007 종속 서비스 실행 중: Background Intelligent Transfer Service

서비스가 자동으로 시작되도록 구성된 경우에는 이 규칙을 사용해야 합니다.

BITS 서비스의 문제를 모니터링하고 SMS 에이전트 호스트에서 필요할 때 BITS 서비스를 시작할 수 없는 경우 이를 보고하기 위해 다음 규칙은 기본적으로 사용하도록 설정되어 있습니다.

  • ConfigMgr 2007 서비스 오류: Background Intelligent Transfer Service가 예기치 않게 종료됨
  • ConfigMgr 2007 서비스 오류: Background Intelligent Transfer Service가 시작 시 멈춤
  • ConfigMgr 2007 서비스 오류: Background Intelligent Transfer Service를 시작하지 못함
  • ConfigMgr 2007 서비스 오류: Background Intelligent Transfer Service가 로그온할 수 없음
  • ConfigMgr 2007 서비스 오류: Background Intelligent Transfer Service를 실행하는 데 필요한 다른 서비스가 시작되지 않았거나 존재하지 않음

응용 프로그램 공급자 경로가 기본적으로 일부 SMS 사이트 서버에서는 유효하지 않을 수 있는 SMS_INSTALL_DIR_PATH%\Logs로 설정된다

다음 구성 요소 규칙에는 응용 프로그램 로그가 사용됩니다.

  • ConfigMgr 2007 구성 요소: 발신자가 LAN(표준 보안)을 통해 원격 사이트에 연결할 수 없음
  • ConfigMgr 2007 구성 요소: 발신자가 RAS 연결을 통해 원격 사이트에 연결할 수 없음
  • ConfigMgr 2007 구성 요소: 발신자가 LAN(고급 보안)을 통해 원격 사이트에 연결할 수 없음
  • ConfigMgr 2007 구성 요소: Distribution Manager가 패키지를 처리하지 못함
  • ConfigMgr 2007 구성 요소: CI_Contents 테이블에 SDM 유형의 콘텐츠가 없어서 Distribution Manager가 SMS 패키지를 삽입하지 못함
  • ConfigMgr 2007 구성 요소: Policy Provider가 SMS 사이트 데이터베이스에서 새 소프트웨어 업데이트 정책을 가져오지 못함
  • ConfigMgr 2007 구성 요소: Policy Provider가 새 소프트웨어 업데이트 정책을 만들지 못함
  • ConfigMgr 2007 구성 요소: Policy Provider가 SMS 사이트 데이터베이스에서 새 호환성 정책을 가져오지 못함
  • ConfigMgr 2007 구성 요소: Policy Provider가 새 호환성 정책을 만들지 못함
  • ConfigMgr 2007 구성 요소: Policy Provider가 Hierarchy Manager에 정책 변경 내용을 알리지 못함

이러한 규칙을 적용하려면 사이트를 설치할 때 지정한 설치 경로를 사용하여 사이트 서버에 %SMS_INSTALL_DIR_PATH% 환경 변수를 만들어야 합니다. 환경 변수 경로는 백슬래시로 끝나면 안 됩니다. 또한 발신자가 있는 각 Configuration Manager 2007 서버가 관리되는 컴퓨터여야 합니다.

ConfigMgr 2007 구성 요소: Distribution Manager가 패키지를 처리하지 못함을 제외한 모든 규칙은 기본적으로 사용하도록 설정되어 있습니다.

발신자 연결을 모니터링하는 상태 메시지 규칙이 발신자 작동에 의존한다

발신자가 부모 사이트에 연결할 수 없는 경우 Configuration Manager 계층 구조의 상위로 상태 메시지가 전달되지 않고 관리 팩에서 해당 상태 메시지에 대한 경고를 생성하지 않습니다. 이는 ConfigMgr 2007 Monitor Status Message 스크립트를 실행하지 않는 보조 사이트의 경우에 특히 중요합니다. 발신자 연결을 모니터링하는 다음 상태 메시지 규칙은 발신자 작동에 의존하며 기본적으로 사용할 수 없도록 설정되어 있습니다.

  • ConfigMgr 2007 상태: 발신자가 LAN(표준 보안)을 통해 원격 사이트에 연결할 수 없음
  • ConfigMgr 2007 상태: 발신자가 RAS 연결을 통해 원격 사이트에 연결할 수 없음
  • ConfigMgr 2007 상태: 발신자가 LAN(고급 보안)을 통해 원격 사이트에 연결할 수 없음
참고
이러한 모든 규칙은 기본적으로 사용할 수 없도록 설정되어 있습니다. 이러한 규칙을 사용하려면 각 SMS 사이트 데이터베이스 서버나 최소한 중앙 사이트가 관리되는 컴퓨터여야 합니다.

병렬 모니터링 방법은 Configuration Manager 2007 발신자 로그를 기반으로 하여 제공되었습니다. 이러한 규칙은 기본적으로 사용하도록 설정되어 있습니다. 이러한 규칙을 사용하지 않을 경우 위의 관련 상태 메시지 규칙을 사용하는 것이 좋습니다. 두 규칙 집합을 모두 사용하면 중복 경고가 발생하므로 둘을 모두 사용하지 마십시오. 이러한 이벤트 또는 경고 규칙을 통합하여 활성 상태인 상태 메시지 및 구성 요소 규칙을 모두 처리할 수 있는 방법은 없습니다.

  • ConfigMgr 2007 구성 요소: 발신자가 LAN(표준 보안)을 통해 원격 사이트에 연결할 수 없음
  • ConfigMgr 2007 구성 요소: 발신자가 RAS 연결을 통해 원격 사이트에 연결할 수 없음
  • ConfigMgr 2007 구성 요소: 발신자가 LAN(고급 보안)을 통해 원격 사이트에 연결할 수 없음

이러한 규칙을 적용하려면 사이트를 설치할 때 지정한 설치 경로를 사용하여 사이트 서버에 %SMS_INSTALL_DIR_PATH% 환경 변수를 만들어야 합니다. 환경 변수 경로는 백슬래시로 끝나면 안 됩니다. 또한 발신자가 있는 각 Configuration Manager 서버가 관리되는 컴퓨터여야 합니다. 자세한 내용은 응용 프로그램 공급자 경로가 기본적으로 일부 SMS 사이트 서버에서는 유효하지 않을 수 있는 SMS_INSTALL_DIR_PATH%\Logs로 설정된다를 참조하십시오.

사이트 계층 구조 검색 뷰의 스크립트 오류에서 컴퓨터 이름 대신 설치 경로가 표시된다

ConfigMgr 2007 사이트 계층 구조 검색 스크립트 및 원래 만들어진 규칙의 스크립트 오류를 볼 때 오류를 생성하는 컴퓨터의 설치 클래스는 원본으로 표시됩니다. 오류를 생성하는 컴퓨터의 컴퓨터 이름은 스크립트 오류에 대한 경고 설명 또는 경로의 일부로 표시됩니다.

사이트 계층 구조 다이어그램을 지원하려면 모든 Configuration Manager 서버에 에이전트가 필요하다

사이트 계층 구조 다이어그램이 작동하기 위해서는 사이트 데이터베이스를 호스팅하는 원격 SQL 서버를 포함하여 사이트의 모든 Configuration Manager 서버에 에이전트가 로컬로 설치되어 있어야 합니다. 이는 중앙 사이트, 주 사이트 및 보조 사이트를 포함하여 모니터링되는 모든 사이트에 해당됩니다.

Configuration Manager 2007 상태 뷰에 SMS 2003 작업이 나타난다

System Management Server(SMS) 2003 및 Configuration Manager 2007 Management Pack이 모두 설치되어 있는 경우 SMS 2003 작업은 SMS 서버 클래스 대신 Windows 컴퓨터 클래스를 대상으로 하므로 SMS 2003 작업은 Configuration Manager 2007 상태 뷰에 표시됩니다.

참고 항목

개념

Configuration Manager 2007 Management Pack의 지원되는 구성

기타 리소스

Configuration Manager 2007 Management Pack 문제 해결
Configuration Manager 2007 Management Pack 개요
Configuration Manager 2007 Management Pack용 참조


Configuration Manager 2007 Management Pack용 참조

이 단원에서 소개하는 참조 자료는 Operations Manager 2007 및 Configuration Manager 2007에 대한 지침을 제공합니다.

이 섹션에서

Configuration Manager 2007 Management Pack용 추가 리소스

Configuration Manager 2007 Management Pack의 사이트 및 구성 요소

Configuration Manager 2007 Management Pack의 컴퓨터 그룹

Configuration Manager 2007 Management Pack의 설치 클래스

Configuration Manager 2007 Management Pack의 스크립트

Configuration Manager 2007 Management Pack의 뷰

Configuration Manager 2007 Management Pack의 다이어그램

Configuration Manager 2007 Management Pack의 보고서

참고 항목

개념

Configuration Manager 2007용 Management Pack 모니터링 시나리오

기타 리소스

Configuration Manager 2007 Management Pack 개요
Configuration Manager 2007 Management Pack 배포
Configuration Manager 2007 Management Pack의 운영 작업 수행


Configuration Manager 2007 Management Pack용 추가 리소스

다음은 System Center Configuration Manager 2007 Management Pack에서 사용할 수 있는 리소스입니다.

Microsoft Operations Manager 2007

인터넷에 있는 Operations Manager 2007 핵심 제품 설명서에 액세스하고 System Center Operations Manager 2007에 대한 최신 정보를 보려면 Operations Manager 2007 제품 웹 페이지(http://go.microsoft.com/fwlink/?LinkID=83259)를 참조하십시오.

System Center Configuration Manager 2007

Configuration Manager 2007을 배포하고 사용하는 데 필요한 모든 정보는 핵심 제품 설명서, Configuration Manager 2007 관리자 콘솔 도움말, Configuration Manager 2007 용어집 및 Configuration Manager 2007 Online Library에 제공되어 있습니다. Configuration Manager 2007 Documentation Library 및 Configuration Manager 2007 관리자 콘솔 도움말은 Configuration Manager 2007 관리자 콘솔에서 액세스할 수 있습니다.

Configuration Manager 2007 Online Library

  • Configuration Manager 2007 Documentation Library에서는 Configuration Manager 2007을 배포하고 사용하는 데 필요한 정보를 제공합니다. Documentation Library는 Configuration Manager 2007과 함께 설치됩니다.

웹의 Configuration Manager 2007

  • Configuration Manager 2007에 대한 최신 정보는 Configuration Manager Documentation Library 웹 페이지(http://go.microsoft.com/fwlink/?LinkId=98803)를 참조하십시오.
  • 추가 지원이 필요하면 Configuration Manager 웹 사이트의 지원 섹션(http://go.microsoft.com/fwlink/?LinkId=98800)에 있는 추가 지원 옵션 목록을 참조하십시오.
  • Microsoft 기술 자료 문서 및 기타 기술 리소스에서 SMS 질문에 대한 빠르고 정확한 답을 검색하려면 Microsoft 도움말 및 지원 웹 사이트를 방문하십시오. 문제에 할당된 "Qxxxxxx" 번호나 "xxxxxx" 번호로 기술 자료를 쿼리하여 특정 문제에 대한 문서를 찾을 수 있습니다.

사용자 의견 제공

  • Configuration Manager 2007 설명서 팀에 사용자 의견을 보내 주시면 사용자에게 가장 필요한 제품 정보를 제공하는 데 많은 도움이 됩니다. Configuration Manager 팀에 설명서에 대한 의견을 보내 주십시오.

참고 항목

개념

Configuration Manager 2007 Management Pack의 사이트 및 구성 요소
Configuration Manager 2007 Management Pack의 컴퓨터 그룹
Configuration Manager 2007 Management Pack의 설치 클래스
Configuration Manager 2007 Management Pack의 스크립트
Configuration Manager 2007 Management Pack의 뷰
Configuration Manager 2007 Management Pack의 다이어그램
Configuration Manager 2007 Management Pack의 보고서


Configuration Manager 2007 Management Pack의 사이트 및 구성 요소

System Center Configuration Manager 구성 요소에는 Configuration Manager 중앙 사이트 서버, Configuration Manager 사이트 데이터베이스 및 Configuration Manager 관리자 콘솔이 포함됩니다. 일반적으로 Configuration Manager 중앙 사이트 서버, Configuration Manager 사이트 데이터베이스 및 Configuration Manager 관리자 콘솔은 동일한 서버에 있으며 각 사이트 시스템 역할은 전용 서버에 있습니다. 중앙 사이트 서버 및 데이터베이스는 사이트 시스템 역할과 함께 단일 Configuration Manager 사이트를 구성합니다. 단일 Configuration Manager 사이트에는 중복 사이트 시스템 역할이 여러 개 포함될 수 있습니다. Configuration Manager 2007 사이트는 계층으로 구성될 수 있으며 하나의 Configuration Manager 사이트에 서버 검색 지점과 같은 일부 사이트 서버 역할을 포함하지 못할 수 있습니다.

Configuration Manager 2007 Management Pack은 Configuration Manager 사이트 계층 구조 및 사이트 내의 서버를 모니터링하기 위한 것으로서, Configuration Manager 클라이언트의 Configuration Manager 기능을 모니터링하기 위한 것이 아닙니다. 그러나 Operations Manager 2007을 사용하여 Configuration Manager 클라이언트 컴퓨터에 있는 다른 응용 프로그램을 모니터링할 수도 있습니다.

Configuration Manager 2007 구성 요소에 대한 자세한 내용은 Configuration Manager Online Library를 참조하십시오. Configuration Manager 설명서에 대한 링크는 이 가이드의 Configuration Manager 2007 Management Pack용 추가 리소스 단원을 참조하십시오.

주요 서버 역할에는 다음이 포함됩니다.

  • 배포 지점
  • 관리 지점
  • 서버 검색 지점
  • 보고 지점
  • 소프트웨어 업데이트 지점
  • 사이트 서버
  • 사이트 데이터베이스
  • Configuration Manager 공급자
  • 모바일 장치 관리 지점
  • Configuration Manager 관리자 콘솔
  • 대체 상태 지점
  • PXE 서비스 지점
  • 시스템 상태 검사기 지점
  • 서버 검색 지점
  • 상태 마이그레이션 지점

배포 지점

배포 지점에는 Configuration Manager에서 배포한 소프트웨어 프로그램을 설치할 때 Configuration Manager 클라이언트에서 사용하는 Configuration Manager 패키지 원본 파일이 저장됩니다. Configuration Manager 관리자가 프로그램을 보급할 때 클라이언트에서는 관리 지점을 통해 보급 및 프로그램 정보를 사용할 수 있습니다.

Configuration Manager가 설치될 때 해당 사이트 서버에는 배포 지점 역할이 자동으로 할당됩니다. Configuration Manager 관리자는 배포 지점에서 BITS(Background Intelligent Transfer Service)를 사용할 수 있도록 설정할 수 있습니다. 이렇게 하면 증분 패키지 파일을 클라이언트에 다운로드할 수 있습니다.

클라이언트에서는 BITS를 사용하여 클라이언트 네트워크 연결 용량을 자동으로 감지하고 전송 속도를 효율적으로 조정할 수 있습니다. 이러한 기능은 Microsoft Windows XP Professional, Microsoft Windows Server™ 2003 운영 체제 및 Windows Vista 운영 체제를 실행하는 클라이언트에서만 지원됩니다.

관리 지점

관리 지점은 Configuration Manager 클라이언트와 Configuration Manager 사이트 서버 간의 주 연락 지점입니다. Windows 네트워크 부하 분산 서비스를 사용하여 여러 개의 관리 지점을 구성할 수도 있지만 Configuration Manager 사이트에는 하나의 기본 관리 지점만 있습니다. 관리 지점은 다음과 같은 역할을 합니다.

  • 클라이언트가 설치된 후 클라이언트에 특정 클라이언트 구성 정보를 제공합니다.
  • 클라이언트 컴퓨터에서 보급을 검사하는 위치로 사용됩니다.
  • 클라이언트의 배포 지점을 찾습니다.
  • 클라이언트로부터 인벤토리, 소프트웨어 미터링 및 상태 정보를 받아 Configuration Manager 사이트 서버로 전달합니다.

서버 검색 지점

서버 검색 지점은 Configuration Manager 클라이언트의 관리 지점을 찾습니다. 서버 검색 지점은 대부분 클라이언트를 설치할 때 사용됩니다. 서버 검색 지점은 다음과 같은 역할을 합니다.

  • 클라이언트가 자동 Configuration Manager 사이트 할당에 맞게 구성된 경우 클라이언트의 관리 지점을 찾습니다.
  • 로그온 스크립트를 기반으로 클라이언트를 설치할 때와 충분한 자격 증명 없이 설치할 때 클라이언트에 관리 지점의 위치를 제공합니다.

보고 지점

보고 지점은 IIS(인터넷 정보 서비스)를 실행하는 서버로서 Report Viewer와 추가 보고서의 코드를 호스팅합니다. 보고 지점은 Configuration Manager 사이트 데이터베이스 서버와만 통신합니다.

소프트웨어 업데이트 지점

Configuration Manager 2007의 소프트웨어 업데이트 지점은 소프트웨어 업데이트의 필수 구성 요소로서, Configuration Manager 콘솔에서 사이트 시스템 역할로 설치됩니다. 소프트웨어 업데이트 지점 사이트 시스템 역할은 WSUS(Windows Server Update Services) 3.0이 설치되어 있으며 WSUS 구성 요소와 상호 작용하여 업데이트 설정을 구성하는 사이트 서버에 만들어야만 업스트림 업데이트 서버와의 동기화를 요청하고 WSUS 데이터베이스의 업데이트를 사이트 서버 데이터베이스와 동기화할 수 있습니다.

소프트웨어 업데이트 지점 및 Windows Server Update Services에 대한 모니터링 기능을 사용하도록 설정하려면 다음 절차를 수행하십시오.

소프트웨어 업데이트 지점 및 Windows Server Update Services에 대한 모니터링 기능을 사용하도록 설정하려면

  1. 운영 콘솔에서 제작을 클릭합니다.

  2. 탐색 창에서 제작 > 관리 팩 개체로 이동한 다음 규칙을 클릭합니다.

  3. 규칙 창에서 사용하도록 설정할 규칙을 검색합니다. 찾을 대상 표시줄이 규칙 목록 위에 표시되지 않는 경우 보기로 이동하고 찾기를 클릭합니다.

  4. 사용하도록 설정할 규칙의 규칙 이름을 마우스 오른쪽 단추로 클릭하고 재정의 > 규칙 재정의로 이동한 다음 해당 규칙으로 모니터링할 개체 집합을 클릭합니다.

  5. 사용 속성을 True로 설정하고 사용자 환경에 맞게 임계값을 수정합니다. 확인을 클릭합니다.

사이트 서버

Configuration Manager 설치 프로그램이 성공적으로 실행된 서버에 할당되는 Configuration Manager 사이트 시스템 역할입니다. 즉, Configuration Manager 사이트가 컴퓨터에 설치되면 해당 컴퓨터에는 사이트 서버 역할이 자동으로 할당됩니다. 모든 Configuration Manager 사이트에는 하나의 사이트 서버가 있습니다.

사이트 데이터베이스

Configuration Manager 사이트 데이터베이스(SQL Server 데이터베이스)를 호스팅하는 컴퓨터에 할당되는 Configuration Manager 사이트 시스템 역할입니다.

Configuration Manager 공급자

Configuration Manager 공급자는 Configuration Manager 사이트 데이터베이스의 데이터에 대한 요청을 처리합니다. Configuration Manager 공급자 역할은 Configuration Manager 사이트 서버나 Configuration Manager 사이트 데이터베이스와 같은 컴퓨터에 설치됩니다. 사이트 서버에 Configuration Manager 공급자와 Configuration Manager 사이트 데이터베이스를 모두 설치하는 것이 좋습니다. 그러면 사이트에 설치된 Configuration Manager 관리자 콘솔에서 Configuration Manager 공급자를 통해 데이터에 액세스할 수 있습니다.

모바일 장치 관리 지점

장치 관리 지점은 Configuration Manager 2007 관리 지점 역할에 종속된 사이트 역할입니다. 장치 관리 지점은 Configuration Manager 2007 Windows Mobile 장치 클라이언트에 대한 통신 지점으로서, Configuration Manager 2007 관리 지점과 동일한 컴퓨터에 있어야 합니다.

Configuration Manager 관리자 콘솔

Configuration Manager 2007 관리자 콘솔은 Configuration Manager를 관리하는 데 사용되는 그래픽 사용자 인터페이스입니다. 이 인터페이스에는 Configuration Manager 제품 소프트웨어와 함께 제공되는 Microsoft Management Console(MMC) 스냅인이 사용됩니다. Configuration Manager 관리자 콘솔은 주 사이트 서버를 설치할 때 기본적으로 설치됩니다. 또한 다른 서버나 워크스테이션에도 설치됩니다.

대체 상태 지점

올바르게 설치할 수 없거나, Configuration Manager 2007 사이트에 할당할 수 없거나, 할당된 관리 지점을 찾거나 통신할 수 없는 클라이언트의 상황 메시지를 수집하는 Configuration Manager 사이트 시스템입니다. 상황 메시지는 클라이언트를 성공적으로 설치하고 할당할 때 대체 상태 지점에도 보내집니다.

PXE 서비스 지점

Configuration Manager 2007에서는 PXE 서비스 지점 사이트 역할을 사용하여 운영 체제 배포 프로세스를 시작합니다. PXE 서비스 지점은 네트워크에 있는 Configuration Manager 2007 클라이언트로부터의 PXE 부팅 요청에 응답한 다음 Configuration Manager 2007 인프라와 상호 작용하여 수행할 적절한 배포 작업을 결정할 수 있도록 구성해야 합니다.

시스템 상태 검사기 지점

시스템 상태 검사기 지점은 NPS(네트워크 정책 서버) 역할로 Windows Server 2008에서 실행되는 Configuration Manager 2007 사이트 시스템 역할입니다. Configuration Manager 2007에서 NAP(네트워크 액세스 보호)를 사용하는 경우 NAP 가능 Configuration Manager 클라이언트에서 상태를 검사하여 호환 또는 비호환 클라이언트 상태를 생성하거나 상태를 확인할 수 없게 하는 오류 조건을 생성하려면 시스템 상태 검사기 지점이 필요합니다.

서버 검색 지점

서버 검색 지점은 Configuration Manager 2007 계층 구조에서 인트라넷을 통해 클라이언트 사이트 할당을 완료하는 데 사용되며, 클라이언트가 Active Directory 도메인 서비스를 통해 관리 지점 정보를 찾을 수 없을 때 관리 지점을 쉽게 찾을 수 있도록 해 줍니다. 인트라넷 클라이언트에서는 Active Directory 도메인 서비스를 기본 방법으로 사용하여 사이트 할당을 완료하고 관리 지점을 찾습니다. 그러나 Active Directory 스키마가 Configuration Manager 2007에 맞게 확장되지 않거나 사이트가 Active Directory 도메인 서비스에 게시되지 않은 경우, 또는 클라이언트가 사이트 서버와 동일한 Active Directory 포리스트에 속해 있지 않은 경우 클라이언트는 서버 검색 지점을 사용해야 합니다.

상태 마이그레이션 지점

상태 마이그레이션 지점은 Configuration Manager 2007 Operating System Deployment에서 운영 체제 이미지 배포의 일부로 한 컴퓨터의 사용자 상태 및 설정을 다른 컴퓨터로 마이그레이션할 때 사용됩니다. 상태 마이그레이션 지점을 사용하려면 IIS(인터넷 정보 서비스)를 설치해야 합니다.

참고 항목

개념

Configuration Manager 2007 Management Pack용 추가 리소스
Configuration Manager 2007 Management Pack의 컴퓨터 그룹
Configuration Manager 2007 Management Pack의 설치 클래스
Configuration Manager 2007 Management Pack의 스크립트
Configuration Manager 2007 Management Pack의 뷰
Configuration Manager 2007 Management Pack의 다이어그램
Configuration Manager 2007 Management Pack의 보고서


Configuration Manager 2007 Management Pack의 컴퓨터 그룹

Configuration Manager 2007 Management Pack에서는 다음과 같은 컴퓨터 그룹을 제공합니다.

  • Microsoft ConfigMgr 2007 관리자 콘솔 - 관리자 콘솔이 설치된 ConfigMgr 2007 사이트 시스템, 구성원 서버 또는 워크스테이션입니다.
  • Microsoft ConfigMgr 2007 고급 클라이언트 - 시스템에 설치된 ConfigMgr 2007 고급 클라이언트입니다.
  • Microsoft ConfigMgr 2007 분기 배포 지점 서버 - 분기 배포 지점 서버 역할을 하는 ConfigMgr 2007 클라이언트입니다.
  • Microsoft ConfigMgr 2007 중앙 사이트 서버 - 중앙 사이트 서버 역할을 하는 ConfigMgr 2007 사이트 서버입니다.
  • Microsoft ConfigMgr 2007 클라이언트 - ConfigMgr 2007 클라이언트가 설치된 ConfigMgr 2007 컴퓨터입니다.
  • IIS 기반 Microsoft ConfigMgr 2007 구성 요소 서버 - IIS 서비스를 실행하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • SMS Executive 기반 Microsoft ConfigMgr 2007 구성 요소 서버 - SMS Executive 서비스를 실행하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 장치 관리 지점 서버 - 장치 관리 지점 역할을 하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 배포 지점 서버 - 배포 지점 서버 역할을 하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 대체 상태 지점 서버 - ConfigMgr 대체 상태 지점이 설치된 ConfigMgr 2007 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 관리 지점 서버 - 관리 지점 역할을 하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 주 사이트 서버 - 주 사이트 서버 역할을 하는 ConfigMgr 2007 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 공급자 - ConfigMgr 공급자 역할을 하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 PXE 서버 - Windows 배포 서비스 서버 역할을 하며 ConfigMgr PXE 서비스 지점이 설치된 ConfigMgr 2007 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 보고 지점 서버 - 보고 지점 역할을 하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 보조 사이트 서버 - 보조 사이트 서버 역할을 하는 ConfigMgr 2007 사이트 서버입니다.
  • Microsoft ConfigMgr 2007 서버 검색 지점 서버 - 서버 검색 지점 역할을 하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 서버 - ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 사이트 데이터베이스 서버 - 사이트 데이터베이스 서버 역할을 하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 사이트 서버 - 주 사이트 서버 또는 보조 사이트 서버 역할을 하는 ConfigMgr 2007 사이트 서버입니다.
  • Microsoft ConfigMgr 2007 소프트웨어 업데이트 지점 서버 - Windows Software Update Services 서버 역할을 하며 ConfigMgr 소프트웨어 업데이트 지점이 설치된 ConfigMgr 2007 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 표준 배포 지점 서버 - 표준 배포 지점 서버 역할을 하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 상태 마이그레이션 지점 서버 - ConfigMgr 상태 마이그레이션 지점이 설치된 ConfigMgr 2007 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 시스템 상태 검사기 서버 - 인터넷 인증 서버 역할을 하며 ConfigMgr 시스템 상태 검사기가 설치된 ConfigMgr 2007 사이트 시스템입니다.

참고 항목

개념

Configuration Manager 2007 Management Pack용 추가 리소스
Configuration Manager 2007 Management Pack의 사이트 및 구성 요소
Configuration Manager 2007 Management Pack의 설치 클래스
Configuration Manager 2007 Management Pack의 스크립트
Configuration Manager 2007 Management Pack의 뷰
Configuration Manager 2007 Management Pack의 다이어그램
Configuration Manager 2007 Management Pack의 보고서


Configuration Manager 2007 Management Pack의 설치 클래스

이 단원에서는 규칙, 모니터 등의 대상을 지정하는 데 사용되는 System Center Configuration Manager 2007 Management Pack 내의 설치 클래스를 설명합니다. 또한 Operations Manager 2007 운영 콘솔의 제작을 살펴보고 범위를 관심 있는 특정 클래스로 설정합니다.

  • Microsoft ConfigMgr 2007 관리자 콘솔 - 관리자 콘솔이 설치된 ConfigMgr 2007 사이트 시스템, 구성원 서버 또는 워크스테이션입니다.
  • Microsoft ConfigMgr 2007 고급 클라이언트 - 시스템에 설치된 ConfigMgr 2007 고급 클라이언트입니다.
  • Microsoft ConfigMgr 2007 분기 배포 지점 서버 - 분기 배포 지점 서버 역할을 하는 ConfigMgr 2007 클라이언트입니다.
  • Microsoft ConfigMgr 2007 중앙 사이트 서버 - 중앙 사이트 서버 역할을 하는 ConfigMgr 2007 사이트 서버입니다.
  • Microsoft ConfigMgr 2007 클라이언트 - ConfigMgr 2007 클라이언트가 설치된 ConfigMgr 2007 컴퓨터입니다.
  • IIS 기반 Microsoft ConfigMgr 2007 구성 요소 서버 - IIS 서비스를 실행하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • SMS Executive 기반 Microsoft ConfigMgr 2007 구성 요소 서버 - SMS Executive 서비스를 실행하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 장치 관리 지점 서버 - 장치 관리 지점 역할을 하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 배포 지점 서버 - 배포 지점 서버 역할을 하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 대체 상태 지점 서버 - ConfigMgr 대체 상태 지점이 설치된 ConfigMgr 2007 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 관리 지점 서버 - 관리 지점 역할을 하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 주 사이트 서버 - 주 사이트 서버 역할을 하는 ConfigMgr 2007 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 공급자 - ConfigMgr 공급자 역할을 하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 PXE 서버 - Windows 배포 서비스 서버 역할을 하며 ConfigMgr PXE 서비스 지점이 설치된 ConfigMgr 2007 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 보고 지점 서버 - 보고 지점 역할을 하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 보조 사이트 서버 - 보조 사이트 서버 역할을 하는 ConfigMgr 2007 사이트 서버입니다.
  • Microsoft ConfigMgr 2007 서버 검색 지점 서버 - 서버 검색 지점 역할을 하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 서버 - ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 사이트 데이터베이스 서버 - 사이트 데이터베이스 서버 역할을 하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 사이트 서버 - 주 사이트 서버 또는 보조 사이트 서버 역할을 하는 ConfigMgr 2007 사이트 서버입니다.
  • Microsoft ConfigMgr 2007 소프트웨어 업데이트 지점 서버 - Windows Software Update Services 서버 역할을 하며 ConfigMgr 소프트웨어 업데이트 지점이 설치된 ConfigMgr 2007 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 표준 배포 지점 서버 - 표준 배포 지점 서버 역할을 하는 ConfigMgr 2007 사이트 서버 또는 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 상태 마이그레이션 지점 서버 - ConfigMgr 상태 마이그레이션 지점이 설치된 ConfigMgr 2007 사이트 시스템입니다.
  • Microsoft ConfigMgr 2007 시스템 상태 검사기 서버 - 인터넷 인증 서버 역할을 하며 ConfigMgr 시스템 상태 검사기가 설치된 ConfigMgr 2007 사이트 시스템입니다.

참고 항목

개념

Configuration Manager 2007 Management Pack용 추가 리소스
Configuration Manager 2007 Management Pack의 사이트 및 구성 요소
Configuration Manager 2007 Management Pack의 컴퓨터 그룹
Configuration Manager 2007 Management Pack의 스크립트
Configuration Manager 2007 Management Pack의 뷰
Configuration Manager 2007 Management Pack의 다이어그램
Configuration Manager 2007 Management Pack의 보고서


Configuration Manager 2007 Management Pack의 스크립트

Configuration Manager 2007 Management Pack에는 에이전트에서 자동으로 실행되는 Operations Manager 2007 스크립트와 관리자가 직접 실행해야 하는 스크립트가 포함되어 있습니다. 이 단원에서는 이러한 스크립트에 대한 추가 정보를 설명합니다.

다음 스크립트는 Operations Manager 2007 에이전트에 의해 자동으로 실행됩니다.

  • ConfigMgr 2007 컬렉션 평가 작업 모니터
  • ConfigMgr 2007 구성 요소 상태 모니터
  • ConfigMgr 2007 NLB 관리 지점 상태 모니터
  • ConfigMgr 2007 서버 상태 모니터
  • ConfigMgr 2007 사이트 유지 관리 작업 모니터
  • ConfigMgr 2007 사이트 시스템 요약 작성기 모니터
  • ConfigMgr 2007 SMS Executive 크래시 덤프 모니터
  • ConfigMgr 2007 SMS 수신함 모니터
  • ConfigMgr 2007 SMS 상태 메시지 모니터
  • ConfigMgr 2007 상황 메시지 요약 작업 모니터
  • ConfigMgr 2007 서비스 검색 - 클라이언트
  • ConfigMgr 2007 서비스 검색 - 서버
  • ConfigMgr 2007 사이트 계층 구조 검색

ConfigMgr 2007 SMS 상태 메시지 모니터

Configuration Manager 2007에서 발생하는 많은 문제는 SMS 상태 시스템을 통해 내부적으로 감지되고 보고됩니다. 상태 메시지는 Configuration Manager 2007 관리자의 관심 조건에 따라 Configuration Manager 2007 구성 요소에 의해 발생합니다.

상태 메시지는 Configuration Manager 2007 사이트의 데이터베이스로 전달되고 부모 사이트의 데이터베이스에서 사이트 계층 구조의 상위로도 전달됩니다. 지정한 사이트 데이터베이스의 Configuration Manager 2007 상태 메시지 표를 쿼리하기만 하면 Configuration Manager 2007 상태 시스템을 사이트별로 모니터링할 수 있습니다.

Configuration Manager 2007 관리자에게 가장 중요한 이벤트를 반영하는 상태 메시지 집합을 모니터링하도록 선택한 경우, 이러한 메시지 중 하나가 데이터베이스에서 발견되면 경고가 생성됩니다.

이 스크립트는 다음 작업을 수행합니다.

  • 스크립트가 에이전트 없는 관리되는 모드에서 실행 중인지 확인합니다. 에이전트 없는 관리되는 모드에서 실행 중인 경우 스크립트는 추가 작업을 수행하지 않고 종료됩니다.
  • 전역 변수를 초기화합니다.
  • ConfigMgr 2007 Monitor SMS Status Messages.VarSet 파일에서 모니터링되는 각 Configuration Manager 사이트 데이터베이스에 대해 마지막으로 처리된 상태 메시지의 RecordID를 열고 읽습니다.
  • 로컬 컴퓨터의 각 Configuration Manager 2007 사이트 데이터베이스에서 발견된 상태 메시지를 처리합니다.
  • 모니터링되는 Configuration Manager 2007 사이트 데이터베이스에 대해 마지막으로 처리된 상태 메시지의 RecordID를 ConfigMgr 2007 Monitor SMS Status Messages.SCOM2007.VarSet 파일에 쓰고 해당 파일을 닫습니다.

ConfigMgr 2007 SMS 상태 메시지 모니터 스크립트는 이벤트 ID를 보고되는 해당 SMS 상태 메시지의 ID로 설정하여 이벤트를 발생시킵니다. 다음 표에서는 발생하는 이벤트의 형식을 설명합니다.

ConfigMgr 2007 SMS 상태 메시지 모니터 스크립트에서 발생하는 이벤트 형식

매개 변수 | 설명
EventType | SMS 상태 메시지의 심각도에 따라 성공, 오류, 경고 또는 정보
EventNumber | SMS 상태 메시지 ID
Category | ConfigMgr 사이트 코드
LoggingDomain | 컴퓨터의 리소스 도메인
LoggingComputer | 컴퓨터의 NetBIOS 이름
Parameter1 | 컴퓨터의 NetBIOS 이름
Parameter2 | ConfigMgr 모듈 이름(예: ConfigMgr 서버)
Parameter3 | ConfigMgr 구성 요소 이름
Parameter4 | SMS 메시지 ID
Parameter5 | Win32 오류 코드
Parameter6 | 부모 또는 최상위 사이트 코드
Parameter7 | SMS 상태 메시지 표에 있는 상태 메시지의 RecordID
Description | "A new monitored SMS status message on machine <NetBIOS Name> from component <Component Name> with message ID <Message ID> was found in the site <Site Code> database."

ConfigMgr 2007 SMS 상태 메시지 모니터 스크립트에서는 다음과 같이 상태 메시지 ID 번호 1102를 통해 스크립트 오류도 보고합니다.

EventType= Warning

EventNumber= 1102

Description = The script ConfigMgr 2007 Monitor SMS Status Messages running under processing rule <ScriptProcessingRuleName> encountered a runtime error. The error message will contain the text "Failed to <ErrorDescription>."

모든 ConfigMgr 2007 상태 메시지 모니터링 이벤트 규칙은 "ConfigMgr 2007 상태:"로 시작되며 ConfigMgr 사이트 데이터베이스 서버 클래스와 연결되어 있습니다.

  • ConfigMgr 2007 상태: 메시지 모니터링

ConfigMgr 2007 상태: 메시지 모니터링은 30분마다 스크립트를 실행하여 00:02에 동기화합니다. 요약 정보는 이 규칙의 Knowledge 속성 페이지에서 제공됩니다.

참고
ConfigMgr 2007 상태: 메시지 모니터링은 모니터링되는 표에 많은 양의 기록 데이터가 있는 경우 실행하는 데 오랜 시간이 걸립니다. 이 쿼리를 사용하는 최상의 방법은 상태 메시지를 간결하게 정리하여 쿼리가 너무 오래 실행되지 않도록 하는 것입니다.

  • ConfigMgr 2007 상태: 스크립트 오류

ConfigMgr 2007 상태: 스크립트 오류는 발생할 수 있는 스크립트 오류 이벤트를 모니터링하고 이를 알립니다. 여기에는 모든 스크립트 오류를 보고하는 스크립트 오류 이벤트(번호 1102) 하나만 있습니다. 이 경고를 해결할 수 있는 방법에 대한 정보는 이 규칙의 Knowledge 속성 페이지에서 제공됩니다.

  • ConfigMgr 2007 상태: <status message name>

ConfigMgr 2007 상태: <status message name>은 특정 상태 메시지 이벤트를 모니터링하고 이를 알립니다. 이 경고를 해결할 수 있는 방법에 대한 정보는 이 규칙의 Knowledge 속성 페이지에서 제공됩니다.

모든 경고에는 다음 형식의 이벤트 설명이 있습니다. 여기에서 $Description$은 이벤트 설명입니다.

$Logging Computer$ - "Rule Name". $Description$

ConfigMgr 2007 Monitor SMS Status Messages.VarSet 파일은 사이트에 대해 마지막으로 처리된 상태 메시지의 RecordID를 저장하는 데 사용됩니다. VarSet 파일은 TMP 환경 변수로 지정된 폴더에 있습니다. 탭으로 구분된 다음 형식의 파일입니다.

코드 복사
LastRecordID_DBNameRecordID#

예를 들어 RecordID가 477860인 LastRecordID_SMS_FLA는 SMS_FLA라는 사이트 데이터베이스에서 마지막으로 처리된 RecordID가 477860임을 나타냅니다.

관리 팩을 이전 버전에서 업그레이드하면 ConfigMgr 2007 Monitor SMS Status Messages.VarSet 파일에 다음과 같이 표시됩니다.

코드 복사
LastRecordID476743
LastRecordID_SMS_FLA477860

데이터베이스 이름이 들어 있지 않은 첫 번째 줄은 원래 버전의 상태 메시지 모니터링이 여러 데이터베이스의 모니터링을 지원하지 않음을 나타냅니다. 데이터베이스 이름 SMS_FLA가 들어 있는 두 번째 줄은 현재 버전의 상태 메시지 모니터링이 여러 데이터베이스의 모니터링을 지원함을 나타냅니다.

사이트 데이터베이스가 여러 개인 경우에는 해당하는 데이터베이스를 확인하기가 어려우므로 첫 번째 줄의 데이터를 이용하는 작업은 수행되지 않습니다. 첫 번째 줄의 데이터는 업그레이드 후 새 변경 내용을 평가하고 상태 메시지 모니터링이 올바른 RecordID로 시작되도록 하는 데 중요한 역할을 할 수 있으므로 VarSet 파일에서 제거되지 않습니다. Configuration Manager 2007에서 사이트 데이터베이스에 액세스하는 모든 스크립트는 SQL 클러스터를 지원하기 위해 사이트 서버에서 실행됩니다. 이는 스크립트가 항상 SQL Server에 대해 로컬로 실행되는 SMS 2003에서 변경된 사항입니다. 따라서 Configuration Manager 2007 사이트 데이터베이스 서버의 인스턴스는 Microsoft Configuration Manager 사이트 서버의 검색된 인스턴스와 동일합니다.

ConfigMgr 2007 사이트 시스템 요약 작성기 모니터

사이트 시스템 요약 작성기

Site System Status Summarizer는 정의된 모든 Configuration Manager 2007 사이트 시스템의 상태를 유지 관리하는 SMS Executive 서비스의 구성 요소 스레드로서, 기본적으로 현재 상태에 대해 매시간마다 한 번씩 폴링합니다. 이 폴링 간격은 Configuration Manager 2007 사이트 제어 파일에 정의되어 있습니다. 폴링 간격은 변경하지 않는 것이 좋습니다. 상태는 Configuration Manager 2007 사이트 데이터베이스의 테이블에서 유지 관리됩니다.

사이트 시스템 DownSince 상태

Site System Status Summarizer에서는 각 폴링 주기 도중 사이트 시스템에 연결할 수 없으면 사이트 시스템이 종료된 것으로 간주합니다. 사이트 시스템에 연결할 수 없는 것은 다음 요인 중 하나 때문일 수 있습니다.

  • 사이트 시스템이 켜져 있지 않거나, 네트워크에 연결되어 있지 않거나, 제대로 동작하지 않는 경우
  • 사용할 수 있는 연결이 없어서 ConfigMgr 2007 Site System Status Summarizer가 연결되어 있지 않은 경우
  • ConfigMgr 2007 Site System Status Summarizer에 사이트 시스템에 연결할 수 있는 충분한 액세스 권한이 없는 경우
  • 네트워크 문제로 인해 ConfigMgr 2007 Site System Status Summarizer에서 사이트 시스템에 연결할 수 없는 경우
  • 사이트 시스템의 서비스가 영구적으로 정지된 경우

DownSince 값은 Summarizer_SiteSystem 사이트 데이터베이스 테이블의 열입니다.

다음과 같은 제약 조건이 있습니다.

  • 사이트 시스템 요약 작성기 폴링 간격은 1시간입니다. 이 간격은 Site System Status Summarizer에서 모든 사이트 시스템을 폴링할 수 있는 충분한 시간입니다. 성능상의 이유로 이 간격은 변경할 수 없습니다. Site System Status Summarizer의 시간 제한 간격은 사이트 제어 파일의 Wakeup Interval 속성이 아니라 Startup Schedule 속성에 의해 제어됩니다. 따라서 Wakeup Interval 속성을 기본값 60에서 다른 값으로 변경해도 아무런 효과가 없습니다. 또한 Startup Schedule을 변경해도 아무런 효과가 없습니다. 기본적으로 이 속성은 60분으로 설정되어 있으며 Site System Status Summarizer에서는 Startup Schedule의 설정에 관계없이 매시간마다 한 번씩 사이트 시스템을 폴링합니다.
  • 경고는 2시간 동안 ConfigMgr 2007 사이트 시스템 요약 작성기: 사이트 시스템이 중지되었을 수 있음 이벤트가 두 번 연속으로 발생하는 경우에만 발생합니다. 이는 네트워크가 임시로 정전될 경우를 고려한 것입니다.
  • Configuration Manager 2007은 Site System Status Summarizer에서 모니터링하지 않는 여러 가지 방식으로 사용 불가능 상태가 될 수 있습니다. 예를 들어 Site System Status Summarizer에서는 SMS 서비스가 실행되고 있지 않거나 Configuration Manager 2007 사이트 데이터베이스를 사용할 수 없는 경우에는 SQL Server 서비스가 중지되었을 때와 같이 Configuration Manager를 사용할 수 없는 것으로 간주하지 않습니다.
  • Site System Status Summarizer는 컴퓨터에서 호스팅되는 각 사이트 개체 및 사이트 시스템 역할의 현재 "DownSince" 상태를 데이터베이스의 Site System Status Summarizer 테이블에 기록합니다.

Site System Status Summarizer 모니터링 스크립트는 Site System Status Summarizer 테이블에서 각 사이트 시스템 역할을 검사하고, 사이트 시스템이 중지된 것으로 표시되어 있으면 이벤트를 발생시킵니다. 그런 다음 이 이벤트에 따라 경고가 생성됩니다. 여러 개의 역할에서 여러 개의 경고가 생성될 수 있습니다.

Configuration Manager 2007 배포 지점을 제외한 각 Configuration Manager 2007 서버 역할은 기본적으로 두 개의 Configuration Manager 2007 서버 역할을 구성합니다. 하나는 특정 역할용이고 다른 하나는 Configuration Manager 2007 구성 요소 서버용입니다. 예를 들어 서버 검색 지점과 보고 지점을 모두 호스팅하는 사이트 시스템의 경우 서버가 2시간 이상, 즉 Site System Status Summarizer 폴링 주기를 두 번 이상 거치는 동안 오프라인 상태였으면 Site System Status Summarizer는 이 두 역할과 해당 Configuration Manager 구성 요소 서버 역할을 중지된 것으로 표시합니다.

그러나 경고는 2시간 동안 각 폴링 간격마다 세 개씩(각 서버 역할에 대한 경고 두 개와 두 개의 서버 역할을 호스팅하는 실제 구성 요소 서버에 대한 경고 하나)만 발생합니다.

  • Site System Status Summarizer 폴링 간격(1시간)이 시작된 지 10분 후에 ConfigMgr 2007 사이트 시스템 요약 작성기 모니터 스크립트가 실행되도록 기본적으로 매시간 10분의 차이가 나는 60분 주기가 설정되어 있습니다. Site System Status Summarizer가 해당 주기를 완료하는 데 10분 이상 소요될 경우에는 시간 제한 이벤트 공급자 오프셋을 적절하게 늘려야 합니다. 그렇지 않으면 최근 사이트 시스템 상태 메시지를 잃게 됩니다.

ConfigMgr 2007 SMS Executive 크래시 덤프 모니터 스크립트

이 스크립트는 다음 작업을 수행합니다.

  • 대상 컴퓨터가 에이전트 없는 모드에서 실행되고 있는지 확인합니다. 에이전트 없는 모드에서 실행 중인 경우 스크립트는 추가 작업을 수행하지 않고 종료됩니다. 이 스크립트는 로컬 VarSet 파일을 사용하여 변수를 저장하므로 SMS Executive 서비스를 실행하는 모든 대상 컴퓨터에 Operations Manager 2007 에이전트가 설치되어 있어야 합니다.
  • TMP 환경 변수로 지정된 경로에 있는 로컬 ConfigMgr 2007 Monitor SMS Executive Crash Dumps.SCOM2007.VarSet 파일을 열고 해당 내용을 컬렉션으로 읽어 들입니다. 이 파일이 없더라도 스크립트 오류 이벤트는 발생하지 않습니다. 파일이 있지만 열 수 없으면 스크립트 오류 이벤트가 발생하고 다음과 같은 메시지가 나타납니다.

Failed to load script variables.

  • 마지막으로 확인한 이후에 새 크래시 덤프가 발생했는지 여부를 확인합니다. 새 크래시 덤프가 발생한 경우 스크립트는 이벤트를 발생시켜 새 크래시 덤프를 보고합니다. 스크립트 오류 이벤트를 발생시키기 위해 스크립트는 다음을 수행합니다.
    • 레지스트리의 SMS Identification 키 아래에서 ConfigMgr 설치 디렉터리(레지스트리 값 "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Identification\ Installation Directory")를 확인합니다. 경로를 확인할 수 없으면 스크립트는 다음 텍스트를 표시하는 스크립트 오류 이벤트 메시지를 발생시킨 후 종료됩니다.

Failed to read registry value.

  • 검색한 Configuration Manager 설치 디렉터리에 "\Logs\CrashDumps"를 추가하여 CrashDumps 디렉터리의 전체 경로를 구성합니다.
  • CrashDumps 디렉터리가 있는지 여부를 확인합니다. CrashDumps 디렉터리가 없는 경우 스크립트는 추가 작업을 수행하지 않고 종료됩니다.
  • CrashDump 디렉터리가 있는 경우 VarSet 컬렉션에서 마지막 크래시 덤프 폴더를 만든 날짜를 확인합니다.
  • 새 크래시 덤프가 만들어졌는지 확인하고 최근 크래시 덤프에 대해서만 작업을 수행합니다. 최근 크래시 덤프인지 확인하기 위해 사용 가능한 경우 마지막 크래시 덤프의 저장 폴더가 생성된 날짜가 사용됩니다. 날짜 및 시간을 비교할 때는 폴더 생성 날짜 및 시간이 초 단위로 비교됩니다.
  • 새 크래시 덤프가 발생한 경우나 스크립트가 처음으로 실행된 경우 스크립트는 새 크래시 덤프 폴더 및 경로를 지정하여 이벤트 1710을 생성하고 로그에 기록합니다. 스크립트는 VarSet 컬렉션에 크래시 덤프의 폴더 생성 날짜를 저장합니다.
  • VarSet 컬렉션의 내용을 로컬 ConfigMgr 2007 Monitor SMS Executive Crash Dumps.SCOM2007.VarSet 파일에 쓰고 이 파일을 닫습니다. 이 파일이 없으면 자동으로 만들어집니다. VarSet 변수가 설정되지 않은 경우에는 파일에 해당 항목이 나타나지 않습니다. 파일을 쓸 때 오류가 발생하면 "Failed to save script variables."라는 스크립트 오류 이벤트 메시지가 발생합니다.

ConfigMgr 2007 SMS Executive 크래시 덤프 모니터링 이벤트

ConfigMgr 2007 SMS Executive 크래시 덤프 모니터 스크립트는 아래와 같이 이벤트 1710을 통해 크래시가 발생했음을 보고합니다.

EventType = Error

EventNumber = 1710

Category = SMS Site Code

Description = SMS Executive in site "XXX" has crashed. For details, see crash dump information under <Drive> <ConfigMgrInstallationPath>\Logs\CrashDumps\NewFolder.

ConfigMgr 2007 SMS Executive 크래시 덤프 모니터링 스크립트 오류 이벤트

"SMS 2003 SMS Executive 크래시 덤프 모니터" 스크립트는 이벤트 1102를 통해 런타임 스크립트 오류를 보고합니다.

EventType = Warning

EventNumber = 1102

Description = The script "SMS 2003 Monitor SMS Executive Crash Dumps" running under processing rule SMS 2003 Crash Dumps: Monitoring SMS Executive encountered a runtime error. CrLf "Failed to <Message>." ErrorString

참고 항목

개념

Configuration Manager 2007 Management Pack용 추가 리소스
Configuration Manager 2007 Management Pack의 사이트 및 구성 요소
Configuration Manager 2007 Management Pack의 컴퓨터 그룹
Configuration Manager 2007 Management Pack의 설치 클래스
Configuration Manager 2007 Management Pack의 뷰
Configuration Manager 2007 Management Pack의 다이어그램
Configuration Manager 2007 Management Pack의 보고서


Configuration Manager 2007 Management Pack의 뷰

Configuration Manager 2007 Management Pack에서는 다음과 같은 일반적인 뷰를 제공합니다.

  • 경고
  • 컴퓨터 상태
  • 이벤트
  • 사이트 계층 구조 다이어그램
  • 사이트 계층 구조 상태
  • 사이트 상태
  • 작업 상태
  • 또한 다음과 같은 범주 뷰 폴더를 제공합니다.
  • 일반
  • 성능

일반

  • 최근 72시간 동안 중앙 사이트 서버에서 발생한 경고
  • 최근 72시간 동안 새로 발생한 경고

성능 뷰

특정 컴퓨터에 대한 데이터를 뷰별로 표시하도록 뷰를 구성할 수 있습니다. 관심 있는 컴퓨터에 대한 카운터를 개별적으로 선택하면 복잡한 그래프를 보다 단순하게 표시할 수 있습니다.

백로그\관리 지점 서버

  • 최근 48시간 동안의 DDR 백로그
  • 최근 48시간 동안의 FileCollection 백로그
  • 최근 48시간 동안의 HINV 백로그
  • 최근 48시간 동안의 발신함 ddr.box 백로그
  • 최근 48시간 동안의 발신함 distmgr.box 백로그
  • 최근 48시간 동안의 발신함 hinv.box 백로그
  • 최근 48시간 동안의 발신함 rdr.box 백로그
  • 최근 48시간 동안의 발신함 sinv.box 백로그
  • 최근 48시간 동안의 발신함 stat.box 백로그
  • 최근 48시간 동안의 발신함 statemsg.box 백로그
  • 최근 48시간 동안의 발신함 swm.box 백로그
  • 최근 48시간 동안의 릴레이 백로그
  • 최근 48시간 동안의 SINV 백로그
  • 최근 48시간 동안의 상태 백로그

백로그\PXE 서비스 지점 서버

  • 최근 24시간 동안의 미해결 데이터베이스 요청 수

백로그\SMS Executive 기반 서버

  • 최근 48시간 동안의 발신함 stat.box 백로그
  • 최근 48시간 동안의 발신함 statemsg.box 백로그

백로그\사이트 서버

  • 최근 48시간 동안의 DDR 백로그
  • 최근 48시간 동안의 HINV 백로그
  • 최근 48시간 동안의 수신함 auth/dataldr.box 백로그
  • 최근 48시간 동안의 수신함 auth/ddm.box 백로그
  • 최근 48시간 동안의 수신함 auth/sinv.box 백로그
  • 최근 48시간 동안의 수신함 auth/statesys.box 백로그
  • 최근 48시간 동안의 수신함 ciamgr.box 백로그
  • 최근 48시간 동안의 수신함 ciamgr.box/RETRY.box 백로그
  • 최근 48시간 동안의 수신함 compsumm.box/repl 백로그
  • 최근 48시간 동안의 수신함 dataldr.box 백로그
  • 최근 48시간 동안의 수신함 ddm.box 백로그
  • 최근 48시간 동안의 수신함 despoolr.box/receive 백로그
  • 최근 48시간 동안의 수신함 objmgr.box/INCOMING 백로그
  • 최근 48시간 동안의 수신함 objmgr.box/INCOMING/Retry 백로그
  • 최근 48시간 동안의 수신함 offermgr.box/INCOMING 백로그
  • 최근 48시간 동안의 수신함 offersum.box/repl 백로그
  • 최근 48시간 동안의 수신함 schedule.box/outboxes/LAN 백로그
  • 최근 48시간 동안의 수신함 schedule.box/requests 백로그
  • 최근 48시간 동안의 수신함 sinv.box 백로그
  • 최근 48시간 동안의 수신함 sitestat.box/repl 백로그
  • 최근 48시간 동안의 수신함 statmgr.box/statmsgs 백로그
  • 최근 48시간 동안의 수신함 swmproc.box/usage 백로그
  • 최근 48시간 동안의 수신함 WOLCMGR.box 백로그
  • 최근 48시간 동안의 수신함 WOLCMGR.box/data 백로그
  • 최근 48시간 동안의 Scheduler 작업 백로그
  • 최근 48시간 동안의 Scheduler 보내기 요청 백로그
  • 최근 48시간 동안의 SINV 백로그
  • 최근 48시간 동안의 SWM 백로그
  • 최근 48시간 동안의 보류 중인 총 WOL 요청 수

조건\상태 마이그레이션 지점 서버

  • 최근 1시간 동안의 사용 가능한 총 디스크 공간

조건\시스템 상태 검사기 서버

  • 최근 24시간 동안의 '패치 쿠키가 올바르지 않음' 조건 수
  • 최근 24시간 동안의 '패치 쿠키가 없음' 조건 수
  • 최근 24시간 동안의 '패치 쿠키가 새 쿠키임' 조건 수
  • 최근 24시간 동안의 '패치 쿠키가 Null임' 조건 수
  • 최근 24시간 동안의 '패치 쿠키가 오래됨' 조건 수
  • 최근 24시간 동안의 '패치 쿠키가 동일함' 조건 수
  • 최근 24시간 동안의 '패치가 설치되지 않음' 조건 수
  • 최근 24시간 동안 비활성화된 SMS NAP 클라이언트 에이전트 수
  • 최근 24시간 동안의 'SoH 만료됨(절대 날짜)' 조건 수
  • 최근 24시간 동안의 'SoH 만료됨(TTL)' 조건 수

일반\<서버 유형>

다음 뷰는 관리 지점 서버, PXE 서비스 지점 서버, 사이트 서버, 소프트웨어 업데이트 지점 서버, 상태 마이그레이션 지점 서버 및 시스템 상태 검사기 서버에 사용할 수 있습니다.

  • 최근 48시간 동안의 LogicalDisk
  • 최근 48시간 동안의 메모리
  • 최근 48시간 동안의 프로세서

처리 속도

  • *최근 24시간 동안 ConfigMgr 2007 관리 지점 서버의 모든 메시지 처리 속도
  • *최근 24시간 동안 ConfigMgr 2007 관리 지점 서버의 모든 보고서 처리 속도
  • *최근 24시간 동안 ConfigMgr 2007 사이트 서버의 모든 보고서 처리 속도

처리 속도\관리 지점 서버

  • 최근 24시간 동안의 초당 DDR 수
  • 최근 24시간 동안의 초당 DM 데이터베이스 연결 시도 횟수
  • 최근 24시간 동안의 초당 DM DDR 수
  • 최근 24시간 동안의 초당 DM 검색 변환 요청 수
  • 최근 24시간 동안의 초당 DM DP 위치 수
  • 최근 24시간 동안의 초당 DM 하드웨어 인벤토리 변환 요청 수
  • 최근 24시간 동안의 초당 DM HINV 수
  • 최근 24시간 동안의 초당 DM ISAPI 요청 수
  • 최근 24시간 동안의 초당 DM 컴퓨터 설정 요청 수
  • 최근 24시간 동안의 초당 DM 패키지 버전 요청 수
  • 최근 24시간 동안의 초당 DM SINV 수
  • 최근 24시간 동안의 초당 DM 소프트웨어 정책 본문 요청 수
  • 최근 24시간 동안의 초당 DM 소프트웨어 정책 ID 요청 수
  • 최근 24시간 동안의 초당 DM 상태 수
  • 최근 24시간 동안의 초당 DM 총 설정 요청 수
  • 최근 24시간 동안의 초당 DP 위치 수
  • 최근 24시간 동안의 초당 실패한 SDM 패키지 가져오기 요청 수
  • 최근 24시간 동안의 초당 SDM 패키지 가져오기 요청 수
  • 최근 24시간 동안의 초당 인증 가져오기 요청 수
  • 최근 24시간 동안의 초당 정책 가져오기 요청 수
  • 최근 24시간 동안의 초당 HINV 수
  • 최근 24시간 동안의 초당 ISAPI 요청 수
  • 최근 24시간 동안의 초당 MP 위치 수
  • 최근 24시간 동안의 발신함 ddr.box의 분당 복사된 파일 수
  • 최근 24시간 동안의 발신함 ddr.box의 총 파일 복사 오류 횟수
  • 최근 24시간 동안의 발신함 ddr.box의 복사된 총 파일 수
  • 최근 24시간 동안의 발신함 distmgr.box의 분당 복사된 파일 수
  • 최근 24시간 동안의 발신함 distmgr.box의 총 파일 복사 오류 횟수
  • 최근 24시간 동안의 발신함 distmgr.box의 복사된 총 파일 수
  • 최근 24시간 동안의 발신함 hinv.box의 분당 복사된 파일 수
  • 최근 24시간 동안의 발신함 hinv.box의 총 파일 복사 오류 횟수
  • 최근 24시간 동안의 발신함 hinv.box의 복사된 총 파일 수
  • 최근 24시간 동안의 발신함 rdr.box의 분당 복사된 파일 수
  • 최근 24시간 동안의 발신함 rdr.box의 총 파일 복사 오류 횟수
  • 최근 24시간 동안의 발신함 rdr.box의 복사된 총 파일 수
  • 최근 24시간 동안의 발신함 sinv.box의 분당 복사된 파일 수
  • 최근 24시간 동안의 발신함 sinv.box의 총 파일 복사 오류 횟수
  • 최근 24시간 동안의 발신함 sinv.box의 복사된 총 파일 수
  • 최근 24시간 동안의 발신함 stat.box의 분당 복사된 파일 수
  • 최근 24시간 동안의 발신함 stat.box의 총 파일 복사 오류 횟수
  • 최근 24시간 동안의 발신함 stat.box의 복사된 총 파일 수
  • 최근 24시간 동안의 발신함 statemsg.box의 분당 복사된 파일 수
  • 최근 24시간 동안의 발신함 statemsg.box의 총 파일 복사 오류 횟수
  • 최근 24시간 동안의 발신함 statemsg.box의 복사된 총 파일 수
  • 최근 24시간 동안의 발신함 swm.box의 분당 복사된 파일 수
  • 최근 24시간 동안의 발신함 swm.box의 총 파일 복사 오류 횟수
  • 최근 24시간 동안의 발신함 swm.box의 복사된 총 파일 수
  • 최근 24시간 동안의 초당 PA 요청 수
  • 최근 24시간 동안의 초당 릴레이 보고서 수
  • 최근 24시간 동안의 서버 가용성 DMP 평균 요청 대기 시간
  • 최근 24시간 동안의 서버 가용성 DMP 실패한 요청 수
  • 최근 24시간 동안의 서버 가용성 DMP 성공한 요청 수
  • 최근 24시간 동안의 서버 가용성 DMP 총 요청 수
  • 최근 24시간 동안의 서버 가용성 MP 성공한 요청 수
  • 최근 24시간 동안의 서버 가용성 MP 총 요청 수
  • 최근 24시간 동안의 초당 SINV 수
  • 최근 24시간 동안의 초당 실행된 SP 수
  • 최근 24시간 동안의 초당 처리된 상황 메시지 수
  • 최근 24시간 동안 거부된 상황 메시지 수
  • 최근 24시간 동안의 초당 상태 수
  • 최근 24시간 동안의 총 DDR 수
  • 최근 24시간 동안의 총 DM DDR 수
  • 최근 24시간 동안의 총 DM HINV 수
  • 최근 24시간 동안 디스패치된 총 DM ISAPI 요청 수
  • 최근 24시간 동안 받은 총 DM ISAPI 요청 수
  • 최근 24시간 동안의 총 DM SINV 수
  • 최근 24시간 동안의 총 DM 상태 수
  • 최근 24시간 동안의 실패한 총 SDM 패키지 가져오기 요청 수
  • 최근 24시간 동안의 총 SDM 패키지 가져오기 요청 수
  • 최근 24시간 동안의 총 HINV 수
  • 최근 24시간 동안의 총 릴레이 보고서 수
  • 최근 24시간 동안의 총 SINV 수
  • 최근 24시간 동안 처리된 상황 메시지 수
  • 최근 24시간 동안의 총 상태 수

처리 속도\PXE 서비스 지점 서버

  • 최근 24시간 동안 처리된 데이터베이스 요청 수
  • 최근 24시간 동안의 초당 처리된 데이터베이스 요청 수
  • 최근 24시간 동안 처리된 DHCP 검색 요청 수
  • 최근 24시간 동안의 초당 처리된 DHCP 검색 요청 수
  • 최근 24시간 동안 처리된 PXE 요청 수
  • 최근 24시간 동안의 초당 처리된 PXE 요청 수
  • 최근 24시간 동안의 서버 가용성 PSP 평균 요청 대기 시간
  • 최근 24시간 동안의 서버 가용성 PSP 실패한 요청 수
  • 최근 24시간 동안의 서버 가용성 PSP 성공한 요청 수
  • 최근 24시간 동안의 서버 가용성 PSP 총 요청 수
  • 최근 24시간 동안의 실패한 총 요청 수
  • 최근 24시간 동안의 총 요청 수
  • 최근 24시간 동안의 초당 총 요청 수

처리 속도\SMS Executive 기반 서버

  • 최근 24시간 동안의 발신함 stat.box의 분당 복사된 파일 수
  • 최근 24시간 동안의 발신함 stat.box의 총 파일 복사 오류 횟수
  • 최근 24시간 동안의 발신함 stat.box의 복사된 총 파일 수
  • 최근 24시간 동안의 발신함 statemsg.box의 분당 복사된 파일 수
  • 최근 24시간 동안의 발신함 statemsg.box의 총 파일 복사 오류 횟수
  • 최근 24시간 동안의 발신함 statemsg.box의 복사된 파일 수

처리 속도\사이트 서버

  • 최근 24시간 동안의 분당 평균 업데이트 쓰기 횟수
  • 최근 24시간 동안의 분당 DDR 수
  • 최근 24시간 동안의 분당 HINV 수
  • 최근 24시간 동안의 초당 WOL 패킷 수
  • 최근 24시간 동안의 분당 SINV 수
  • 최근 24시간 동안의 상황 메시지 파일 처리 스레드 수
  • 최근 24시간 동안의 분당 처리된 상황 메시지 파일 수
  • 최근 24시간 동안의 분당 처리된 상황 메시지 레코드 수
  • 최근 24시간 동안의 분당 상태 수
  • 최근 24시간 동안의 분당 SWM 수
  • 최근 24시간 동안 처리된 잘못된 상황 메시지 파일의 총 수
  • 최근 24시간 동안의 총 DDR 수
  • 최근 24시간 동안의 총 HINV 수
  • 최근 24시간 동안 처리된 잘못된 상황 메시지 레코드의 총 수
  • 최근 24시간 동안 실패한 총 WOL 패킷 수
  • 최근 24시간 동안 보낸 총 WOL 패킷 수
  • 최근 24시간 동안의 총 SINV 수
  • 최근 24시간 동안 처리된 총 상황 메시지 파일 수
  • 최근 24시간 동안 중단된 총 상황 메시지 레코드 수
  • 최근 24시간 동안 처리된 총 상황 메시지 레코드 수
  • 최근 24시간 동안의 총 상태 수
  • 최근 24시간 동안의 총 SWM 수
  • 최근 24시간 동안의 총 업데이트 쓰기 횟수

처리 속도\상태 마이그레이션 지점 서버

  • 최근 1시간 동안의 현재 저장 완료된 상태인 클라이언트 수
  • 최근 1시간 동안의 현재 복원 중 상태인 클라이언트 수
  • 최근 1시간 동안의 현재 저장 중 상태인 클라이언트 수
  • 최근 24시간 동안의 서버 가용성 SMP 평균 요청 대기 시간
  • 최근 24시간 동안의 서버 가용성 SMP 실패한 요청 수
  • 최근 24시간 동안의 서버 가용성 SMP 성공한 요청 수
  • 최근 24시간 동안의 서버 가용성 SMP 총 요청 수
  • 최근 1시간 동안 거부된 총 클라이언트 수

처리 속도\시스템 상태 검사기 서버

  • 최근 24시간 동안의 초당 SoH 요청 수
  • 최근 24시간 동안의 총 SoH 요청 수
  • 최근 24시간 동안의 SoH '클라이언트 취약' 응답 수
  • 최근 24시간 동안의 SoH '호환' 응답 수
  • 최근 24시간 동안의 SoH '오류' 응답 수
  • 최근 24시간 동안의 SoH '비호환' 응답 수
  • 최근 24시간 동안의 SoH '서버 취약' 응답 수
  • 최근 24시간 동안의 SoH '알 수 없음' 응답 수

참고 항목

개념

Configuration Manager 2007 Management Pack용 추가 리소스
Configuration Manager 2007 Management Pack의 사이트 및 구성 요소
Configuration Manager 2007 Management Pack의 컴퓨터 그룹
Configuration Manager 2007 Management Pack의 설치 클래스
Configuration Manager 2007 Management Pack의 스크립트
Configuration Manager 2007 Management Pack의 다이어그램
Configuration Manager 2007 Management Pack의 보고서


Configuration Manager 2007 Management Pack의 다이어그램

Configuration Manager 2007 Management Pack에서는 Configuration Manager 2007 사이트 계층 구조에 대한 다이어그램을 제공합니다. 이 다이어그램은 사이트 서버와 사이트 시스템을 표시하고 상황에 맞는 정보로 상호 관계를 보여 줍니다. 이 토폴로지 다이어그램에는 계층 구조, 사이트 등의 논리적 데이터와 사이트 서버, 사이트 시스템 등의 물리적 데이터가 포함됩니다. Configuration Manager 2007 계층 구조는 매우 클 수 있으므로 다이어그램에는 다음과 같은 요구 사항이 있습니다.

  • 모든 중앙 사이트 서버와 해당 SMS 공급자에 로컬로 Operations Manager 2007 에이전트가 설치되어 있어야 합니다.
  • Configuration Manager 사이트 계층 구조의 원하는 수준 수에 따라 하향식으로 모든 주 사이트 서버에 Operations Manager 2007 에이전트를 로컬로 설치합니다.
  • 설치된 각 Operations Manager 2007 에이전트에 대해 프록시를 통한 연결 기능을 사용할 수 있어야 합니다.
  • Configuration Manager 2007 관리자 콘솔을 사용하여 FQDN(정규화된 도메인 이름)을 입력해야 Operations Manager에서 각 서버를 검색할 수 있습니다.
  • Configuration Manager 서버가 검색되어 Configuration Manager 관리자 콘솔의 All Systems 컬렉션에 나타나야 합니다.
  • 서비스 검색을 통해 ConfigMgr 서버 인스턴스가 검색되어야 합니다.

검색은 다음 두 개의 스크립트를 통해 수행됩니다.

  • ConfigMgr 2007 서비스 검색 - 서버
  • ConfigMgr 2007 사이트 계층 구조 검색

서비스 검색에서는 ConfigMgr 서버 클래스의 인스턴스를 검색합니다. 사이트 계층 구조 검색에서는 다음 항목을 검색합니다.

  • 사이트 - 주 사이트의 공급자에서 사이트별로 중앙 사이트, 주 사이트 및 보조 사이트를 검색합니다.
  • 사이트 간 관계
  • 사이트 내의 서버
  • 사이트 서버와 사이트 시스템 간의 관계

다이어그램에서는 검색 데이터가 부분적으로 표시될 수 있으며 전체 데이터는 개체 속성을 통해 볼 수 있습니다. 또한 다이어그램은 .jpeg, .bmp 또는 .png 파일 형식으로 저장할 수 있습니다.

참고 항목

개념

Configuration Manager 2007 Management Pack용 추가 리소스
Configuration Manager 2007 Management Pack의 사이트 및 구성 요소
Configuration Manager 2007 Management Pack의 컴퓨터 그룹
Configuration Manager 2007 Management Pack의 설치 클래스
Configuration Manager 2007 Management Pack의 스크립트
Configuration Manager 2007 Management Pack의 뷰
Configuration Manager 2007 Management Pack의 보고서


Configuration Manager 2007 Management Pack의 보고서

이 단원에서 설명하는 보고서는 Configuration Manager 2007 Management Pack에서 사용할 수 있습니다. 보고 기능은 별도로 설치해야 하는 선택적 Operations Manager 구성 요소입니다. 보고 서버 배포에 대한 자세한 내용은 Operations Manager 2007 제품 웹 페이지(http://go.microsoft.com/fwlink/?LinkID=83259)를 참조하십시오.

Configuration Manager 2007 보고 기능

Configuration Manager 2007 Management Pack에는 다음 세 가지 유형의 보고서가 포함되어 있습니다.

  • 가용성
  • 구성
  • 성능

개체 선택기를 사용하여 보고서의 대상을 그룹이나 개체로 지정합니다. 모든 보고서는 Operations Manager 2007 보고 기능을 사용할 수 있도록 연결되어 있습니다. 내보내기 가능한 7가지 보고서 형식 중에서 선택할 수 있습니다.

가용성 보고서

Configuration Manager 2007 Management Pack의 가용성 보고서는 ConfigMgr 서버 클래스 및 모니터를 대상으로 합니다. 이 보고서는 보고서의 개체 선택기에서 Microsoft.SystemCenter.ConfigurationManager.2007.ServersGroup 그룹 또는 Microsoft.SystemCenter.ConfigurationManager.2007.SMS_Server_Class 개체를 선택하여 실행할 수 있습니다.

서버 가용성

이 보고서는 특정 서버에 있는 모든 엔터티의 집계 상태를 기반으로 하며 System.Health.EntityState의 가용성 상태가 포함됩니다.

배포 지점 가용성

이 보고서는 배포 지점의 가용성 상태를 기반으로 하며 DP 상태 모니터의 정보를 사용합니다.

관리 지점 가용성

이 보고서는 관리 지점의 가용성 상태를 기반으로 하며 MP 상태 모니터의 정보를 사용합니다.

PXE 서비스 지점 가용성

이 보고서는 PXE 서비스 지점의 가용성 상태를 기반으로 하며 PSP 상태 모니터의 정보를 사용합니다.

사이트 서버 가용성

이 보고서는 사이트 서버의 가용성 상태를 기반으로 하며 SS 상태 모니터의 정보를 사용합니다.

소프트웨어 업데이트 지점 가용성

이 보고서는 소프트웨어 업데이트 지점의 가용성 상태를 기반으로 하며 SUP 상태 모니터의 정보를 사용합니다.

시스템 상태 검사기 가용성

이 보고서는 시스템 상태 검사기 지점의 가용성 상태를 기반으로 하며 SHV 상태 모니터의 정보를 사용합니다.

구성 보고서

Configuration Manager 2007 Management Pack에서 사용할 수 있는 구성 보고서는 Configuration Manager 2007 서버 사용자 지정 구성 보고서 하나뿐입니다. 이 보고서에는 다음과 같은 ConfigMgr 서버 클래스 속성이 표시됩니다.

  • 버전(Configuration Manager 2007 제품 버전)
  • 사이트 시스템 유형(사이트 시스템 유형, 서버 유형, 데이터베이스 서버 유형)
  • 구성 요소(사이트 서버, 서버 검색 지점, 배포 지점, 관리 지점, 보고 지점, 데이터베이스 서버, 공급자, 발신자, 클라이언트 액세스 지점)
  • 사이트 코드(SMS 사이트 코드)
  • 서버 유형(중앙, 주, 보조 사이트 서버)
  • 이름(NetBIOS 이름)
  • 데이터베이스 서버 유형(사이트 데이터베이스 서버)

이 보고서는 보고서의 개체 선택기에서 Microsoft.SystemCenter.ConfigurationManager.2007.ServersGroup 그룹 또는 Microsoft.SystemCenter.ConfigurationManager.2007.SMS_Server_Class 개체를 선택하여 실행할 수 있습니다.

성능 보고서

성능 보고서는 주로 Configuration Manager 서버 역할 또는 개체(관리 지점 또는 데이터 검색 기록)에 따라 그룹화됩니다. 이러한 그룹은 원시(합계) 및 속도(초당 또는 분당) 유형으로 세분되므로 값은 보고서 내에서 적절하게 계산됩니다.

보고서 및 해당 성능 카운터는 추세 분석 및 문제 해결이 용이할 수 있도록 이 방식으로 구성되어 있습니다. 개체 보고서는 대개 Configuration Manager 인프라의 문제를 조사할 때 사용되는 반면 서버 역할 보고서는 관리 지점에 대한 문제를 해결하는 데 사용됩니다.

Configuration Manager 2007 서버 성능 그룹 보고서

다음 보고서를 실행하려면 개체 선택기 대상 그룹에 Microsoft.SystemCenter.ConfigurationManager.2007.ServerPerformanceGroup 개체를 선택합니다.

ConfigMgr 2007 DDR(데이터 검색 기록) 속도 성능

이 보고서에는 해당되는 모든 Configuration Manager 2007 서버 역할의 DDR(데이터 검색 기록) 처리 속도가 표시됩니다.

ConfigMgr 2007 성능 측정: 사이트 서버의 DDR 처리 속도 | 처리된 DDR 수/분
ConfigMgr 2007 성능 측정: MP DDR Mgr(총 보고서 수/초) | 총 보고서 수/초
ConfigMgr 2007 성능 측정: DMP의 DDR 처리 속도 | 생성된 검색 보고서 수/초

ConfigMgr 2007 DDR(데이터 검색 기록) 원시 성능

이 보고서에는 해당되는 모든 Configuration Manager 2007 서버 역할에 대해 처리된 DDR 백로그 및 합계가 표시됩니다.

ConfigMgr 2007 성능 측정: 사이트 서버의 DDR 백로그 | 대기열에 들어간 총 DDR(데이터 검색 기록) 속도 표시
ConfigMgr 2007 성능 측정: 사이트 서버의 처리된 총 DDR 수 | 총 보고서 수/초
ConfigMgr 2007 성능 측정: DMP의 DDR 처리 속도 | 생성된 검색 보고서 수/초

ConfigMgr 2007 장치 관리 지점 원시 성능

이 보고서에는 Configuration Manager 2007 장치 관리 지점 서버 역할에 대해 처리된 합계가 표시됩니다.

ConfigMgr 2007 성능 측정: DMP의 처리된 총 DDR 수 | 생성된 총 검색 보고서 수
ConfigMgr 2007 성능 측정: DMP의 처리된 총 HINV 수 | 생성된 총 하드웨어 인벤토리 보고서 수
ConfigMgr 2007 성능 측정: DMP의 처리된 총 SINV 수 | 생성된 총 소프트웨어 인벤토리 보고서 수
ConfigMgr 2007 성능 측정: DMP의 처리된 총 상태 메시지 수 | 발생한 총 상태 메시지 수
ConfigMgr 2007 성능 측정: DMP의 디스패치된 총 ISAPI 요청 수 | 디스패치된 총 메시지 수
ConfigMgr 2007 성능 측정: DMP의 받은 총 ISAPI 요청 수 | 받은 총 메시지 수

ConfigMgr 2007 장치 관리 지점 속도 성능

이 보고서에는 Configuration Manager 2007 장치 관리 지점 서버 역할의 처리 속도가 표시됩니다.

ConfigMgr 2007 성능 측정: DMP 설정 요청 속도 | DMP 설정 요청 수/초
ConfigMgr 2007 성능 측정: DMP의 컴퓨터 설정 요청 속도 | 컴퓨터 설정 요청 수/초
ConfigMgr 2007 성능 측정: DMP의 소프트웨어 정책 ID 요청 속도 | 소프트웨어 정책 ID 요청 수/초
ConfigMgr 2007 성능 측정: DMP의 소프트웨어 정책 본문 요청 속도 | 소프트웨어 정책 본문 요청 수/초
ConfigMgr 2007 성능 측정: DMP의 패키지 버전 요청 속도 | 패키지 버전 요청 수/초
ConfigMgr 2007 성능 측정: DMP의 검색 변환 요청 속도 | 검색 변환 요청 수/초
ConfigMgr 2007 성능 측정: DMP의 하드웨어 인벤토리 변환 요청 속도 | 하드웨어 인벤토리 변환 요청 수/초
ConfigMgr 2007 성능 측정: DMP의 데이터베이스 연결 시도 속도 | 데이터베이스 연결 시도 횟수/초
ConfigMgr 2007 성능 측정: DMP의 DDR 처리 속도 | 생성된 검색 보고서 수/초
ConfigMgr 2007 성능 측정: DMP의 HINV 처리 속도 | 생성된 하드웨어 인벤토리 보고서 수/초
ConfigMgr 2007 성능 측정: DMP의 DP 위치 요청 처리 속도 | 생성된 위치 요청 수/초
ConfigMgr 2007 성능 측정: DMP의 ISAPI 메시지 처리 속도 | 디스패치된 메시지 수/초
ConfigMgr 2007 성능 측정: DMP의 SINV 처리 속도 | 생성된 소프트웨어 인벤토리 보고서 수/초
ConfigMgr 2007 성능 측정: DMP의 상태 처리 속도 | 발생한 상태 메시지 수/초

ConfigMgr 2007 HINV(하드웨어 인벤토리) 속도 성능

이 보고서에는 해당되는 모든 SMS 서버 역할의 HINV(하드웨어 인벤토리) 처리 속도가 표시됩니다.

ConfigMgr 2007 성능 측정: 사이트 서버의 HINV 처리 속도 | 처리된 MIF 수/분
ConfigMgr 2007 성능 측정: MP HINV Mgr(총 보고서 수/초) | 총 보고서 수/초
ConfigMgr 2007 성능 측정: MP HINV Retry Mgr(총 보고서 수/초) | 총 보고서 수/초
ConfigMgr 2007 성능 측정: DMP의 HINV 처리 속도 | 생성된 하드웨어 인벤토리 보고서 수/초

ConfigMgr 2007 HINV(하드웨어 인벤토리) 원시 성능

이 보고서에는 해당되는 모든 Configuration Manager 2007 서버 역할에 대해 처리된 HINV 백로그 및 합계가 표시됩니다.

ConfigMgr 2007 성능 측정: 사이트 서버의 HINV 백로그 | 대기열에 들어간 총 MIF 수
ConfigMgr 2007 성능 측정: 사이트 서버의 처리된 총 HINV 수 | 처리된 총 MIF 수
ConfigMgr 2007 성능 측정: MP HINV 백로그 | 대기 중인 메시지 수
ConfigMgr 2007 성능 측정: MP HINV Mgr(총 보고서 수) | 총 보고서 수
ConfigMgr 2007 성능 측정: DMP의 처리된 총 HINV 수 | 생성된 총 하드웨어 인벤토리 보고서 수

ConfigMgr 2007 관리 지점 속도 성능

이 보고서에는 Configuration Manager 2007 관리 지점 서버 역할의 처리 속도가 표시됩니다.

ConfigMgr 2007 성능 측정: MP Location Mgr(MP 요청 수/초) | MP 요청 수/초
ConfigMgr 2007 성능 측정: MP Location Mgr(DP 요청 수/초) | DP 요청 수/초
ConfigMgr 2007 성능 측정: MP 정책 가져오기(요청 수/초) | 요청 수/초
ConfigMgr 2007 성능 측정: MP 인증 가져오기(요청 수/초) | 요청 수/초
ConfigMgr 2007 성능 측정: MP Policy Mgr(PA 요청 수/초) | PA 요청 수/초
ConfigMgr 2007 성능 측정: MP DAL(실행된 SP 수/초) | 실행된 SP 수/초
ConfigMgr 2007 성능 측정: MP HINV Mgr(총 보고서 수/초) | 총 보고서 수/초
ConfigMgr 2007 성능 측정: MP HINV Retry Mgr(총 보고서 수/초) | 총 보고서 수/초
ConfigMgr 2007 성능 측정: MP SINV Mgr(총 보고서 수/초) | 총 보고서 수/초
ConfigMgr 2007 성능 측정: MP SINV ColFile Mgr(총 보고서 수/초) | 총 보고서 수/초
ConfigMgr 2007 성능 측정: MP Relay Mgr(총 보고서 수/초) | 총 보고서 수/초
ConfigMgr 2007 성능 측정: MP Status Mgr(총 이벤트 수/초) | 총 이벤트 수/초

ConfigMgr 2007 관리 지점 원시 성능

이 보고서에는 Configuration Manager 2007 관리 지점 서버 역할에 대해 처리된 백로그 및 합계가 표시됩니다.

ConfigMgr 2007 성능 측정: MP DDR 백로그 | 대기 중인 메시지 수
ConfigMgr 2007 성능 측정: MP DDR Mgr(총 보고서 수) | 총 보고서 수
ConfigMgr 2007 성능 측정: MP HINV 백로그 | 대기 중인 메시지 수
ConfigMgr 2007 성능 측정: MP HINV Mgr(총 보고서 수) | 총 보고서 수
ConfigMgr 2007 성능 측정: MP 파일 컬렉션 백로그 | 대기 중인 메시지 수
ConfigMgr 2007 성능 측정: MP SINV 백로그 | 대기 중인 메시지 수
ConfigMgr 2007 성능 측정: MP SINV Mgr(총 보고서 수) | 총 보고서 수
ConfigMgr 2007 성능 측정: MP Relay Mgr 백로그 | 대기 중인 메시지 수
ConfigMgr 2007 성능 측정: MP Relay Mgr(총 보고서 수) | 총 보고서 수
ConfigMgr 2007 성능 측정: MP 상태 백로그 | 대기 중인 메시지 수
ConfigMgr 2007 성능 측정: MP Status Mgr(총 이벤트 수) | 총 이벤트 수

ConfigMgr 2007 서버 시스템 리소스 성능

이 보고서에는 Configuration Manager 2007 서버 역할별 시스템 리소스 사용량이 표시됩니다.

ConfigMgr 2007 성능 측정: 메모리 - %사용 중인 커밋된 바이트 | 사용 중인 커밋된 바이트
ConfigMgr 2007 성능 측정: 페이징 파일 - %사용 | % 사용
ConfigMgr 2007 성능 측정: 프로세서 - % 프로세서 시간(_Total) | % 프로세서 시간
ConfigMgr 2007 성능 측정: 프로세스 - % 프로세서 시간(smsexec) | % 프로세서 시간
ConfigMgr 2007 성능 측정: 프로세스 - % 프로세서 시간(ccmexec) | % 프로세서 시간
ConfigMgr 2007 성능 측정: 시스템 - 시스템 가동 시간 | 시스템 가동 시간

ConfigMgr 2007 사이트 서버 원시 성능

이 보고서에는 Configuration Manager 2007 사이트 서버 역할의 처리 속도가 표시됩니다.

ConfigMgr 2007 성능 측정: 사이트 서버의 Scheduler 작업 백로그 | 작업 수
ConfigMgr 2007 성능 측정: 사이트 서버의 Scheduler 보내기 요청 백로그 | 보내기 요청 수
ConfigMgr 2007 성능 측정: SMS Executive 스레드 상태(실행 스레드 수: _Total) | 실행 스레드 수
ConfigMgr 2007 성능 측정: 사이트 서버의 DDR 백로그 | 대기열에 들어간 총 DDR 수
ConfigMgr 2007 성능 측정: 사이트 서버의 처리된 총 DDR 수 | 처리된 총 DDR 수
ConfigMgr 2007 성능 측정: 사이트 서버의 HINV 백로그 | 대기열에 들어간 총 MIF 수
ConfigMgr 2007 성능 측정: 사이트 서버의 처리된 총 HINV 수 | 처리된 총 MIF 수
ConfigMgr 2007 성능 측정: 사이트 서버의 SINV 백로그 | 대기열에 들어간 총 SINV 수
ConfigMgr 2007 성능 측정: 사이트 서버의 처리된 총 SINV 수 | 처리된 총 SINV 수
ConfigMgr 2007 성능 측정: 사이트 서버의 SWM 백로그 | 대기열에 들어간 총 SWM 사용 파일 수
ConfigMgr 2007 성능 측정: 사이트 서버의 처리된 총 SWM 수 | 처리된 총 SWM 사용 파일 수
ConfigMgr 2007 성능 측정: 사이트 서버의 처리된 총 상태 메시지 수 | 받은 상태 메시지 수
ConfigMgr 2007 성능 측정: SMS 상태 시스템의 처리된 총 메시지 레코드 수 | 처리된 총 메시지 레코드 수
ConfigMgr 2007 성능 측정: SMS 상태 시스템의 처리된 잘못된 메시지 레코드 총 수 | 처리된 잘못된 메시지 레코드 총 수
ConfigMgr 2007 성능 측정: SMS 상태 시스템의 중단된 총 메시지 레코드 수 | 중단된 총 메시지 레코드 수
ConfigMgr 2007 성능 측정: SMS 상태 시스템의 처리된 총 메시지 파일 수 | 처리된 총 메시지 파일 수
ConfigMgr 2007 성능 측정: SMS 상태 시스템의 처리된 잘못된 메시지 파일 총 수 | 처리된 잘못된 메시지 파일 총 수
ConfigMgr 2007 성능 측정: SMS 상태 시스템의 메시지 파일 처리 스레드 수 | 메시지 파일 처리 스레드 수
ConfigMgr 2007 성능 측정: SMS Wake On LAN Communication Manager의 보낸 총 패킷 수 | 보낸 총 패킷 수
ConfigMgr 2007 성능 측정: SMS Wake On LAN Communication Manager의 실패한 총 패킷 수 | 실패한 총 패킷 수
ConfigMgr 2007 성능 측정: SMS Wake On LAN Communication Manager의 보류 중인 총 요청 수 | 보류 중인 총 요청 수

ConfigMgr 2007 사이트 서버 속도 성능

이 보고서에는 Configuration Manager 2007 사이트 서버 역할의 처리 속도가 표시됩니다.

ConfigMgr 2007 성능 측정: 사이트 서버의 HINV 처리 속도 | 처리된 MIF 수/분
ConfigMgr 2007 성능 측정: 사이트 서버의 SINV 처리 속도 | 처리된 SINV 수/분
ConfigMgr 2007 성능 측정: 사이트 서버의 SWM 처리 속도 | 처리된 SWM 사용 레코드 수/분
ConfigMgr 2007 성능 측정: 사이트 서버의 상태 처리 속도 | 처리된 상태 메시지 수/초
ConfigMgr 2007 성능 측정: SMS 상태 시스템의 메시지 레코드 처리 속도 | 처리 속도
ConfigMgr 2007 성능 측정: SMS 상태 시스템의 메시지 파일 처리 속도 | 처리된 메시지 파일 수/분
ConfigMgr 2007 성능 측정: SMS Wake On LAN Communication Manager의 초당 패킷 수 | 초당 패킷 수

ConfigMgr 2007 SINV(소프트웨어 인벤토리) 속도 성능

이 보고서에는 해당되는 모든 Configuration Manager 2007 서버 역할의 SINV(소프트웨어 인벤토리) 처리 속도가 표시됩니다.

ConfigMgr 2007 성능 측정: 사이트 서버의 SINV 처리 속도 | 처리된 SINV 수/분
ConfigMgr 2007 성능 측정: MP SINV Mgr(총 보고서 수/초) | 총 보고서 수/초
ConfigMgr 2007 성능 측정: MP SINV ColFile Mgr(총 보고서 수/초) | 총 보고서 수/초
ConfigMgr 2007 성능 측정: DMP의 SINV 처리 속도 | 생성된 소프트웨어 인벤토리 보고서 수/초

ConfigMgr 2007 SINV(소프트웨어 인벤토리) 원시 성능

이 보고서에는 해당되는 모든 Configuration Manager 2007 서버 역할에 대해 처리된 SINV 백로그 및 합계가 표시됩니다.

ConfigMgr 2007 성능 측정: 사이트 서버의 SINV 백로그 | 대기열에 들어간 총 SINV 수
ConfigMgr 2007 성능 측정: 사이트 서버의 처리된 총 SINV 수 | 처리된 총 SINV 수
ConfigMgr 2007 성능 측정: MP FileCollection 백로그 | 대기 중인 메시지 수
ConfigMgr 2007 성능 측정: MP SINV 백로그 | 대기 중인 메시지 수
ConfigMgr 2007 성능 측정: MP SINV Mgr(총 보고서 수) | 총 보고서 수
ConfigMgr 2007 성능 측정: DMP의 처리된 총 SINV 수 | 생성된 총 소프트웨어 인벤토리 보고서 수

ConfigMgr 2007 SWM(소프트웨어 미터링) 원시 성능

이 보고서에는 해당되는 모든 Configuration Manager 2007 서버 역할에 대해 처리된 SWM(소프트웨어 미터링) 백로그 및 합계가 표시됩니다.

ConfigMgr 2007 성능 측정: 사이트 서버의 SWM 백로그 | 대기열에 들어간 총 SWM 사용 파일 수
ConfigMgr 2007 성능 측정: 사이트 서버의 처리된 총 SWM 수 | 처리된 총 SWM 사용 레코드 수
ConfigMgr 2007 성능 측정: MP Relay Mgr 백로그 | 대기 중인 메시지 수
ConfigMgr 2007 성능 측정: MP Relay Mgr(총 보고서 수) | 총 보고서 수

ConfigMgr 2007 SWM(소프트웨어 미터링) 속도 성능

이 보고서에는 해당되는 모든 Configuration Manager 2007 서버 역할의 SWM 처리 속도가 표시됩니다.

ConfigMgr 2007 성능 측정: 사이트 서버의 SWM 처리 속도 | 처리된 SWM 사용 레코드 수/분
ConfigMgr 2007 성능 측정: MP Relay Mgr(총 보고서 수/초) | 총 보고서 수/초

ConfigMgr 2007 상황 메시지 원시 성능

이 보고서에는 해당되는 모든 SMS 서버 역할에 대해 처리된 Configuration Manager 2007 상황 메시지 백로그 및 합계가 표시됩니다.

ConfigMgr 2007 성능 측정: SMS 상태 시스템의 처리된 총 메시지 레코드 수 | 처리된 총 메시지 레코드 수
ConfigMgr 2007 성능 측정: SMS 상태 시스템의 처리된 잘못된 메시지 레코드 총 수 | 처리된 잘못된 메시지 레코드 총 수
ConfigMgr 2007 성능 측정: SMS 상태 시스템의 중단된 총 메시지 레코드 수 | 중단된 총 메시지 레코드 수
ConfigMgr 2007 성능 측정: SMS 상태 시스템의 처리된 총 메시지 파일 수 | 처리된 총 메시지 파일 수
ConfigMgr 2007 성능 측정: SMS 상태 시스템의 처리된 잘못된 메시지 레코드 총 수 | 처리된 잘못된 메시지 파일 총 수
ConfigMgr 2007 성능 측정: SMS 상태 시스템의 메시지 파일 처리 스레드 수 | 메시지 파일 처리 스레드 수
ConfigMgr 2007 성능 측정: MP의 처리된 상황 메시지 수 | 총 메시지 수
ConfigMgr 2007 성능 측정: MP의 거부된 상황 메시지 수 | 거부된 상태 메시지 수

ConfigMgr 2007 상황 메시지 속도 성능

이 보고서에는 해당되는 모든 Configuration Manager 2007 서버 역할의 SMS 상황 메시지 처리 속도가 표시됩니다.

ConfigMgr 2007 성능 측정: SMS 상태 시스템의 메시지 레코드 처리 속도 | 처리된 메시지 레코드 수/분
ConfigMgr 2007 성능 측정: SMS 상태 시스템의 메시지 파일 처리 속도 | 처리된 메시지 파일 수/분
ConfigMgr 2007 성능 측정: MP의 상황 메시지 처리 속도 | 메시지 수/초

ConfigMgr 2007 상태 메시지 원시 성능

이 보고서에는 해당되는 모든 Configuration Manager 2007 서버 역할에 대해 처리된 SMS 상태 메시지 백로그 및 합계가 표시됩니다.

ConfigMgr 2007 성능 측정: 사이트 서버의 처리된 총 상태 메시지 수 | 받은 상태 메시지 수
ConfigMgr 2007 성능 측정: MP 상태 백로그 | 대기 중인 메시지 수
ConfigMgr 2007 성능 측정: MP Status Mgr(총 이벤트 수) | 총 이벤트 수
ConfigMgr 2007 성능 측정: DMP의 처리된 총 상태 메시지 수 | 발생한 총 상태 메시지 수

ConfigMgr 2007 상태 메시지 속도 성능

이 보고서에는 해당되는 모든 Configuration Manager 2007 서버 역할의 SMS 상태 메시지 처리 속도가 표시됩니다.

ConfigMgr 2007 성능 측정: 사이트 서버의 상태 처리 속도 | 처리된 상태 메시지 수/초
ConfigMgr 2007 성능 측정: MP Status Mgr(총 이벤트 수/초) | 총 이벤트 수/초
ConfigMgr 2007 성능 측정: DMP의 상태 처리 속도 | 발생한 상태 메시지 수/초

ConfigMgr 2007 서버 역할 지원 성능

이 보고서에는 Configuration Manager 2007 서버 역할을 지원하는 서비스의 성능이 표시됩니다.

ConfigMgr 2007 성능 측정: 웹 서비스(ISAPI 확장 요청 수/초)

ISAPI 확장 요청 수/초

참고 항목

개념

Configuration Manager 2007 Management Pack용 추가 리소스
Configuration Manager 2007 Management Pack의 사이트 및 구성 요소
Configuration Manager 2007 Management Pack의 컴퓨터 그룹
Configuration Manager 2007 Management Pack의 설치 클래스
Configuration Manager 2007 Management Pack의 스크립트
Configuration Manager 2007 Management Pack의 뷰
Configuration Manager 2007 Management Pack의 다이어그램